102 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.1k Punkte)

Hallo und einen schönen Sonntag

Wer kann mir helfen bei der Erweiterung dieser Formel:

Hoffe, dass ich mich verständlich ausdrücke habe.

Habe vieles probiert bevor ich diese Frage stelle.

Diese Formel steht in Zelle CG5 und sagt aus: In  G1 ist die Nr 1: in CG 5 werden Daten von CG 11 übernommen und bezieht sich nur auf Spieler 1

=WENNFEHLER(WENN($G$1=1;$CG$11;WENN($G$1=4;$CG$11;WENN($G$1=5;$CG$11;WENN($G$1=8;$CG$11;WENN($G$1=9;$CG$11;WENN($G$1=12;$CG$11;WENN($G$1=13;$CG$11;WENN($G$1=16;$CG$11;WENN($G$1=17;$CG$11;WENN($G$1=20;$CG$11;WENN($G$1=21;$CG$11;WENN($G$1=24;$CG$11))))))))))))&" "&$CG$4;"")

Diese Formel steht in Zelle CS5 und sagt aus: In  G1 ist die Nr 1: in CS 5 werden Daten von CG 11 übernommen und bezieht sich nur auf Spieler 2

=WENNFEHLER(WENN($G$1=2;$CG$11;WENN($G$1=3;$CG$11;WENN($G$1=6;$CG$11;WENN($G$1=7;$CG$11;WENN($G$1=10;$CG$11;WENN($G$1=11;$CG$11;WENN($G$1=14;$CG$11;WENN($G$1=15;$CG$11;WENN($G$1=18;$CG$11;WENN($G$1=19;$CG$11;WENN($G$1=22;$CG$11;WENN($G$1=23;$CG$11))))))))))))&" "&$CS$4;"")

Nun zur meiner Erweiterung die ich gerne gemacht hätte aber nicht hinbekomme.

Folgendes: wenn Spieler 2 dran ist, soll die Zelle CG5 leer bleiben und wenn Spieler 1 dran ist, soll Zelle CS5 leer bleiben da hier die Werte von gegen seitig angezeigt werden.

Beispiel: Wenn ich auf Spieler 2 gehe

Spieler

Adde 1  Punktzahl  33                  Rommet 2                   Bei Rommet werden von

Geworfen 108  36                        Geworfen 108        Adde die geworfene Punkte

Rest 193            39                      Rest 193                  auf Rommet übertragen das

                                                                                               Möchte ich verhindern.

                                                                                             

Auf eine Lösung würde ich mich freuen.

Gruß Adde

1 Antwort

0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)
Bearbeitet von addeguddi
Lösung geschafft:

Folgendermaßend bin ich vorgegangen.

Für Spieler 1

1ter Schritt:

Habe In Zelle DO10 folgende Formel erstellt =WENN(UND($CS$10<4;$CG$11);"";CG9)

2ter Schritt: die oben genannte Formel  in Zelle DP10 eingefügt.

In Zelle DV9 Geworfen und in Zelle DW9 Rest eingetragen danach

3ter Schritt:In Zelle DV 10 folgende Formel eingetragen: =$CG$4&" "&$DO$10&" "&" "&"Punkte"&"Geworfen"&" "&"Rest"&" "&$DX$10

4ter Schritt: In ZelleDX10 Wert aus Zelle =CH8 übernommen.

Das Gleiche habe ich dann mit Spieler 2 gemacht und das Ergebnis ist so, das wenn Spieler 1 oder 2 dran ist wird das Ergebnis vom anderen Spieler nicht angezeigt. So wie ich es mir erhofft habe.
zum Schluss das in die Zelle bringen wo das Ergebnis stehen soll hier im Beispiel in CG4 = DV10
Meine Geduld hat sich gelohnt.

Noch etwas wen Spieler 1 dran ist wird in den besagten Zellen Falsch angezeigt. Das kann man unter bedingter Formatierung unter Regeln zum Hervorheben Text ändern
...