347 Aufrufe
Gefragt in HW-Sonstiges von suppnetfan Experte (1k Punkte)
Hallo,

ich nutze immer noch einen Uralt-Terminkalender Casio SF4900er. Alle paar Wochen sicher ich die Daten auf einem PC mittels Xlink-Win. Unter Win7 funktionierte dies einwandfrei, mit Win10 habe ich noch Probleme Nun habe ich es erstmals auf einem Laptop mit Win10-Home probiert und erhielt die Meldung, dass keine Comports vorhanden sein.

Siehe: https://www.directupload.net/file/d/5778/k2key33s_jpg.htm

(rechts unten: Com1 ... Com4 not available)

Frage: wie kann ich die Comports wieder aktivieren?

Für Tipps: danke im Voraus!

12 Antworten

+1 Punkt
Beantwortet von computerschrat Profi (24.6k Punkte)
Hast du den passenden Treiber für den Terminkalender gefunden und installiert?

Gruß computerschrat
+1 Punkt
Beantwortet von flupo Profi (15.5k Punkte)

Es nützt nichts, nach der Software zu gucken, wenn die Ports auf der Hardware-Seite fehlen. Wenn dein Rechner/Laptop noch Com-Anschlüsse hat, sollten sie sich auch im Gerätemanager (Anschlüsse) finden lassen.

Beim Rechner könnte auch ein Blick ins Innere helfen, denn die Ports sind manchmal nur als Steckkontakt auf dem Board, der aber nicht mit einem Anschluss auf der Rückseite verbunden ist, vorhanden.

Falls nichts da ist könnte ein passender USB-Adapter helfen.

Z.B. der hier

Gruß Flupo

0 Punkte
Beantwortet von

@Flupo: danke für die Erläuterungen.

"Wenn dein Rechner/Laptop noch Com-Anschlüsse hat, sollten sie sich auch im Gerätemanager (Anschlüsse) finden lassen." 

-> anscheinend habe ich es überhaupt nicht mit bekommen, dass moderne Computer keine (oder kaum noch) Com-Ports mehr haben? Habe gerade mal bei meinem PC nachgeschaut. Dort ist auch nur noch vermerkt: "Kommunikationsanschluss Com1"

0 Punkte
Beantwortet von suppnetfan Experte (1k Punkte)

@computerschrat: danke für den Hinweis. Kann mich erinnern, dass ich vor 2 oder 3 Jahren schon mal an dem Punkt gescheitert bin. Unter Win7 funktionierte die Datenübertragung, unter Win10 bekomme ich immer "Übertragungsfehler", obwohl ich die neueste und für Win10 geeignet Version des xlinkwin32.exe von imsl-software downgeloadet habe (die Lizenz hatte ich auch mal gekauft). 

Im Gerätemanager habe ich ein gelbes Rufzeichen bei "Prolific Usb-to-serial comm port (Com4)". Seinerzeit hatte ich mir mal notiert: http://www.mikrocontroller.net/topic/273964

Aber das brachte und bringt mich auch nicht weiter. Anscheinend gibt es keinen funktionsfähigen Prolific-Treiber für Win10. Hier http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=225&pcid=41 blicke ich überhaupt nicht durch.

0 Punkte
Beantwortet von suppnetfan Experte (1k Punkte)
Also, Adapter habe ich ja. Damit verbinde ich ja den Casio SF4900er Terminkalender mit dem USB_Anschluss am PC. Das Problem scheint eher softwaremässig zu sein
0 Punkte
Beantwortet von vadderloewe Mitglied (243 Punkte)
Auch mit Sofware CD ?
+1 Punkt
Beantwortet von

Danke euch für die Hinweise. Die von flupo und vadder verlinkten Adapter schauen optisch genauso aus wie der, den ich benutze: https://www.directupload.net/file/d/5781/s2hts5n9_jpg.htm

und den ich dann mit dem Kabel von dem Casio verbinde.

Bei dem Adapater

https://www.ebay.de/itm/USB-to-RS232-Serial-Port-DB9-9-Pin-Male-COM-Port-Converter-Adapter-Cable-KQ/184205566707?hash=item2ae381e2f3:g:r-gAAOSwwFlckzi3

ist weiter unten unter Description nur "Compatible with: Windows 98/SE/ME/2000/XP/Vista/7/8"

vermerkt. Ob auf der Software-CD trotzdem der richtige Treiber für Win10 wäre?

0 Punkte
Beantwortet von suppnetfan Experte (1k Punkte)
Wahrscheinlich habe ich auch noch ein Verständnis-Problem,was die Comports anbelangt:

Der Gerätemanager

https://www.directupload.net/file/d/5781/hl9rdlw6_jpg.htm

zeigt mir den Com1 an. Dann, je nachdem an welchem Usb-Anschluss ich einstecke, kommt "Prolific USB-to-Serial Comm Port (Com4)" bis Com11

Das Xlinkwin-Programm wiederum

https://www.directupload.net/file/d/5781/656malef_jpg.htm

zeigt Com1 Status ok. Aber Com4 not available.

Liegt dies an dem (mutmasslich) falschen Prolific-Treiber?
+1 Punkt
Beantwortet von flupo Profi (15.5k Punkte)

Welche Nummer ein COM-Port hat, ist eher zweitrangig. Wichtiger sind die zugewiesenen Ressourcen wie die Hardware-Adresse und der Interrupt. Oft werden die Nummern der COM-Ports gleichbedeutend mit den folgenden Adressen verwendet:

Danach sieht es auch in deinem Terminal-Programm aus.

Welche Adresse dein Stick benutzt, kannst du im Gerätemanager, wahrscheinlich auf der Registerkarte "Port Settings", herausfinden.

Wenn hier die Hardware-Adresse (E/A-Bereich) 03F8 - 03FF steht, gibt es sehr wahrscheinlich einen Konflikt mit dem anderen COM1-Port (darauf könnte das gelbe Dreieck hindeuten). Da du den Stick nutzen willst, kannst du in diesem Fall den anderen Port per Rechtsklick deaktivieren oder im Treiber/Programm des Sticks eine andere Adresse einstellen.

Je nach eingestelltem Wert (das muss dann im Gerätemanager auch so ohne Fehlermeldung angezeigt werden) konfigurierst du dein Terminal-Programm.

Gruß Flupo

...