44 Aufrufe
Gefragt in Windows 10 von
Vor Kurzem habe ich mir ein NAS (Selbstbau; Netzwerk ist Gigabit) zugelegt und neben zwei anderen Platten auch meine Festplatte, die ich als Speicherort verwende, hinein verbaut. Nun habe ich aber das Problem, dass alle paar Minuten Windows nicht mehr auf Eingaben reagiert. Das Problem tritt, wie es scheint, aber immer nur auf, wenn ich Dateien auf diese Platte lade und entpacke. Eine zusätzliche Firewall ist nicht mehr installiert, Antivirenprogramme ebensowenig.

Kann ich da etwas machen?

Gruß
Paul

6 Antworten

0 Punkte
Beantwortet von computerschrat Profi (24.1k Punkte)
Hallo Paul,

häufiges Problem beim Zugriff auf solche Laufwerke ist, dass sie sich nach einer definierten Zeit ohne Zugriffe in den Ruhezustand begeben. Bei erneutem Zugriff muss das Laufwerk erst wieder hochfahren, was bei Festplatten wegen der rotierenden Scheiben einige Sekunden dauern kann. In der Zeit wartet Windows auf das Laufwerk und wirkt wie eingefroren. Dagegen kannst du möglicherweise etwas tun, indem das NAS nicht in den Ruhezustand geht.

Andere Ideen zum Problemhintergrund sind nur mit Kenntnis des NAS-Aufbaus zu Netzanbindung, Controllertyp möglich, aber dazu hast du nichts gesagt.

Gruß computerschrat
0 Punkte
Beantwortet von

Wie ich bereits erwähnte, passiert das während des Herunterladens und Entpackens von Dateien, da kann es wohl nicht der Ruhezustand sein. Das NAS ist immer im Betrieb, einen Spindown der Festplatten habe ich (noch) nicht konfiguriert.

Zum NAS
Board: ASRock J5005-ITX (LAN: Realtek RTL8111H)
RAM: Crucial 16GB DDR4-2400 CL17 SO-DIMM
HDD: 2x 8TB WD, 1x 3TB Toshiba, 1x 4TB Toshiba (besagtes Speicherlaufwerk)
SSD (für das OS und Docker-Container): Crucial MX500 CT250MX500SSD4 250GB M.2 über USB 3.0 Adapter
Netzteil: be quiet! Pure Power 11 350W
GPU: NVIDIA Quadro P400
OS: OpenMediaVault (Debian Buster)

Zum Aufbau des Netzwerkes (Gigabit-LAN)
Der PC und das NAS ist mit einem Switch (NETGEAR GS305) mit dem Router verbunden. Da noch eine andere Haushälfte mit am Netzwerk hängt, ist noch ein NETGEAR GS305 mit dem Router verbunden.

Gruß
Paul

0 Punkte
Beantwortet von computerschrat Profi (24.1k Punkte)
Mir war beim Lesen der Frage nicht klar, ob das während des laufenden Kopiervorgangs passiert, oder bei dessen Start.

Du schreibst, das passiert alle paar Minuten wenn du Daten kopierst und entpackst. Läuft der Kopier-/ Entpackvorgang über viele Minuten, so dass es innerhalb eines solchen Prozesses zu mehreren Hängern kommt?

Welches System übernimmt das Entpacken? Windows oder Linux?

Was sagen denn die Taskmanager der beiden Systeme, während Windows eingefroren ist?

Gruß computerschrat
0 Punkte
Beantwortet von
Es wird ständig auf die Platte geladen, anschließend entpackt und währenddessen schon wieder geladen.
Und ja, es kommt innerhalb dieses Prozesses zu mehreren Hängern. Das Entpacken übernimmt Windows.

Ich habe das Problem aber auch schon bei normalen Kopiervorgängen beobachten können.

Den Taskmanager kann ich nicht aufrufen, es funktioniert ja keine Eingabe. Vermutlich sollte ich diesen aber mal geöffnet halten.

Gruß
Paul
0 Punkte
Beantwortet von computerschrat Profi (24.1k Punkte)
Den Taskmanager musst du auch vor Beginn der Aktion starten, damit du die Auslastung im Ruhezustand, im noch laufenden Vorgang und bei eingefrorenem Rechner beobachten kannst.

Wenn Windows das Entpacken nach dem Übertragen an das NAS übernimmt, kann natürlich auch ein Bandbreitenproblem des Netzwerks dazukommen. Du kopierst eine gepackte Datei auf das NAS, dann holst du die gepackte Datei zum Entpacken wieder zum Windows PC, der entpackt sie und schickt sie dann entpackt wieder zum NAS. Also geht, je nach Kompressionsverhältnis des Packers etwas das 3,5-fache Volumen der gepackten Datei durch das Netz. Da es offensichtlich mehrere parallel laufende Vorgänge dieser Art gibt, wäre es wirklich interessant, die Netzwerkauslastung zu beobachten.

Gruß computerschrat
0 Punkte
Beantwortet von
Danke für deine Hilfe, ich werde mich jetzt mal auf ausführliche Ursachenforschung begeben.

Gruß
Paul
...