46 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.1k Punkte)

Hallo ich schon wieder,

es geht nochmals um meine Dart Tabelle.

Folgendes möchte ich gerne erreichen.

Habe in VBA einen Befehl der die gesamte Punktzahl nach jedem dritten Wurf anzeigt, und nach ein paar Sekunden wieder ausgeblendet wird. Dies möchte ich jetzt gerne erweitern, dass in den Zellen in denen die einzelnen Punkte angezeigt werden nach jedem dritten wirf Bzw.  wenn die Punktzahl 301 oder 501 erreicht ist, auch nach ein paar Sekunden ausgeblendet werden.

Die Punktzahl für jeden Wurf erscheint in den Zellen ID2, IE2 und IF2 und diese werden durch eine Formel eingefügt.

Sie lautet für ID2:

=WENNFEHLER(VERWEIS(2;1/(INDIREKT(ADRESSE(19;$G$1+10+($G$1-1)*2)):INDIREKT(ADRESSE(28;$G$1+10+($G$1-1)*2))<>"");INDIREKT(ADRESSE(19;$G$1+10+($G$1-1)*2)):INDIREKT(ADRESSE(28;$G$1+10+($G$1-1)*2)));"")

IE2:

 =WENNFEHLER(VERWEIS(2;1/(INDIREKT(ADRESSE(19;$G$1+11+($G$1-1)*2)):INDIREKT(ADRESSE(28;$G$1+11+($G$1-1)*2))<>"");INDIREKT(ADRESSE(19;$G$1+11+($G$1-1)*2)):INDIREKT(ADRESSE(28;$G$1+11+($G$1-1)*2)));"")

IF2:

=WENNFEHLER(VERWEIS(2;1/(INDIREKT(ADRESSE(19;$G$1+12+($G$1-1)*2)):INDIREKT(ADRESSE(28;$G$1+12+($G$1-1)*2))<>"");INDIREKT(ADRESSE(19;$G$1+12+($G$1-1)*2)):INDIREKT(ADRESSE(28;$G$1+12+($G$1-1)*2)));"")

Die gesamte Punktzahl für 3 Würfe wird in der Zelle CH4 eingeblendet und erlischt nach 5 Sekunden..

Hier ist die Eingabe  vom Makro für das Ausbleneden:

'prüfen ob Anzahl der Würfe ohne Rest durch 3 Teilbar ist oder Checkout vorliegt

  If Cells(lngSZeile, lngWSpalte).Value Mod 3 = 0 And Cells(1, lngSpalte).Value <> "Checkout" Then

   'Anzeige

    Range("CH4") = "Geworfen: " & Cells(arrRueck(3), arrRueck(4)).Value + Cells(arrRueck(3), arrRueck(4) - 2) + Cells(arrRueck(3), arrRueck(4) - 1) & vbLf & "Rest: " & Cells(6, arrRueck(4) - 2).Value

    lngAnsage = Cells(lngWZeile, lngSpalte + Cells(lngSZeile, lngWSpalte).Value - 1) + Cells(lngWZeile, lngSpalte + Cells(lngSZeile, lngWSpalte).Value - 2) + Cells(lngWZeile, lngSpalte + Cells(lngSZeile, lngWSpalte).Value - 3)

    Start_Ansage (lngAnsage)

    'Anzeige nach 5 Sekunden wieder löschen

    Application.Wait Now + TimeValue("00:00:5")

    Range("CH4") = ""

  End If

End If

Habe versucht bei Range die Zellen ID2:IF2 einzugeben aber das funktioniert leider nicht.

Hoffe für mich, dass mir jemand dabei helfen kann.

Gruß Adde

Hier ist die Datei

https://filehorst.de/d/djabsfaf

1 Antwort

0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)
Hallo an das Forum habe eine Lösung gefunden.

Je nach Gebrauch kann man das erweitern und nach seinen Bedürfnissen erstellen.

Wert wird angezeigt und nach Klick wird dieser ausgeblendet und der neue Wert wird angezeigt.

Folgende Formel habe ich dazu erstellt.

=WENN($L$5=1;$II$21;"")&WENN($L$5=4;$II$21;"")&WENN($L$5=7;$II$21;"")&WENN($L$5=10;$II$21;"")&WENN($L$5=13;$II$21;"")&WENN($L$5=16;II21;"")&WENN(L5=19;II21;"")&WENN(L5=22;II21;"")&WENN($R$5=1;$II$21;"")&WENN($R$5=4;$II$21;"")&WENN($R$5=7;$II$21;"")&WENN($R$5=10;$II$21;"")&WENN($R$5=13;$II$21;"")&WENN($R$5=16;II21;"")&WENN(R5=19;II21;"")&WENN(R5=22;II21;"")

Gruß Adde
...