103 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.1k Punkte)

Hallo

Wer kann mir bitte helfen.

Ich verstehe nicht warum bei dieser Formel der Wert von einer Zelle mit der einer anderen Zelle als Ergebnis angezeigt wird. Die gelbmarkierten Formeln werden als eine angezeigt. Normalerweise müsste die Zelle in dem dick umranden Zahlen für sich alleine die 1 dann 22 und 4 stehen aber es erscheint 1224. Wenn es was mit dem & zu tun hat wie kann ich die Formel verändern, so dass jede Zahl für sich erscheint?

Bei den 2, davorliegenden Zellen mit der gleichen Formel funktioniert es. Anderen Bezug.

=WENN($L$5=3;k$19;"")&WENN($L$5=6;k$20;""…………..

=WENN($L$5=3;M$19;"")&WENN($L$5=6;M$20;"")&WENN($L$5=9;M$21;"")&WENN($L$5=12;M$22;"")&WENN($L$5=15;M$23;"")&WENN($L$5=18;M$24;"")&WENN($L$5=21;M$25;"")&WENN($L$5=24;M$26;"")&WENN($O$5=3;P$19;"")&WENN($O$5=6;P$20;"")&WENN($O$5=9;P$21;"")&WENN($O$5=12;P$22;"")&WENN($O$5=15;P$23;"")&WENN($O$5=18;P$24;"")&WENN($O$5=20;P$25;"")&WENN($O$5=24;P$26;"")&WENN($R$5=3;S$19;"")&WENN($R$5=6;S$20;"")&WENN($R$5=9;S$21;"")&WENN($R$5=12;S$22;"")&WENN($R$5=15;S$23;"")&WENN($R$5=18;S$24;"")&WENN($R$5=21;S$25;"")&WENN($R$5=24;S$26;"")

Für HILFE wäre ich sehr dankbar.

Gruß Adde

3 Antworten

0 Punkte
Beantwortet von computerschrat Profi (24.6k Punkte)
Hallo Adde,

ich sehe in deiner Formel nur eine Aneinanderreihung von Abfragen, die jeweils eine Zeleninhalt oder einen Leerstrin hinterlassen. Ihc sehe aber nirgendwo ein Leerzeichen, das die einzelnen Zellinhalte voneinander trennt.

Nur Als Beispiel der Anfang deiner Formel:

WENN($L$5=24;M$26;"")&WENN($O$5=3;P$19;"")

Vorausgesetzt beide Bedingungen werden erfüllt, steht da als Ergebnis der Inhalt von M$26 und P$19 direkt hintereinander. Wenn da ein Leerzeichen dazwischen soll, musst Du es noch ergänzen..

Falls das in einer anderen Zeile funktioniert, steht in den Zellen M.. und P.. das Leerzeichen vielleicht als Inhalt drin und wird dann in das Ergebnis mit hinein kopiert.

Gruß computerschrat
0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)
Hallo Computerschrat,

vorab erst einmal Danke für dein Feedback.

Wie du schon gesehen hast werden die Werte aus den Zellen K19 bis P50 geholt.Bei dieser Tabelle handelt es sich um ein Dartspiel. Beginnend mit Spieler 1 . wenn ich hier für den ersten Wurf den Wert eingebe bleibt er sichtbar nach dem zweiten Wurf wird der erste Wurf durch "" ausgeblendet und der Wert des zweiten Wurfes angezeigt und das wiederholt sich für jeden Wurf. Dies funktioniert für Spieler 1 ohne Probleme. Zur besseren Verständigung. Für Spieler 1 Werden die Werte Aus Zelle K19 bis M50 übernommen für Spieler 2 N19 bis P50 usw. das, so wie ich es mir vorgestellt habe. Diese Werte werden in den Zellen ID2 bis IF2 übernommen.Jetzt kommt das eigentliche Problem, wenn ich auf Spieler 2 gehe zeigt er mir in der Letzten Zell;also in IF den Wert von Spieler 1 an, müsste eigentlich leer sein. Wenn ich nun für Spieler zwei den 1ten Wurf eingebe bleibt der Wert stehen bis zur Eingabe des zweiten Wurfes und wenn ich nun den dritten Wurf eingebe zeigt er mir vom ersten Spieler den letzten und vom zweiten Spieler den Wert an. Beispiel Sp.1 24 Sp.2 34 erscheint in IF2 die Zahl 2434 sollte nur 34 stehen und wenn ich den 3 Spieler nehme steht dann 112434. Ich weis nicht wie ich das bewältigen kann.

Vielleicht hast du eine Lösung für mich.

Wenn du möchtest, kann ich dir auch die Datei hochladen, damit du das vielleicht besser nachvollziehen kannst.

Gruß Adde
0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)
Hallo Computerschrat,

habe eine andere Lösung erstellt und zwar habe ich die oben genannte Formel in eine andere Spalte untergebracht und unterteilt.

Sie sieht jetzt so aus:

Die Hilfsspalten = KA 1 , KB 1 , KC 1

In KA 1) =WENN($L$5=1;K$19;"")&WENN($L$5=4;K$20;"")&WENN($L$5=7;K$21;"")&WENN($L$5=10;K$22;"")&WENN($L$5=13;K$23;"")&WENN($L$5=16;K$24;"")&WENN($L$5=19;K$25;"")&WENN($L$5=22;K$26;"")

In KB 1)

=WENN($L$5=2;L$19;"")&WENN($L$5=5;L$20;"")&WENN($L$5=8;L$21;"")&WENN($L$5=11;L$22;"")&WENN($L$5=14;L$23;"")&WENN($L$5=17;L$24;"")&WENN($L$5=20;L$25;"")&WENN($L$5=23;L$26;"")

In KC 1

=WENN($L$5=3;M$19;"")&WENN($L$5=5;M$20;"")&WENN($L$5=8;M$21;"")&WENN($L$5=11;M$22;"")&WENN($L$5=14;M$23;"")&WENN($L$5=17;M$24;"")&WENN($L$5=20;M$25;"")&WENN($L$5=23;M$26;"")

Dies habe ich für alle Abfragen eingegeben.

Danach habe ich den Bezug in den dafür vorgesehenen Zellen nach Spieler Nummern verbunden und dies habe ich so gemacht:

=WENNFEHLER(WENN($G$1=1;KA1;WENN($G$1=2;KA2;WENN($G$1=3;KA3;WENN($G$1=4;KA4;WENN($G$1=5;KA5;WENN($G$1=6;KA6;WENN($G$1=7;KA7;WENN($G$1=8;KA8;WENN($G$1=9;KA10;WENN($G$1=10;KA11;WENN($G$1=11;KA12;WENN($G$1=12;KA13))))))))))));"")

Das g1=1 bedeutet Spieler 1 usw. und Ka1 ist die Höhe der Zahl.

Jetzt habe ich das was ich erreichen wollte. Ist zwar sehr umständlich aber das Ziel ist erreicht.

Gruß Adde
...