1.3k Aufrufe
Gefragt in Tabellenkalkulation von

Hallo,

ich soll eine Excel Tabelle erstellen um die Zeitzuschläge automatisch auszurechnen. Dazu würde ich dann eine Wennformel verwenden.

=WENN(UND(D14<=ZEIT(20;0;0);D14>=ZEIT(21;0;0));ZEIT(1;0;0);"")*WENN(UND(E14<=ZEIT(20;0;0);E14<=ZEIT(21;0;0));ZEIT(1;0;0);"")

Es soll halt eine Stunde extra berechnet werden wenn die Zeit zwischen 20 und 21 Uhr ist. (Eigentlich nur Samstags, aber das hab ich jetzt mal weggelassen)

So sieht die Tabelle aus:

Samstags Samstag Nachtarbeit Sonntags  Feiertage
Über- 13.00 20:00 21.00  0.00 
stunden - 20:00  - 21:00 - 6:00 - 24:00
Uhrzeit Schlüssel  anzurechn. x 30 % x 20%  x 20 % x  20 % x  25 % x  35 %
von bis von  bis nur Anzahl Stunden 15 21 21 21 19 94
00:00 00:00 00:00
00:00 00:00 00:00 00:00
00:00 00:00 00:00 00:00
20:00:00 22:00:00 02:00 02:00 02:00 #WERT!

Freue mich wenn ihr mir helfen könnt :)

36 Antworten

0 Punkte
Beantwortet von
Die Formel hab ich auch. Allerdings besteht dann wieder das Problem, dass er eine Stunde ausrechnet bei einer Arbeitszeit von z.B. 21:30 bis 22:00
+1 Punkt
Beantwortet von m-o Profi (21.8k Punkte)
Hallo,

mit dieser Formel:

=WENN(UND(STUNDE(E14)<=21;STUNDE(F14)>=21);F14-21/24;WENN(UND(STUNDE(E14)>=21;STUNDE(F14)>=21);F14-E14;WENN(UND(STUNDE(E14)>=21;STUNDE(F14)<=6);REST(F14-E14;1);WENN(UND(STUNDE(E14)>=21;STUNDE(F14)>6);REST(6/24-E14;1);WENN(UND(STUNDE(E14)>0;STUNDE(E14)<=6;STUNDE(F14)<=6);F14-E14;WENN(UND(STUNDE(E14)>0;STUNDE(E14)<=6;STUNDE(F14)>6);6/24-E14;0))))))+WENN(UND(STUNDE(G14)<21;STUNDE(H14)>=21);H14-21/24;WENN(UND(STUNDE(G14)>=21;STUNDE(H14)>=21);H14-G14;WENN(UND(STUNDE(G14)>=21;STUNDE(H14)<=6);REST(H14-G14;1);WENN(UND(STUNDE(G14)>=21;STUNDE(H14)>6);REST(6/24-G14;1);WENN(UND(STUNDE(G14)>0;STUNDE(G14)<=6;STUNDE(H14)<=6);H14-G14;WENN(UND(STUNDE(G14)>0;STUNDE(G14)<=6;STUNDE(H14)>6);6/24-G14;0))))))

wird bei mir - bei einer Arbeitszeit von 21:30 bis 22:00 Uhr (in Spalten G und H) - eine halbe Stunde angezeigt.

Gruß

M.O.
0 Punkte
Beantwortet von
Ich habe 21:30 bis 22:00 in den Spalten E und F stehen. Dann ist es tatsächlich eine Stunde.

Spalte G und H sind richtig
+1 Punkt
Beantwortet von m-o Profi (21.8k Punkte)

Hallo,

Ich habe 21:30 bis 22:00 in den Spalten E und F stehen

Und woher soll ich das wissen? wink

Dann versuch mal diese Version:

=WENN(UND(STUNDE(E14)<21;STUNDE(F14)>=21);F14-21/24;WENN(UND(STUNDE(E14)>=21;STUNDE(F14)>=21);F14-E14;WENN(UND(STUNDE(E14)>=21;STUNDE(F14)<=6);REST(F14-E14;1);WENN(UND(STUNDE(E14)>=21;STUNDE(F14)>6);REST(6/24-E14;1);WENN(UND(STUNDE(E14)>0;STUNDE(E14)<=6;STUNDE(F14)<=6);F14-E14;WENN(UND(STUNDE(E14)>0;STUNDE(E14)<=6;STUNDE(F14)>6);6/24-E14;0))))))+WENN(UND(STUNDE(G14)<21;STUNDE(H14)>=21);H14-21/24;WENN(UND(STUNDE(G14)>=21;STUNDE(H14)>=21);H14-G14;WENN(UND(STUNDE(G14)>=21;STUNDE(H14)<=6);REST(H14-G14;1);WENN(UND(STUNDE(G14)>=21;STUNDE(H14)>6);REST(6/24-G14;1);WENN(UND(STUNDE(G14)>0;STUNDE(G14)<=6;STUNDE(H14)<=6);H14-G14;WENN(UND(STUNDE(G14)>0;STUNDE(G14)<=6;STUNDE(H14)>6);6/24-G14;0))))))

Gruß

M.O.

0 Punkte
Beantwortet von

Viiielen Dank für deine Hilfe.

Es tut mir wirklich leid das ich ständig nerven muss, aber diese Tabelle bringt mich zum verzweifeln. sad

Der Samstag haut in Spalte L und M immer noch nicht hin. Vielleicht hast du da noch eine Idee?

https://supportnet.de/forum/?qa=blob&qa_blobid=3299792759190342900

+1 Punkt
Beantwortet von m-o Profi (21.8k Punkte)

Hallo,

probiere mal die Formeln für Samstag aus: bearbeitete Datei

Gruß

M.O.

0 Punkte
Beantwortet von

https://supportnet.de/forum/?qa=blob&qa_blobid=16015495993250326687

Hmm.., irgendwie sieht das ergebnis dann so aus

+1 Punkt
Beantwortet von m-o Profi (21.8k Punkte)

Hallo,

hier die verbesserte Version: Download

Gruß

M.O.

0 Punkte
Beantwortet von japfl177 Einsteiger_in (24 Punkte)

Mooin,

ich bin es wieder (diesmal mit Anmeldung)

Die Datei ist soweit super. Ein kleines Problem gibt es noch. Die Mitarbeiter erhalten keinen Nachtzuschlag an einen Sonntag. Dies ist auch mit einer Formel hinterlegt. Allerdings nimmt er dann irgendwie etwas Minus.

Siehe Januar unten. https://supportnet.de/forum/?qa=blob&qa_blobid=3974718791053912379

+1 Punkt
Beantwortet von m-o Profi (21.8k Punkte)

Hallo,

ich kann mich dunkel an den Thread erinnern wink.

Im ersten Teil der Formel (vor dem Pluszeichen; s.u.) trifft die letzte WENN-Bedingung zu und er zieht dann die 6:30 Uhr von 6.00 Uhr ab, was dann eben ein negatives Ergebnis ergibt.

Hier mal die geänderte Formel, so dass am Sonntag der Fehler nicht mehr auftaucht.

=WENN(B39="F";"";WENN(A39="Sonntag";0;WENN(UND(STUNDE(E39)<21;STUNDE(F39)>=21);F39-21/24;WENN(UND(STUNDE(E39)>=21;STUNDE(F39)>=21);F39-E39;WENN(UND(STUNDE(E39)>=21;STUNDE(F39)<=6);REST(F39-E39;1);WENN(UND(STUNDE(E39)>=21;STUNDE(F39)>6);REST(6/24-E39;1);WENN(UND(STUNDE(E39)>0;STUNDE(E39)<=6;STUNDE(F39)<=6);F39-E39;WENN(UND(STUNDE(E39)>0;STUNDE(E39)<=6;STUNDE(F39)>6);6/24-E39;0)))))))+WENN(UND(STUNDE(G39)<21;STUNDE(H39)>=21);H39-21/24;WENN(UND(STUNDE(G39)>=21;STUNDE(H39)>=21);H39-G39;WENN(UND(STUNDE(G39)>=21;STUNDE(H39)<=6);REST(H39-G39;1);WENN(UND(STUNDE(G39)>=21;STUNDE(H39)>6);REST(6/24-G39;1);WENN(UND(STUNDE(G39)>0;STUNDE(G39)<=6;STUNDE(H39)<=6);H39-G39;WENN(UND(STUNDE(G39)>0;STUNDE(G39)<=6;STUNDE(H39)>6);6/24-G39;0)))))))

Die letzte Bedingung sollte man aber noch einmal überprüfen.

Gruß

M.O.

...