95 Aufrufe
Gefragt in Tabellenkalkulation von

Hallo,

ich soll eine Excel Tabelle erstellen um die Zeitzuschläge automatisch auszurechnen. Dazu würde ich dann eine Wennformel verwenden.

=WENN(UND(D14<=ZEIT(20;0;0);D14>=ZEIT(21;0;0));ZEIT(1;0;0);"")*WENN(UND(E14<=ZEIT(20;0;0);E14<=ZEIT(21;0;0));ZEIT(1;0;0);"")

Es soll halt eine Stunde extra berechnet werden wenn die Zeit zwischen 20 und 21 Uhr ist. (Eigentlich nur Samstags, aber das hab ich jetzt mal weggelassen)

So sieht die Tabelle aus:

Samstags Samstag Nachtarbeit Sonntags  Feiertage
Über- 13.00 20:00 21.00  0.00 
stunden - 20:00  - 21:00 - 6:00 - 24:00
Uhrzeit Schlüssel  anzurechn. x 30 % x 20%  x 20 % x  20 % x  25 % x  35 %
von bis von  bis nur Anzahl Stunden 15 21 21 21 19 94
00:00 00:00 00:00
00:00 00:00 00:00 00:00
00:00 00:00 00:00 00:00
20:00:00 22:00:00 02:00 02:00 02:00 #WERT!

Freue mich wenn ihr mir helfen könnt :)

18 Antworten

0 Punkte
Beantwortet von m-o Profi (18.1k Punkte)

Hallo,

es wäre gut, wenn du mal eine kleine Beispieltabelle als Exceltabelle zur Verfügung stellen könntest. Wie du eine Tabelle ins Forum einstellen kannst, kannst hier nachlesen: Anleitung

Ich nehme mal an, du willst nur die zusätzliche Stunde berechnen?
Gruß
M.O.
0 Punkte
Beantwortet von

https://supportnet.de/forum/?qa=blob&qa_blobid=17013374728479010508

Für das Gelb markierte bräuchte ich noch formeln.

Einfach nur das die entsprechende Stundenanzahl angezeigt wird

0 Punkte
Beantwortet von m-o Profi (18.1k Punkte)

Hallo,

hier mal die bearbeitete Beispieltabelle: Download Tabelle

Ich habe dir mal ein paar Formeln erstellt. Aber Achtung, die Formeln decken nicht alle Möglichkeiten ab (z.B. bei der Nacharbeit Arbeitsbeginn nach 0:00 Uhr). Aber das kann man auch noch ergänzen, falls es gebraucht wird.

Gruß

M.O.

0 Punkte
Beantwortet von
Wow das ist super. Auf die Funktion Rest wäre ich niemals bekommen.

Wie würde man denn die Nachtarbeit ergänzen? Es kommt zwar sehr selten vor, aber wenn dann wäre es schon gut wenn es abgedeckt wird :)
0 Punkte
Beantwortet von m-o Profi (18.1k Punkte)
Hallo,

hier die erweiterte Formel für M11:

=WENN(UND(STUNDE(D11)<21;STUNDE(E11)>21);E11-21/24;WENN(UND(STUNDE(D11)>21;STUNDE(E11)>21);E11-D11;WENN(UND(STUNDE(D11)>21;STUNDE(E11)<=6);REST(E11-D11;1);WENN(UND(STUNDE(D11)>21;STUNDE(E11)>6);REST(6/24-D11;1);WENN(UND(STUNDE(D11)>0;STUNDE(D11)<=6;STUNDE(E11)<=6);E11-D11;WENN(UND(STUNDE(D11)>0;STUNDE(D11)<=6;STUNDE(E11)>6);6/24-D11;0))))))+WENN(UND(STUNDE(F11)<21;STUNDE(G11)>21);G11-21/24;WENN(UND(STUNDE(F11)>21;STUNDE(G11)>21);G11-F11;WENN(UND(STUNDE(F11)>21;STUNDE(G11)<=6);REST(G11-F11;1);WENN(UND(STUNDE(F11)>21;STUNDE(G11)>6);REST(6/24-F11;1);WENN(UND(STUNDE(F11)>0;STUNDE(F11)<=6;STUNDE(G11)<=6);G11-F11;WENN(UND(STUNDE(F11)>0;STUNDE(F11)<=6;STUNDE(G11)>6);6/24-F11;0))))))

Die Formel kannst du soweit wie benötigt nach unten ziehen.

Gruß

M.O.
0 Punkte
Beantwortet von
Hallo M.O.

mir ist noch ein Punkt aufgefallen der noch nicht klappt. Wenn ich eine Arbeitszeit von 12:00 bis z.B. 19:00 eingebe, dann rechnet der bei Samstag 0 Stunden aus. Eigentlich müsste der dann an den Samstag 9 Überstunden und 8 Stunden Samstagszuschlag berechnen.
0 Punkte
Beantwortet von m-o Profi (18.1k Punkte)
Hallo,

ich hatte ja geschrieben, dass die Formeln nicht alle Möglichkeiten abdecken.

Mit der folgenden ergänzten Formel für die Zelle K11 wird auch in deinem Fall die Samstagszeit mit 6 Stunden (13 - 19 Uhr) berechnet:

=WENN(A11<>"Samstag";"";WENN(UND(STUNDE(D11)>=13;STUNDE(E11<20));REST(E11-D11;1);WENN(UND(STUNDE(D11)>=13;STUNDE(E11)>20);REST(20/24-D11;1);0))+WENN(UND(STUNDE(F11)>=13;STUNDE(G11<20));REST(F11-G11;1);WENN(UND(STUNDE(FD11)>=13;STUNDE(G11)>20);REST(20/24-F11;1);WENN(UND(STUNDE(D11)<13;STUNDE(E11)<=20);E11-13/24;WENN(UND(STUNDE(D11)<13;STUNDE(E11)>20);7/24;0)))))

Die Formel für L11 habe ich auch noch etwas angepasst:

=WENN(A11<>"Samstag";"";WENN(UND(STUNDE(D11)<=20;STUNDE(E11)>=21);1/24;WENN(UND(STUNDE(D11)>20;STUNDE(E11)<=21);REST(E11-D11;1);0))+WENN(UND(STUNDE(F11)<20;STUNDE(G11)>21);1/24;WENN(UND(STUNDE(F11)>20;STUNDE(G11)<=21);REST(G11-F11;1);0)))

Beide Formeln kannst du soweit wie benötigt nach unten ziehen.

Gruß

M.O.
0 Punkte
Beantwortet von

So ganz haut die Samstagformel noch nicht hin.

Wenn ich von 10 bis 15:30 und von 19 bis 22 Uhr arbeite. Zeigt er bei der Samstagszeit (13-20 Uhr) nur 2:30 an. Es müssten aber 3:30 sein. Ich hab schon probiert es zu lösen, aber das ist gar nicht so einfach

Samstag 4.1.20 10:00 15:30 19:00 22:00 08:30 08:30 08:30 02:30
0 Punkte
Beantwortet von m-o Profi (18.1k Punkte)
Hallo,

in der Formel war ein Fehler drin. So sollte es funktionieren. Formel für Zelle K11:

=WENN(A11<>"Samstag";"";WENN(UND(STUNDE(D11)>=13;STUNDE(E11<20));REST(E11-D11;1);WENN(UND(STUNDE(D11)>=13;STUNDE(E11)>20);REST(20/24-D11;1);WENN(UND(STUNDE(D11)<13;STUNDE(E11)<=20);E11-13/24;WENN(UND(STUNDE(D11)<13;STUNDE(E11)>20);7/24;0)))+WENN(UND(STUNDE(F11)>=13;STUNDE(G11<20));REST(F11-G11;1);WENN(UND(STUNDE(F11)>=13;STUNDE(G11)>20);REST(20/24-F11;1);0))))

Gruß

M.O.
0 Punkte
Beantwortet von

https://supportnet.de/forum/?qa=blob&qa_blobid=12814470595636657386

Irgendwie haut es doch noch nicht so ganz hin..

Vielen, vielen Dank für deine Hilfe :)

...