23 Aufrufe
Gefragt in Tabellenkalkulation von
excel bedingte formatierung gleiche werte aber nur das letzte soll in farbe dargestellt werden

habe in den spalten b1 g2 die jahre stehen  und darunder zahlen

2000   2001  2002 2003 2004 2005

100    500     100   150  200   300

nun möchte ich das es mir nur die zelle 2002 (100) farbig anzeigt und nicht die Zelle 2000 (100) auch

3 Antworten

0 Punkte
Beantwortet von
Hi Bischoff2000

Etwas mehr Infos wären gut. Wie lautet die Bedingung? Sind die Jahre in B1 bis G2 rollierend? Kann die 2002 also auch in einer anderen Zelle als D1 stehen? Ist es wichtig, dass nur der Wert 100 rot markiert wird oder kann in 2002 auch ein anderer Wert stehen? Gibt es weitere Bedingungen?

So wie du das momentan beschreibst könntest du auch einfach die Zelle D2 auf normalem Weg rot formatieren.

Gruß Mr. K.
0 Punkte
Beantwortet von
Bearbeitet
Hi Bischoff2000

versuchs mal damit. Markiere die Zeile B2:G2 und trage in der bedingten Formatierung unter Formel folgendes ein:

=ZÄHLENWENN($B$2:B2;B2)>1

bei doppelten Werten wird nur das letzte markiert. Bei drei Werten werden die letzten beiden markiert. Stellst du dir das so vor?

Wenn es wirklich nur der letzte Wert sein soll, dann muss die Formel so lauten:

=UND(ZÄHLENWENN($B$2:B2;B2)>1;ZÄHLENWENN($B$2:B2;B2)=ZÄHLENWENN($B$2:$G$2;B2))

Gruß Mr. K.
0 Punkte
Beantwortet von
Korrektur:

Da du sicher mehr als nur einen Datensatz hast und das Format auf alle anwenden willst, muss die Zeile variabel gehalten werden. Also muss die Formel so lauten:

=UND(ZÄHLENWENN($B2:B2;B2)>1;ZÄHLENWENN($B2:B2;B2)=ZÄHLENWENN($B2:$G2;B2))

Dann kannst du das Format einfach mit dem Pinsel-Symbol auf alle anderen Zellen übertragen. Oder du kopierst die Zeile 2 und machst bei den anderen Zeilen Inhalte einfügen -> Formate.

Gruß Mr. K.
...