24 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.4k Punkte)

Hallo, eine Frage für VBA Spezialisten

habe mir eine Formel erstellt doch dies ist sehr umständlich für mich vielleicht kann mir hierbei jemand eine Lösung über VBA helfen.

Habe bis jetzt nur für 4 Spieler das Doppel 1 und Doppel 2 Würfe erstellt, so dass das ja erscheint. Müsste aber das für 48 Spiele erstellen und jeweils alle Doppel also Doppel 3, 4, 5 usw. insgesamt 22 mal.

So ist die Anzeige:

WAHR Ja
FALSCH                  
Das wären die Formeln
nein
 

 Dies steht in der Zelle FK20 und FL20 und ist nur Doppel 1 eine Zelle darunter für Doppel 2

=WENN($J$1=1;K19=2;WENN($J$1=2;N19=2;WENN($J$1=3;Q19=2;WENN($J$1=4;T19=2))))

=WENN($FK$19=FALSCH;$J$11;WENN($FK$19=WAHR;$I$11))

Das ist für Doppel 2

=WENN($J$1=1;K19=4;WENN($J$1=2;N19=4;WENN($J$1=3;Q19=4;WENN($J$1=4;T19=4))))

=WENN($FK$20=FALSCH;$J$11;WENN($FK$20=WAHR;$I$11))

Nun meine Frage: wie kann ich diese Anordnung zusammen fügen.

Für HILFE wäre ich wirklich ganz DANKBAR

Gruß Adde

1 Antwort

0 Punkte
Beantwortet von addeguddi Experte (1.4k Punkte)

Hallo 

habe eine Lösung erstellt für meine Bedürfnisse.

Habe folgendes erstellt:

Formel nur für Doppel 1, diese habe ich dann für alle Doppel die Möglich sind erstellt.

=WENN($J$1=1;$K$19=2;WENN($J$1=2;$N$19=2;WENN($J$1=3;$Q$19=2;WENN($J$1=4;$T$19=2;WENN($J$1=5;$W$19=2;WENN($J$1=6;$Z$19=2;WENN($J$1=7;$AC$19=2;WENN($J$1=8;$AF$19=2;WENN($J$1=9;$AI$19=2;WENN($J$1=10;$AL$19=2;WENN($J$1=11;$AO$19=2;WENN($J$1=12;$AR$19=2;WENN($J$1=13;$AU$19=2;WENN($J$1=14;$AX$19=2;WENN($J$1=15;$BA$19=2;WENN($J$1=16;$BD$19=2;WENN($J$1=17;$BG$19=2;WENN($J$1=18;$BJ$19=2;WENN($J$1=19;$BM$19=2;WENN($J$1=20;$BP$19=2;WENN($J$1=21;$BS$9=2;WENN($J$1=22;$BV$19=2;WENN($J$1=23;$AB$19=2;WENN($J$1=24;$CB$19=2;WENN($J$1=25;$CE$19=2;WENN($J$1=26;$CH$19=2;WENN($J$1=27;$CK$19=2;WENN($J$1=28;$CN$19=2;WENN($J$1=29;$CQ$19=2;WENN($J$1=30;$CT$19=2;WENN($J$1=31;$CW$19=2;WENN($J$1=32;$CZ$19=2;WENN($J$1=33;$DC$19=2;WENN($J$1=34;$DF$19=2;WENN($J$1=35;$DI$19=2;WENN($J$1=36;$DL$19=2;WENN($J$1=37;$DO$19=2;WENN($J$1=38;$DR$19=2;WENN($J$1=39;$DU$19=2;WENN($J$1=40;$DX$19=2;WENN($J$1=41;$EA$19=2;WENN($J$1=42;$ED$19=2;WENN($J$1=43;$EG$19=2;WENN($J$1=44;$EJ$9=2;WENN($J$1=45;$EM$19=2;WENN($J$1=46;$EP$19=2;WENN($J$1=47;$ES$19=2;WENN($J$1=48;$EV$19=2))))))))))))))))))))))))))))))))))))))))))))))))

Wenn das Ergebnis als Wahr erscheint wird dies in die Ausgabezelle als Wahr angezeigt. diese Wahr oder Falsch wird in ja oder nein umgewandelt. 

Die Formel dafür:

=WENN($FO$19=FALSCH;$J$11;WENN($FO$19=WAHR;$I$11))

Da die Formel für Wahr oder Falsch sich auf mehrere Zeilen beziehen musste ich noch eine Zelle mit einer Formel erstellen

Formel ist :

=ODER(IDENTISCH(I11;FL19:FL39)) mit Strg alt Enter abschließen.

So habe ich mein Ziel erreicht. VBA wäre wahrscheinlicher viel einfacher aber da ich das nicht kann, muss ich mir mit Formel helfen, dauert zwar sehr lange aber ich habe mein Ziel erreicht.

Sollte trotzdem mir jemand eine Lösung in VBA zukommen lassen würde ich mich freuen.

Gruß Adde

 wird dies in der ausgeabe

...