83 Aufrufe
Gefragt in Tabellenkalkulation von

Hallo zusammen,

ich habe einen Wert pro Jahr (4), den ich in Abhängigkeit von einen Start- und Enddatum automatisch über vorgegebene Jahre verteilen möchte.

Beispiel:
- 4 Mitarbeiter pro Jahr
- Einsatzbeginn: 01.04.2022
- Einsatzende: 31.12.2023
- Tabelle mit Jahren von 2021-2025

Im Jahr 2022 würde ich also 4 Mitarbeiter an 274 von 365 Tagen beschäftigen (31.12.2022-01.04.2022), Wochenende, Feiertage, Urlaub etc. ist für die Kalkulation egal. 

Ich würde also erwarten, dass in einer Tabelle nun folgende Werte in Abhängigkeit von Einsatzbeginn und Einsatzende automatisch berechnet werden. Wie lautet die Formel in der Zeile "Anteil"? (D5 ist 274/365*4)

Vielen Dank!

Christian

1 Antwort

0 Punkte
Beantwortet von m-o Profi (19.9k Punkte)
Hallo Christian,

ich hoffe, ich habe dich richtig verstanden. Versuche mal die folgende Formel in C5:

=WENN(UND(JAHR($B$2)=JAHR(C4);JAHR($B$3)=JAHR(C4));$B$3-$B$2;WENN(UND(JAHR($B$2)=JAHR(C4);JAHR($B$3)>JAHR(C4));C4-$B$2;WENN(UND(JAHR($B$2)<JAHR(C4);JAHR($B$3)>JAHR(C4));DATUM(JAHR(C4);12;31)-DATUM(JAHR(C4)-1;12;31);WENN(UND(JAHR($B$2)<JAHR(C4);JAHR($B$3)=JAHR(C4));$B$3-DATUM(JAHR(C4)-1;12;31);0))))/365*$B$1

Die Formel kannst du soweit wie benötigt nach rechts ziehen.

Gruß

M.O.
...