22 Aufrufe
Gefragt in Tabellenkalkulation von little-key-2 Einsteiger_in (25 Punkte)

Hallo liebe Foenmitglieder.

Mein Problem: SVERWEIS, 100x probiert und nie richtig verstanden.

In Tabelle1 Zelle A1 steht eine Bestellnummer.

Diese Nummer soll in Tabelle2 Spalte B gesucht werden und der Eintrag aus Spalte E in Tabelle1 Spalte H ausgegeben werden.

Das Problem ist, diese Nummer kommt in Tabelle2 mehrmals vor. So wäre die Bedingung, nur wenn in Tabelle2 Spalte F "ot_total" steht.

Tabelle1

A B C D E F G H
1 444333 Ausgabe Tab2, E3
2

Tabelle2

A B C D E F
1 444333 4,33 ot_ship
2 444333 7,38 ot_sub
3 444333 20,00 ot_total
4 444333 3,43 ot_tax

Hoffe, ich konnte das einigermaßen erklären, bitte um Hilfe.

(Ich verstehe mich selbst nicht, warum das SVERWEIS einfach nicht in meinen Kopf will)

Liebe Grüße Mario

5 Antworten

0 Punkte
Beantwortet von computerschrat Profi (26.9k Punkte)
Hallo little-key-2,

versuchs mal hiermit:

=SVERWEIS(Tabelle1!A1&"or_total";WAHL({1.2};B1:B4&F1:F4;E1:E4);2;0)

Über & werden die zwei Suchkriterien verknüpft, die Bestellnummer in Tabelle1!A1 und der Begriff "or_total".

Gesucht werden die Begriffe in einer Tabelle, die über die Wahl() Funktion erzeugt wird. Die Tabelle besteht aus B1:B4 (mit den Bestellnummern) und F1:F4 (mit dem zweiten Kriterium "or_total"). E1:E4 verweist auf den Ergebnisvektor.

Die Bereiche der Spalten musst du noch an die tatsächliche Größe deiner Tabelle anpassen.

Gruß computerschrat
0 Punkte
Beantwortet von little-key-2 Einsteiger_in (25 Punkte)
Hallo computerschrat,

vielen lieben Dank, aber leider tut sich da nichts.

In Tabelle 2 H1 soll die Ausgabe erfolgen.
Es wundert mich warum anfangs steht: =SVERWEIS(Tabelle1...
Kein Bezug auf Tabelle2.

Gruß Mario
0 Punkte
Beantwortet von computerschrat Profi (26.9k Punkte)
Die Formel musst du in die Zelle schreiben, in der die Ausgabe erfolgen soll, also in H1 von Tabelle 2.

Da die gesuchte Bestellnummer in A1 von Tabelle 1 steht, ist im SVERWEIS der Bezug auf Tabelle1.

Alle anderen Daten stehen in Tabelle 2, dann braucht die Formel, die auch in Tabelle 2 steht keinen weiteren Bezug auf Tabelle2.

Gruß computerschrat
0 Punkte
Beantwortet von little-key-2 Einsteiger_in (25 Punkte)
Entschuldige, aber da hast Du ev. etwas falsch verstanden bzw. ich das falsch erklärt.

Die Ausgabe soll in Tabelle1 H1 erfolgen, siehe Beispiel-Tabelle (Ausgabe aus Tabelle2, E3)

Lieben Gruß
0 Punkte
Beantwortet von computerschrat Profi (26.9k Punkte)
OK, das war in deiner vorherigen Antwort anders geschrieben :-)

Aber dann schreib die Formel in Tabelle 1 und ändere die Bezüge wie folgt:

=SVERWEIS(A1&"or_total";WAHL({1.2};Tabelle2!B1:B4&Tabelle2!F1:F4;Tabelle2!E1:E4);2;0)

Gruß computerschrat
...