45 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.6k Punkte)

Hallo und einen schönen guten Tag

Habe eine Gewinnerliste erstell und versuche die Gesamtsumme der einzelnen Spieler zu ermitteln.

In den Zellen C2 bis C9 ist die Reihenfolge der Platzierungen (Namen) und der Gewinn steht in den Zellen D2 bis D9 die aus einer Rangliste übernommen werden. Das Gleiche ist in den Zellen H2 bis H9 M2 bis M9 und R2 bis R9, der Gewinn steht jeweils in der Nachbarzelle. Diese Namen werden dann in den Zellen C17 bis C24 und für die anderen Paarungen analog übernommen.

Um festzustellen wer was gewonnen hat, habe ich die Teilnehmer in den Zellen D17 bis D24 aus den Spielpaarungen übernommen, das Gleiche auch für die anderen Spielpaarungen in I17 bis I24, N17 bis N24 und S17 bis S24.

Da sich die Namen in der Rangfolge ändern können, möchte ich, dass aus diesen Zellen:

1tens; das in Zelle E17 der Betrag steht der erzielt wurde, dies sollte auch für die anderen Paarungen so sein.

Beispiel: In Zelle D17 steht Guddi und der Wert daneben, dies sollte analog den anderen Zellen auch so sein.

Erst danach soll die Summe der einzelnen Spieler addiert werden.

Und diese sollen dann absteigend in U17 stehen.

Das ist eine Formel in der Zelle E17 =WENN(D17=$C$2;$D$2;""&WENN(D17=$C$3;$D$3;""&WENN(D17=$C$3;$D$3;""&WENN(D17=$C$4;$D$4;""&WENN(D17=$C$5;$D$5;""&WENN(D17=$C$6;$D$6;""&WENN(D17=$C$7;$D$7;""&WENN(D17=$C$8;$D$8;""&WENN(D17=$C$9;$D$9;""))))))))) in Zelle e 22 Steht es so wie es sein soll, alle anderen Zellen ist es nicht so.

Dann habe ich das probiert: =WENNFEHLER(WENN(IDENTISCH(R18;$S$17:$S$24);$S$17:$S$24);"")Zeigt es null an.

Habe Datei hochgeladen: https://filehorst.de/d/ekqlsIsp

Gruß Adde

1 Antwort

0 Punkte
Beantwortet von addeguddi Experte (1.6k Punkte)

Guten Morgen,

Lösung erstellt.

Habe die Namen aller Spielvarianten in den Zellen A1 bis A34 und die aus der Rangtabelle die Reihenfolge der Namen in den Zellen B1 bis b34 gesetzt. ='Rang 8 Spieler 1'!G2 und den Betrag ='Rang 8 Spieler 1'!H2 in Zelle C1 bis C34  dann die Formel =WENN(ZÄHLENWENN($A$1:$A$34;B1)>1;SUMMENPRODUKT(($B$1:$B$34=A1)*($C$1:$C$34));0) in D1 erstellt nun funktioniert es. In VBA wäre es bestimmt leichter aber da kenne ich mich nicht aus, daher versuche ich es immer über eine Formel. 

Gruß Adde

...