195 Aufrufe
Gefragt in BS-Sonstige von deltafurcht Mitglied (198 Punkte)

Hallo,

mein Blog habe ich bei wordpress.com erstellt. Im Format "beispiel.wordpress.com".  Bei united-domains bezahle ich für eine Domain in dem Format "beispiel.blog". Wenn diese Adresse aufgerufen wird, erfolgt eine automatische Weiterleitung zu "beispiel.wordpress.com"

Wenn nun unter Win10 in einem x-beliebigen Browser "beispiel.blog" aufrufe, erscheint einmal der Hinweis "Datenschutz&Cookies, wir Wordpress und unsere Werbepartner können  Cookies ....". Diesen Hinweis klicke ich dann einmalig weg mit "Zustimmen" und dann ist Ruhe. Gleich wieviele Unterseiten und Beiträge meines Blogs ich anklicke.

Das Problem: auf Android-Handys (habe es bei zweien getestet) kommt nach jedem Aufruf einer Unterseite oder eines Beitrags wieder neu der Hinweis "Datenschutz&Cookies...," Jedesmal muss man neu zustimmen, damit der Hinweis verschwindet.

Hat jemand einen Tipp, wie man diesen immer wieder kehrenden nervigen Hinweis ausschalten kann?

Ich sehe weder bei Wordpress noch bei united-domains eine Möglichkeit dazu

Für Hinweise danke im Voraus!

7 Antworten

+1 Punkt
Beantwortet von computerschrat Profi (29.2k Punkte)
Hallo deltafurcht,

eventuell ist bei den Androiden eingestellt, dass sie Cookies jeder Art ablehnen. Wenn dann die Webseite beim erneuten Aufruf beim Handy nachfragt, ob der Cookie-Hinweis bereits beantwortet wurde, kommt ein nein zurück, denn das Handy hat das entsprechende Cookie, mit dem diese Antword vermerkt wird, nicht gespeichert. Also kommt der Hinweis erneut.

Gruß computerschrat
0 Punkte
Beantwortet von deltafurcht Mitglied (198 Punkte)
@computerschrat: danke für den Hinweis.

Getestet habe ich es mit 3 verschiedenen Tablets/Smartphones (Android 11 bis 7).

Bei meinem Smartphone Poco X3 ist es Android 11, Chrome 94 und unter den Chrome-Einstellungen ist "Cookies zugelassen" eingestellt.

Habe gerade mal den Cache und Browserspuren bereinigt. Dann supportnet aufgerufen. Es kam 1mal die Cookie-Abfrage und danach war dann Ruhe beim Aufruf weiterer Seiten.

Nur bei meinem Fall oben, tritt das Problem auf. Entweder ist der Cookie-Hinweis von Wordpress besonders renitent (unwahrscheinlich) oder es liegt vielleicht an der Weiterleitung bei United Domains?
0 Punkte
Beantwortet von deltafurcht Mitglied (198 Punkte)

Habe gerade mal bei united domains die Weiterleitung versuchsweise auf https:, http:, www. abgeändert. Ohne Veränderung des Ergebnisses.

Dann ist mir noch eine Besonderheit aufgefallen:

Wenn ich unter Win10 in einem x-beliebigen Browser "beispiel.blog" aufrufe, erscheint einmal der Hinweis "Datenschutz&Cookies, wir Wordpress und unsere Werbepartner können  Cookies ....". Diesen Hinweis klicke ich dann einmalig weg mit "Zustimmen" und dann ist Ruhe. Gleich wieviele Unterseiten und Beiträge meines Blogs ich anklicke. ABER: wenn ich dann eine andere Webseite aufrufe, zB google.com und dann anschließend wieder "beispiel.blog" aufrufe, kommt auch wieder der Cookie-Hinweis. Obwohl doch eigentlich gespeichert sein müsste, dass ich diesen bereits bejaht habe!!?

+1 Punkt
Beantwortet von computerschrat Profi (29.2k Punkte)
Normalerweise wird beim Wegklicken oder genehmigen dieser Cookie-Hinweise ein Cookie gesetzt. Beim nächsten Seitenaufruf innerhalb dieser Domain wird dieses Cookie abgefragt. Wenn es vorhanden ist, kommt keine neuer Hinweis.

Anstatt ein Cookie zu setzen, kann auch eine Session-ID erteilt werden. Zu dieser Session-ID merkt sich der Server das Ergebnis der Antwort auf den Cookie-Hinweis. Die Session-ID wird aber, je nach serverseitiger Einstellung, bei Verlassen der Domain ungültig. Mit dem nächsten Aufruf einer Webseite dieser Domain bekommst du eine neue ID und damit auch wieder den lästigen Cookie-Hinweis.

Gruß computerschrat
+1 Punkt
Beantwortet von kody Experte (1.3k Punkte)
Hallo deltafurcht,

hast Du evtl. in den Browser-Optionen, bei Sitzung beenden, "Cookies löschen" eingestellt?

MfG Kody
0 Punkte
Beantwortet von deltafurcht Mitglied (198 Punkte)

Danke für die Antworten.

"Sitzung beenden, "Cookies löschen" ist nicht eingestellt.

Auf den Supportseiten bin ich gerade auf Folgendes gestossen:

" ... Öffnen Sie auf Ihrem Android-Smartphone oder ‑Tablet die Chrome App Chrome

  1. Rufen Sie eine Website auf.
  2. Tippen Sie rechts neben der Adressleiste auf „Mehr“ Dreipunkt-Menü und dann „Info“ Informationen und dann Cookies.
  3. Tippen Sie neben der Anzahl der verwendeten Cookies auf „Löschen“ ..."
Daraufhin habe ich folgendes probiert: im Chrome-Browser sämtliche Cookies, Websitedaten, Browserverlauf etc. gelöscht.
Dann habe ich meine Seite xxx.blog aufgerufen. Sofort kam wieder halbseitig der Hinweis ""Datenschutz&Cookies, wir Wordpress und unsere Werbepartner können  Cookies ....".
Nun habe ich sofort zugestimmt, sondern bin, wie oben beim Google-Support beschrieben" auf 3 Punkte, Info, Cookies gegangen. Dort wurden mir 10 verwendete Cookies angezeigt. Dann habe ich auf die nächste Unterseite meines Blogs geklickt, Cookies zugestimmt. Dann wieder unter Info nachgeschaut: nun wurden mir 11 verwendete Cookies auf meiner Webseite angezeigt.
Fazit: die Cookies werden also tatsächlich auf dem/den Android-Gerät(en) gespeichert. 
Trotzdem erscheint bei jedem neuen Klick auf einen Unterpunkt des Blogs wieder ""Datenschutz&Cookies, wir Wordpress und unsere Werbepartner können  Cookies ...."
Liegt es an Wordpress oder an United-Domains?
0 Punkte
Beantwortet von deltafurcht Mitglied (198 Punkte)
Nächster Versuch, jetzt bin ich dem Problem näher gekommen.

Und zwar habe ich bei United-Domains deaktiviert: "Frame-Weiterleitung (versteckte Weiterleitung) Bei der Frame-Weiterleitung bleibt die Start-URL in der Adresszeile des Browsers sichtbar. Der Besucher sieht nicht, dass er weitergeleitet wird. Zusätzlich können Meta-Tags zur Suchmaschinen-Optimierung angegeben werden."

Stattdessen die Alternative angeklickt "Header-Redirect (offene Weiterleitung) Bei der Weiterleitung mit Header-Redirect wird die Ziel-URL in der Adresszeile des Browsers angezeigt. Der Besucher sieht, dass er weitergeleitet wurde..."

Ergebnis: jetzt tritt das Cookie-Problem nicht mehr auf. Nur sieht jetzt jeder Besucher meines Blog nach Anwahl von "xxx.blog" sofort, dass er weitergeleitet wurde von "delta87xy.wordpress.com". Die Unterseiten werden in der Adressleiste des Browsers angezeigt in dem Stil "delta87xy.wordpress.com2020beitrag..."

Kleiner Schönheitsfehler, an dem man nichts ändern kann?
...