41 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.7k Punkte)
Hallo und einen schönen Samstag

Stehe, wie so oft, vor einem Problem. Versuche seit (meiner letzten Frage) eine Reihenfolge von Namen die sich immer nach einem Durchgang einer Spielrunde um eine Zelle verschieben.

Es gibt verschiedene Spielrunden: Mit 2 Spieler, 3, 4, 6 und 8 Spieler

Namen werden über diese Formel eingepflegt:

Bedeutung der Zahlen und Spielvariante: 10 ist für 2 Spieler, 11 für 3, 12 für 4, 13 für 6 und 14 für 8 Spieler dies ist die Spielvariante ohne dopple in. Die Zahlen 20, 21 usw. für sind für dopple in, 31 für dopple out , 41 für dopple in und dopple out

=WENN($E$4=10;$B$17;WENN($E$5=11;$B$17;WENN($E$6=12;$B$17;WENN($E$7=13;$B$17;WENN($E$8=14;$B$17;WENN($F$4=20;$B$17;WENN($F$5=21;$B$17;WENN($F$6=22;$B$17;WENN(F7=23;$B$17;WENN($F$8=24;$B$17;WENN($G$4=30;$B$17;WENN($G$5=31;$B$17;WENN($G$6=32;$B$17;WENN($G$7=33;$B$17;WENN($G$8=34;$B$17;WENN($H$4=40;$B$17;WENN($H$5=41;$B$17;WENN($H$6=42;$B$17;WENN($H$7=43;$B$17;WENN($H$8=44;$B$17))))))))))))))))))))

Das bedeutet: Es ist für alle Spielrunden der erste Name. Für den zweiten wird aus B17 die C17 bis I17 für den 8ten Spielernamen.

Nun möchte ich wenn 2 Spieler spielen, der 1te. Namen in Zelle C20 erscheint der zweite Namen in C21 usw. Spieler 1 ist Adde und beginnt mit der Runde 1, dann kommt Spieler 2 ist Guddi. In der 2. Runde beginnt Guddi und dieser Name soll dann in C22 erscheinen und Adde in C23 nun folgt die 3. Runde  hier beginnt wieder Adde dann Guddi.

Runde 1               Runde 2               Runde 3               Runde 4

Adde, Guddi,   Guddi, Adde,    Adde, Guddi,   Guddi, Adde; dies sollte fortlaufend sein.

Dies habe ich bis 8 Runden geschafft, ab der neunten Runde nicht mehr.

Das gleiche Spiel mit 3, 4, 6 und 8 Spieler.

Bespiel:

Runde 1 für 3 Spieler                     Runde 2 für 3 Spieler               Runde 3 für 3 Spieler                        

1Adde, 2Guddi, 3Thomas,      2Guddi, 3Thomas, 1Adde           3Thomas, 1Adde,2Guddi,  

ab Runde 4 wiederholt sich der Vorgang

1Adde, 2Guddi, 3Thomas,      2Guddi, 3Thomas, 1Adde        3Thomas, 1Adde,2Guddi,  

Dies soll für alle Spielvariationen geschehen aus Spieler 1 der rückt nach der Runde auf den letzten Rang, der 2te auf den 1ten usw.

Habe es mit einer Formel probiert aber das funktioniert nicht da ich einige Zellen Doppelt nehmen muß.

Hoffe ich habe das verständlich erklärt und es kann mir jemand eine Lösung zu kommen lassen.

Lade die Liste noch hoch. Bei den Listen bis 8 Spieler hier klicken erscheint eine zahl diese wird in

Liste 1 Leg übernommen. https://filehorst.de/d/ezpIsfjI

Gruß Adde

1 Antwort

0 Punkte
Beantwortet von addeguddi Experte (1.7k Punkte)
Hallo Forum,

für diese Frage brauch sich keiner mehr Gedanken zu machen für eine Lösung.

Habe Ziel erreicht. War sehr zeitaufwendig aber wenn es dann klappt ist man zufrieden.

Hier ein Beispiel meiner Lösung für 8 Teilnehmer.

Diese Formel Ist jetzt für 8 Spieler 1 Runde hier beginnt Spieler 1 mit der Zuordnung von Zelle B17 in Zelle C20,

bei der 2 Runde ist Spieler 1 an letzter Stelle; der Eintrag erfolgt von Zelle B17 in Zelle C35

usw.

=WENN($E$8=14;$B$17;WENN($E$7=13;$B$17;WENN($E$4=10;$B$17;WENN($E$5=11;$B$17;WENN($E$6=12;$B$17;WENN($E$7=13;$B$17;WENN($E$8=14;$B$17;WENN($E$4=10;$B$17;WENN($E$5=11;$B$17;WENN($E$6=12;$B$17;WENN(E7=13;$B$17;WENN($E$8=14;$B$17;WENN($E$4=10;$B$17;WENN($E$5=11;$B$17;WENN($E$6=12;$B$17;WENN($E$7=13;$B$17;WENN($E$8=14;$B$17;WENN($E$4=10;$B$17;WENN($E$5=11;$B$17;WENN($E$6=12;$B$17;WENN($E$7=13;$B$17;WENN($E$8=14;$B$17))))))))))))))))))))))

Runde 2

=WENN($E$8=14;$B$17;WENN($E$7=13;$G$17;WENN($E$6=12;$D$17;WENN($E$5=11;$D$17;WENN($E$7=13;$B$17;WENN($E$5=11;$D$17;WENN($E$6=12;$C$17;WENN($E$6=12;$E$17;WENN($E$5=11;$C$17;WENN($E$4=10;$B$17;WENN($E$5=11;$D$17;WENN($E$4=10;$C$17;WENN($E$6=12;$D$17;WENN($E$7=13;$E$17;WENN(E$6=12;$C$17;WENN($E$7=13;$E$17;WENN($E$5=11;$C$17;WENN($E$4=10;$B$17;WENN($E$5=11;$E$17;WENN($E$6=12;$E$17;WENN($E$7=13;$E$17;WENN($E$8=14;$E$17;WENN($E$4=10;$E$17;WENN($E$5=11;$E$17;WENN($E$6=12;$E$17;WENN($E$7=13;$E$17;WENN($E$8=14;$E$17;WENN($E$4=10;$E$17;WENN($E$5=11;$E$17;WENN($E$6=12;$E$17;WENN($E$7=13;$E$17;WENN($E$8=14;$E$17;WENN($E$4=10;$B$17;WENN($E$5=11;$E$17;WENN($E$6=12;$E$17;WENN($E$7=13;$E$17;WENN($E$8=14;$E$17;)))))))))))))))))))))))))))))))))))))

Gruß Adde
...