83 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.9k Punkte)
Guten Morgen,

vielleicht kann mich jemand unterstützen

Zeigt mir nicht den Wert der Zelle nicht an

Das ist die Formel:

=WENN($J$1<13;ADH112;WENN(UND($E$7=6;$J$1=12);ADH112;WENN($J$1<11;ADB112;WENN(UND(E6=5;$J$1=10);ADB112;WENN($J$1<9;ACV112;WENN(UND($E$5=4;$J$1=8);ACV112;WENN(J1<6;ACP112;WENN(UND($J$1=6;E4=3);ACP112;WENN(UND($E$3=2;$J$1<4);ACJ112;WENN(UND($J$1=4;E3=2);ACJ112;WENN(J1<2;ACD112;WENN(UND($E$2=1;$J$1=2);ACD112))))))))))))

Nehmen wir diesen Teil der Formel  WENN(J1<2;ACD112;WENN(UND($E$2=1;$J$1=2);ACD112))))))))))))

In ACD112 steht die Zahl 18, diese wird durch ein X ersetzt wenn in Zelle K19 die 18 erscheint, ist auch OK, es erscheint ein X in der Zelle ACD112. Dieses X soll dann in der Zelle ABM 2 übernommen werden, doch hierscheint die 18 anstatt ein X????

Habe ich hier einen Fehler in der Formel hinterlegt?

Es wäre sehr nett wenn ich eine Rückmeldung erhalten würde.

Gruß Adde

6 Antworten

+1 Punkt
Beantwortet von m-o Profi (21.7k Punkte)
Bearbeitet von m-o
Hallo Adde,

wenn nicht das Ergebnis kommt, das du erwartest, dann muss wohl eine Bedingung vorher erfüllt sein, so dass dir nicht ACD112 angezeigt wird.

Kontrolliere doch einfach mal die einzelnen Bedingungen deiner Formel, dann wirst du sehen, woher das Ergebnis kommt.

Was mir noch auffällt ist, dass du bei deiner letzten WENN-Abfrage kein "Sonst" hast. Das ist zwar nicht schlimm, aber wenn keine Bedingung erfüllt ist, taucht dann FALSCH in der Zelle auf.

Gruß

M.O.
0 Punkte
Beantwortet von addeguddi Experte (1.9k Punkte)
Hallo M.O.

danke für deine Antwort. Habe nichts gefunden, dass dieser Bezug wo anders auftaucht.

Habe jetzt komplett neue Formel erstellt. diese funktioniert auch.

Das ist die Formel. War sehr aufwendig und das ist nur für ein Spieler jetzt muss ich das noch für 7 Spieler eingeben, da sich dei Bezugszellen für jeden Spieler ändern. Aber ich kann es nicht besser.

=WENN(UND($F$2=1;$E$7=6);ADB112;WENN(UND($F$2=1;$E$6=5);ACV112;WENN(UND($F$2=1;$E$5=4);ACP112;WENN(UND($F$2=1;$E$4=3);ACJ112;WENN(UND($F$2=1;$E$3=2);ACJ112;WENN(UND($F$2=1;$E$2=1);ACD112;WENN(UND($F$3=2;$E$7=6);ADW112;WENN(UND($F$3=2;$E$6=5);ADN112;WENN(UND($F$3=2;$E$5=4);ADE112;WENN(UND($F$3=2;$E$4=3);ACV112;WENN(UND($F$3=2;$E$3=2);ACM112;WENN(UND($F$3=2;$E$2=1);ACD112;WENN(UND($F$2=1;$E$2=1);ACD112;WENN(UND($F$4=3;$E$7=6);AEL112;WENN(UND($F$4=3;$E$6=5);ADZ112;WENN(UND($F$4=3;$E$5=4);ADN112;WENN(UND($F$4=3;$E$4=3);ADB112;WENN(UND($F$4=3;$E$3=2);ACP112;WENN(UND($F$4=3;$E$2=1);ACD112;WENN(UND($F$5=4;$E$7=6);AFP112;WENN(UND($F$5=4;$E$6=5);AEX112;WENN(UND($F$5=4;$E$5=4);AEF112;WENN(UND($F$5=4;$E$4=3);ADN112;WENN(UND($F$5=4;$E$3=2);ACV112;WENN(UND($F$5=4;$E$2=1);ACD112;WENN(UND($F$6=5;$E$7=6);AGT112;WENN(UND($F$6=5;$E$6=5);AFV112;WENN(UND($F$6=5;$E$5=4);AEX112;WENN(UND($F$6=5;$E$4=3);ADZ112;WENN(UND($F$6=5;$E$3=2);ADB112;WENN(UND($F$6=5;$E$2=1);ACD112)))))))))))))))))))))))))))))))

Oder gibt es für hier eine Bessere Lösung?

Gruß Adde.
0 Punkte
Beantwortet von m-o Profi (21.7k Punkte)

Hallo Adde,

mir ist nur aufgefallen, dass mitten in deiner Formel noch einmal eine WENN-Abfrage mit F2 steht:

=WENN(UND($F$2=1;$E$7=6);ADB112;WENN(UND($F$2=1;$E$6=5);ACV112;WENN(UND($F$2=1;$E$5=4);ACP112;WENN(UND($F$2=1;$E$4=3);ACJ112;WENN(UND($F$2=1;$E$3=2);ACJ112;WENN(UND($F$2=1;$E$2=1);ACD112;WENN(UND($F$3=2;$E$7=6);ADW112;WENN(UND($F$3=2;$E$6=5);ADN112;WENN(UND($F$3=2;$E$5=4);ADE112;WENN(UND($F$3=2;$E$4=3);ACV112;WENN(UND($F$3=2;$E$3=2);ACM112;WENN(UND($F$3=2;$E$2=1);ACD112;WENN(UND($F$2=1;$E$2=1);ACD112;WENN(UND($F$4=3;$E$7=6);AEL112;WENN(UND($F$4=3;$E$6=5);ADZ112;WENN(UND($F$4=3;$E$5=4);ADN112;WENN(UND($F$4=3;$E$4=3);ADB112;WENN(UND($F$4=3;$E$3=2);ACP112;WENN(UND($F$4=3;$E$2=1);ACD112;WENN(UND($F$5=4;$E$7=6);AFP112;WENN(UND($F$5=4;$E$6=5);AEX112;WENN(UND($F$5=4;$E$5=4);AEF112;WENN(UND($F$5=4;$E$4=3);ADN112;WENN(UND($F$5=4;$E$3=2);ACV112;WENN(UND($F$5=4;$E$2=1);ACD112;WENN(UND($F$6=5;$E$7=6);AGT112;WENN(UND($F$6=5;$E$6=5);AFV112;WENN(UND($F$6=5;$E$5=4);AEX112;WENN(UND($F$6=5;$E$4=3);ADZ112;WENN(UND($F$6=5;$E$3=2);ADB112;WENN(UND($F$6=5;$E$2=1);ACD112)))))))))))))))))))))))))))))))

Nur von der Formel her wüsste ich jetzt nicht, wie man diese - ohne Kenntnis deiner Tabelle - vereinfachen könnte.

Wenn z.B. die Zellen E2 bis E7 nacheinander beginnend mit Zelle E2 mit den Zahlen 1 bis 6 gefüllt werden, könnte man z.B.

=WENN(UND($F$2=1;$E$7=6);ADB112;WENN(UND($F$2=1;$E$6=5);ACV112;WENN(UND($F$2=1;$E$5=4);ACP112;WENN(UND($F$2=1;$E$4=3);ACJ112;WENN(UND($F$2=1;$E$3=2);ACJ112;WENN(UND($F$2=1;$E$2=1);ACD112;

durch

=WENN(F2=1;WAHL(MAX(E2:E7);ACD112;ACJ112;ACJ112;ACP112;ACV112;ADB112);"hier dann die nächsten Wenn-Bedingungen entsprechend")

ersetzen. So würde deine Verschachtelung deutlich übersichtlicher.

Gruß

M.O.

0 Punkte
Beantwortet von addeguddi Experte (1.9k Punkte)

Hallo M.O.

nochmals Danke für deine Mühe.

Das sieht gut aus, nur kurze Rückfrage und Erklärung zu F2 und E2:

E2 gleich Runde 1  und F2 gleich Anzahl Spieler  

Für die nächste Bedingung müsste ich ;WENN(F3=2;WAHL(MAX(E2:E7)ACG112 ::::::::: ist das richtig?

Gruß Adde

0 Punkte
Beantwortet von m-o Profi (21.7k Punkte)
Hallo Adde,

bei WAHL wird abhängig vom Wert (also hier die Zahlen 1 bis 6) der entsprechende Wert gewählt, also bei 1 der 1. Wert, bei 2 der 2. usw. Danach müsste das für Spieler 2 so lauten:

WENN(F3=2;WAHL(MAX(E2:E7);ACD112;ACM112;ACV112;ADE112;ADN112;ADW112)

Also wenn maximaler Wert E2:E7 ist gleich 1, dann nimm Wert aus Zelle ACD112, bei 2 dann Wert aus Zelle ACM112 usw. (entsprechend deiner obigen Formel und wenn ich nicht den Überblick verloren habe).

Gruß

M.O.
0 Punkte
Beantwortet von addeguddi Experte (1.9k Punkte)
Hallo M.O.

entschuldige bitte, das ich jetzt erste Antworte. Habe das was du mir geschrieben hast umgesetzt. Es funktioniert super. Habe das mit Wahl erst nicht verstanden. Jetzt verstehe ich es.

Nochmals vielen Dank.

Gruß Adde
...