92 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (2.1k Punkte)
Bearbeitet von addeguddi

Ein nettes Halo an das Forum,

Zu meiner Frage: 

Wenn in einer Zelle eine Formel hinterlegt ist und diese Werte sollen in anderer Zelle übernommen werden müssten dies eigentlich übernommen werden? 

Mein Beispiel:

In Zelle UO13 ist eine Zahl die in der Zelle UF2 angezeigt erden soll doch hier kommt "falsch" und ich verstehe das nicht.

Dies ist die Formel, die in der Zelle UF 2 hinterlegt ist

Kurze Erklärung zur Formel:

RE5 sagt aus wieviel Spieler es sind. I( meinem Fall sind es 3 Spieler also WENN($R$5=3;UO13;

=WENN($RE$5=2;UO8;WENN($R$5=3;UO13;WENN($RE$5=4;UO18;WENN($R$5=5;UO23;WENN($R$5=6;UO28;WENN($R$5=7;UO33;WENN($R$5=8;UO38)))))))

Und in der Zelle, in dem die Werte stehen und auch sichtbar sind, wird trotzdem in Zelle UF2 falsch angezeigt. Hier ein Beispiel: von der Zelle von diesen die Werte in UF2 angezeigt werden sollen.

1ter Spieler

3 Spieler 24 Punktzahl
1Würfe
72Durchschniit
24Gesamt Punktzahl 0 0

Und diese Formel wurde zum berechnen der Spieler erstellt.

Kurze Erklärung zu diese Formel:

RE5 Anzahl Spieler und RE4 = Anzahl Runden

=WENN(UND($RE$5=3;$RE$4=15);WG1;WENN(UND($RE$5=3;$RE$4=14);WC1;WENN(UND($RE$5=3;$RE$4=13);VX1;WENN(UND($RE$5=3;$RE$4=12);VU1;WENN(UND($RE$5=3;$RE$4=11);VS1;WENN(UND($RE$5=3;$RE$4=10);VQ1;WENN(UND($RE$5=3;$RE$4=9);VL1;WENN(UND($RE$5=3;$RE$4=8);VI1;WENN(UND($RE$5=3;$RE$4=7);VG1;WENN(UND($RE$5=3;$RE$4=6);VE1;WENN(UND($RE$5=3;$RE$4=5);UZ1;WENN(UND($RE$5=3;$RE$4=4);UW6;WENN(UND($RE$5=3;$RE$4=3);UU1;WENN(UND($RE$5=3;$RE$4=2);US1;WENN(UND($RE$5=3;$RE$4=1);UN1;)))))))))))))))

 Vielleicht hat jemand eine Lösung für mich, kann die Datei auch gerne hochladen.

Gruß Adde.

https://filehorst.de/d/eGAbDqcb

6 Antworten

0 Punkte
Beantwortet von addeguddi Experte (2.1k Punkte)
Hallo

habe den Fehler gefunden.

Habe anstatt re5 nur r5 eingetragen.

Gruß Adde
+1 Punkt
Beantwortet von

Guten Morgen

Würde Dir an der Stelle trotzdem WAHL vorschlagen damit wird die Formel deutlich kürzer ;) (und der Fehler wäre nicht passiert weil Du RE5 nur einmal verwendet hättest)

=WENN($RE$5=2;UO8;WENN($R$5=3;UO13;WENN($RE$5=4;UO18;WENN($R$5=5;UO23;WENN($R$5=6;UO28;WENN($R$5=7;UO33;WENN($R$5=8;UO38)))))))

=WAHL($RE$5;;UO8;UO13;UO18;UO23;UO28;UO33;UO38)

bei

=WENN(UND($RE$5=3;$RE$4=15);WG1;WENN(UND($RE$5=3;$RE$4=14);WC1;WENN(UND($RE$5=3;$RE$4=13);VX1;WENN(UND($RE$5=3;$RE$4=12);VU1;WENN(UND($RE$5=3;$RE$4=11);VS1;WENN(UND($RE$5=3;$RE$4=10);VQ1;WENN(UND($RE$5=3;$RE$4=9);VL1;WENN(UND($RE$5=3;$RE$4=8);VI1;WENN(UND($RE$5=3;$RE$4=7);VG1;WENN(UND($RE$5=3;$RE$4=6);VE1;WENN(UND($RE$5=3;$RE$4=5);UZ1;WENN(UND($RE$5=3;$RE$4=4);UW6;WENN(UND($RE$5=3;$RE$4=3);UU1;WENN(UND($RE$5=3;$RE$4=2);US1;WENN(UND($RE$5=3;$RE$4=1);UN1;)))))))))))))))

 müsste es auch gehen (schau es Dir aber lieber noch genauer an)

WENN($RE$5=3;WAHL($RE$4;UN1;US1;UU1;UW6;UZ1;VE1;VG1;VI1;VL1;VQ1;VS1;VU1;VX1;WC1;WG1); )

Ab Excel 2019 wäre noch ERSTERWERT zu erwähnen, das ist eine verbesserte Version von Wahl (vor allem für komplexere Abfragen)

0 Punkte
Beantwortet von addeguddi Experte (2.1k Punkte)

Hallo Anonym,

danke für deine Antwort. Habe es umgesetzt und alles OK.

Habe noch eine Frage zu der Formel WAHL:

Würde das auch mit dieser Formel gehen? Ich weiß nicht wie ich das eingeben sollte. Dies ist ein Cricket Spiel in Dart: 

Für 2 bis 8 Spieler Spieler erstellt, muss dies aber bis 8 Spieler erweitern. Habe nur ein Beispiel für 2 Spieler

Die Reihenfolge ändert sich auch. 

Hier muss man die Zahlen von 15, 16, 17, 18, 19, 20, und 25 Bulls Eyes  je 3 mal treffen. 

Diese Sagt aus, RE4 zeigt die der Anzahl Runden an und ist Spieler 1 und Runde 1. Hier ist es die 1te Runde und dass wenn AMB 8 ist 0, dann wird die Zahl 15 angezeigt wenn AMB 8 ist 1 dann wird -15, wenn AM 8 ist 2 dann wird 15/ wenn AM 8  ist 3 dann wird X angezeigt. Dies sagt aus ich habe die 3 mal getroffen die 15 getroffen habe.

Das ist für Runde 1 und für Spieler 1 

=WENN(UND($RE$4=1;AMB8=0);15;WENN(UND($RE$4=1;AMB8=1);$AMA$2;WENN(UND($RE$4=1;AMB8=2);$AMA$3;WENN(UND($RE$4=1;AMB8=3);$AMA$4))))

Für Runde 2 würde diese Formel erstellt:

=WENN(UND($RE$4=2;AMZ8=0);15;WENN(UND($RE$4=2;AMZ8=1);$AMA$2;WENN(UND($RE$4=2;AMZ8=2);$AMZ$3;WENN(UND($RE$4=2;AMZ8=3);$AMA$4))))WENN(UND($RE$4=1;AMB8=0);15;WENN(UND($RE$4=1;AMB8=1);$AMA$2;WENN(UND($RE$4=1;AMB8=2);$AMA$3;WENN(UND($RE$4=1;AMB8=3);$AMA$4))))

Usw. Die Zuordnung ändert sich je nach Runde.

Wäre toll wenn dies auch mit WAHL ginge.

Gruß Adde

 

0 Punkte
Beantwortet von addeguddi Experte (2.1k Punkte)

Hallo Anonym

Habe eine Lösung erstellt:

Dies ist jetzt nur für 2 Spieler.

Zuordnung für Spieler 1 die Zahl 15:

Bedeutung:

RE4 ist Runden Anzahl, RE5 Anzahl Spieler

AMB2 ist die Zuordnung, wird aus TR378 geholt:

In TR378 ist die Anzahl der Würfe

=WENN(TR378=1;"-15";WENN(TR378=2;"/15";WENN(TR378=3;"X";WENN(TR3<3;15;""))))

Bei Wahl wird die Rundenanzahl  geholt 

AMB2 ist runde 1 AME2 ist Runde 2 usw.

=WENN(UND($RE$4=1;$RE$5=2);AMB2;WAHL(AMB2;AME2;AMF2;AMI2;AMJ2;AMM2;AMN2;AMQ2;AMR2;AMU2))

Dies erweitere ich dann für 3, 4, 5, 6, 7, 8 mit 

=WENN(UND($RE$4=1;$RE$5=3); usw.

Könnte mir vorstellen, dass einer der sich in VBA auskennt viel einfacher erstellen könnte als ich. Leider verstehe ich die Eingaben nicht. 

Vielleicht, wenn das einer der Experten liest bietet er mir Hilfe an. Würde dann die Datei hochladen

Gruß Adde

0 Punkte
Beantwortet von

Hallo,

ich versuche mal mich rein zu denken, dein Excel ist ja schon ziemlich groß, da fällt das nicht ganz so einfach ;)

WAHL macht ja nichts anderes als mit einem Zähler x (1 Parameter), den x ten Parameter danach auszuwählen

somit würde

=WENN(UND($RE$4=1;AMB8=0);15;WENN(UND($RE$4=1;AMB8=1);$AMA$2;WENN(UND($RE$4=1;AMB8=2);$AMA$3;WENN(UND($RE$4=1;AMB8=3);$AMA$4))))

zu

=WENN($RE$4=1;WAHL(AMB8+1;15;$AMA$2;$AMA$3;$AMA$4))

da der TEIL $RE$4=1 ja in allen Wenns vorkommt

und

=WENN(UND($RE$4=2;AMZ8=0);15;WENN(UND($RE$4=2;AMZ8=1);$AMA$2;WENN(UND($RE$4=2;AMZ8=2);$AMZ$3;WENN(UND($RE$4=2;AMZ8=3);$AMA$4))))WENN(UND($RE$4=1;AMB8=0);15;WENN(UND($RE$4=1;AMB8=1);$AMA$2;WENN(UND($RE$4=1;AMB8=2);$AMA$3;WENN(UND($RE$4=1;AMB8=3);$AMA$4))))

würde dann zu

=WENN($RE$4=2;WAHL(AMZ8+1;15;$AMA$2;$AMZ$3;$AMA$4);WENN($RE$4=1;WAHL(AMB8+1;15;$AMA$2;$AMA$3;$AMA$4))

oder WAHLQUADRAT 

=WAHL($RE$4;WAHL(AMB8+1;15;$AMA$2;$AMA$3;$AMA$4);WAHL(AMZ8+1;15;$AMA$2;$AMZ$3;$AMA$4);)

werden (wobei die A s eventuell Z sein sollten ?)

als nächster Schritt käme dann in etwa 

=WENN($RE$4=3;WAHL(ANY8+1;15;$ANY$2;$ANY$3;$ANY$4)

dazu

0 Punkte
Beantwortet von addeguddi Experte (2.1k Punkte)
Hallo Anonym,

wen du möchtest, lade ich die Datei mal. Habe sie bis 6 Spieler fertig gestellt.

Gruß Ddde
...