66 Aufrufe
Gefragt in Tabellenkalkulation von sylvie Einsteiger_in (53 Punkte)
Hallo,

ich möchte gerne Rechnungen per Excel erstellen, bei denen der Preis einer Leistung je nach mitlaufendem Zähler variiert. Der Mengenzähler soll pro Jahr mitlaufen.

In den Stammdaten ist somit folgendes hinterlegt:

Staffel gültig von: 01.01.23 bis 31.12.23

Leistung 1      Menge ab 0           10 EUR

Leistung 1      Menge ab 100         5 EUR

Der Zähler soll bei jeder Rechnung mitlaufen. Z.B. greift bei den ersten drei Rechnungen noch der Preis von 10 Eur. Bei Rechnung vier steht der gesamte Zähler über 100. Somit wird der Preis von 5 Eur gezogen.

Ist der Preis eventuell mit der Formel "SUMMENPRODUKT" zu errechnen?

LG sylvie

3 Antworten

0 Punkte
Beantwortet von m-o Profi (21.9k Punkte)
Hallo Sylvie,

leider schreibst du nicht, wie deine Tabelle aufgebaut ist. Wenn ich aber deine Frage richtig interpretiere, kannst du die bisherigen Leistungen mit SUMMEWENN berechnen. Den Preis kannst du dann einfach über eine WENN-Formel ermitteln.

Gruß

M.O.
0 Punkte
Beantwortet von sylvie Einsteiger_in (53 Punkte)

Hallo M.O.

das erste Tabellenblatt ist aufgebaut wie ein Rechnungsformular mit Datum, Anschrift, Betreff, Leistungen, Mengen, Preis, Gesamtpreis. Der mittlere Bereich mit den Leistungsarten sieht ungefähr so aus:

Beispiel Rechnung 1

Leistungsart-Nr.    Leistungs-Bezeichnung    Menge    Einheit    Einzelpreis             Betrag

001                        Testleistung                      2             Stck                   10 EUR       20 EUR

Beispiel Rechnung 2

Leistungsart-Nr.    Leistungs-Bezeichnung    Menge    Einheit    Einzelpreis             Betrag

001                        Testleistung                      102        Stck                       5 EUR      510 EUR

Dann gibt es ein zweites Tabellenblatt mit sogenannten Stammdaten. Dort sind die Staffelpreise hinterlegt:

Leistungsart-Nr. Leistungs-Bezeichnung       Staffel gültig von:   bis:              Menge ab          Preis

001                        Testleistung                            01.01.2023               31.12.2023         0                 10 EUR
001                        Testleistung                            01.01.2023               31.12.2023         100              5  EUR

0 Punkte
Beantwortet von

Guten Morgen

Also angenommen Leistungsart steht in Spalte A, Menge in C und Einzelpreis in  E 

und wir sind in Zeile 2

und in den Stammdaten sind es die gleichen Spalten A, E, F und die Zeilen 1 bis 1000

dann sollte es so gehen in E2 die Formel

=SUMMENPRODUKT((A2=Stammdaten!$A$2:$A$1000)*(Stammdaten!$E$2:$E$1000>=C2)*(Stammdaten!$F$2:$F$1000))

bzw. (falls deine Excelversion SUMMEWENNS beinhaltet)

=SUMMEWENNS(Stammdaten!$F$2:$F$1000;Stammdaten!$A$2:$A$1000;A2;Stammdaten!$E$2:$E$1000;

">=" &C2)

...