221 Aufrufe
Gefragt in Tabellenkalkulation von jelena Mitglied (763 Punkte)
Bearbeitet von jelena
Hallo bitte um Hilfe. Ich habe eine beispieldatei hochgeladen. Es sollen auch die Daten aus Spalte R und S sowie V und W angezeigt (berechnet) werden. Danke

5 Antworten

0 Punkte
Beantwortet von m-o Profi (22.8k Punkte)
Hallo Jelena,

um welche Formel in welcher Spalte geht es denn?

Gruß

M.O.
0 Punkte
Beantwortet von
Guten Morgen,

Falls Du die (einigermaßen) neuste Version von Excel benutzt sollte es hiermit gehen

=EINDEUTIG(TEXTTEILEN(TEXTVERKETTEN(";";WAHR;N3:N32;R3:R32;V3:V32);;";"))

(überlaufende Matrixformel somit müssen die Zellen darunter frei sein oder es kommt #ÜBERLAUF)

ansonsten fürchte ich, dass man an einer Hilfspalte nur schwer vorbeikommen wird
0 Punkte
Beantwortet von jelena Mitglied (763 Punkte)
Bearbeitet von jelena

Hallo M.O. die Daten aus Spalte N und O, R und S sowie V und W sollen in Spalte Z und AA wie im Beispiel Z3 bis Z32 und AA3 bis AA32 angezeigt (berechnet) werden. Mit der derzeitigen Formel in Spalte Z und AA werden nur die Daten aus Spalte N und O berechnet.

0 Punkte
Beantwortet von
ausgewählt von jelena
 
Beste Antwort

Nachtrag 

Es geht auch mit der Formel die bereits verwendet wird, allerdings wird es wenn es noch mehr Spalten werden ziemlich lang

in Z3

=WENN(SUMME(ZÄHLENWENN($N$3:$N$32;Z$2:Z2))>=SUMME(($N$3:$N$32<>"")*1);
WENN(SUMME(ZÄHLENWENN($N$3:$N$32;Z$2:Z2))+SUMME(ZÄHLENWENN($R$3:$R$32;Z$2:Z2))>=SUMME(($N$3:$N$32<>"")*1)+SUMME(($R$3:$R$32<>"")*1);
WENN(SUMME(ZÄHLENWENN($N$3:$N$32;Z$2:Z2))+SUMME(ZÄHLENWENN($R$3:$R$32;Z$2:Z2))+SUMME(ZÄHLENWENN($V$3:$V$32;Z$2:Z2))>=SUMME(($N$3:$N$32<>"")*1)+SUMME(($R$3:$R$32<>"")*1)+SUMME(($V$3:$V$32<>"")*1);
"";
INDEX($V$3:$V$32;VERGLEICH(1;(ZÄHLENWENN(Z$2:Z2;$V$3:$V$32)=0)*($V$3:$V$32<>"");0)));
INDEX($R$3:$R$32;VERGLEICH(1;(ZÄHLENWENN(Z$2:Z2;$R$3:$R$32)=0)*($R$3:$R$32<>"");0)));
INDEX($N$3:$N$32;VERGLEICH(1;(ZÄHLENWENN(Z$2:Z2;$N$3:$N$32)=0)*($N$3:$N$32<>"");0)))

und in AA3 sollte man noch nachbessern auf 

=WENN(Z3="";"";SUMMEWENN($N$3:$W$32;Z3;$O$3:$O$32))

0 Punkte
Beantwortet von jelena Mitglied (763 Punkte)
Hallo M.O. die Formel im Nachtrag passt. Vielen Dank
...