244 Aufrufe
Gefragt in Tabellenkalkulation von revanchist Mitglied (183 Punkte)

Hallo
wer kann mir helfen, Werte in einer Spalte (die machmal aus 50 oder auch 500 oder noch mehr Zeilen bestehen kann) in umgekehrter Reihenfolge dastellen?
Beispiel:
vorhanden

in Zelle A4 steht die Zahl 17
in Zelle A5 steht die Zahl 8
in Zelle A6 steht die Zahl 36
in Zelle A7 steht die Zahl 12

nach Routineausführung ist die Reihenfolge
12
36
8
17

alles nur als Beispiel zur Verdeutlichung

Gesucht werden 3 Lösungen

1. es ist nur die Spalte A befüllt und zwar beginnend nach unten ab Zelle A4
  das Ergebnis nach Routine kann die vorhandenen Eintragungungen einfach überschreiben

2. es ist nur die Spalte A befüllt und zwar beginnend nach unten ab Zelle A4
  das Ergebnis nach Routine kann in Spalte C ab Zelle C4 nach unten stehen

3. wenn mehrere Spalten befüllt sind (alle ab Zeile 4 nach unten) soll die Routine
  in einem Schwupp alle befüllten Spalten (welche auch noch unterschiedlich hinsichtlich
  Zeilen- (resp. Zellen-) Belegung sind, ab der ersten freien Spalte +1 in umgedrehter Reihenfolge eintragen
 Hinweis: es können bis zu 35 Spalten vor Routineauslösung belegt sein.

Teil 2 folgt

5 Antworten

0 Punkte
Beantwortet von revanchist Mitglied (183 Punkte)

Hier ein paar Beispiele:

es müssen nicht zwingend für alle 3 Varianten VBA-Lösungen gefunden werden. Variante 3 wäre natürlich von großen Vorteil - aber kein Muss

Ciao der Revanchist

0 Punkte
Beantwortet von raisix Mitglied (287 Punkte)
Hallo Revanchist,

ich kann mit einer Formel-Lösung weiterhelfen:

Für die dritte Variante diese Formel in Zelle F4 eintragen:

=WENN(MAX(INDEX((A$1:A$1000<>"")*ZEILE(A$1:A$1000);0))-ZEILE($A3)>0;INDEX(A$4:A$100;MAX(INDEX((A$1:A$1000<>"")*ZEILE(A$1:A$1000);0))-ZEILE($A3);1);"")

Diese dann nach unten und rechts kopieren!

Die Formel kann entsprechend den Anforderungen angepasst und auf die Varianten 1-2 übertragen werden.

Beste Grüße
0 Punkte
Beantwortet von revanchist Mitglied (183 Punkte)
Hallo raisix

vielen Dank für die schnelle Hilfe. Eine formelbasierende Lösung ist absolut gut für das wo ich die Umkehr brauche.

Dachte nur, dass das mit Formeln vermutlich nicht zu lösen geht - daher die Frage nach einer VBA-Routine

Schönen Tag noch
der Revanchist
0 Punkte
Beantwortet von raisix Mitglied (287 Punkte)

Hallo Revanchist,

vielen Dank für die Rückmeldung. 

Freut mich, dass ich helfen konnte.

Bis bald

0 Punkte
Beantwortet von revanchist Mitglied (183 Punkte)
Bearbeitet von revanchist
hab denn Fehler gefunden und korrigieren können
Sorry !
...