213 Aufrufe
Gefragt in Tabellenkalkulation von jelena Mitglied (750 Punkte)

Guten Tag, da kann mir sicher jemand weiterhelfen. Ich suche die Summe

wo in zelle G3:G27 eine Zahl dann Summe aus zelle H3:H27

wo in zelle G31:G55 eine Zahl dann Summe aus zelle H31:H55

wo in zelle G59:G83 eine Zahl dann Summe aus zelle H59:H83

habe eine Datei (Beispiel Vorlage.xlsx) https://supportnet.de/forum/?qa=blob&qa_blobid=11991582436135390006 beigefügt. Danke

10 Antworten

0 Punkte
Beantwortet von beverly_ Experte (3.3k Punkte)
Hi Jelena,

versuche es mal mit dieser Formel: =INDEX(H:H;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)+25)

Bis später, Karin
0 Punkte
Beantwortet von jelena Mitglied (750 Punkte)
Hallo Karin funktioniert leider nicht, sobald ich z.B. die Zahl in Zelle G5 lösche, darf der Wert in Zelle U11 nur 1 anzeigen es darf nur die Summe angezeigt werden wo z.B.  in Zelle G5 und H5 eine Zahl enthalten ist. Danke
0 Punkte
Beantwortet von beverly_ Experte (3.3k Punkte)
Hi Jelena,

was macht es für einen Sinn, dass in H5 ein Wert steht wenn G5 leer ist???

=SUMMEWENNS(INDEX(H:H;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)):INDEX(H:H;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)+24);INDEX(G:G;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)):INDEX(G:G;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)+24);">"&0)

Bis später, Karin
0 Punkte
Beantwortet von jelena Mitglied (750 Punkte)
Hallo Karin wollte sagen es soll nur die Summe berechnet werden wenn in den gleichen Zellen G und H eine Zahl steht. Danke
0 Punkte
Beantwortet von beverly_ Experte (3.3k Punkte)
Hi Jelena,

hast du die neue Formel, die ich gepostet habe, denn schon schon getestet?

Bis später, Karin
0 Punkte
Beantwortet von jelena Mitglied (750 Punkte)
wieder angezeigt von jelena
Hallo Karin, die neue Formel passt genau Danke.
0 Punkte
Beantwortet von jelena Mitglied (750 Punkte)
wieder angezeigt von jelena

Hallo Karin, hätte da noch eine bitte. Es sollen aus dem jeweiligen Bereich die verschiedenen Texte oder Zahlen gezählt werden jedoch nur einmal z.B. in Zelle K3 steht Halle und in Zelle K25 steht auch Halle so soll der Text Halle nur einmal gezählt werden dasselbe soll auch mit Zahlen geschehen. Danke
wo in zelle G3:G27 eine Zahl dann Summe aus zelle K3:K27
wo in zelle G31:G55 eine Zahl dann Summe aus zelle K31:K55
wo in zelle G59:G83 eine Zahl dann Summe aus zelle K59:K83

0 Punkte
Beantwortet von jelena Mitglied (750 Punkte)
Bearbeitet von jelena

Hallo Karin, hätte da noch eine bitte. Es sollen aus dem jeweiligen Bereich die verschiedenen Texte oder Zahlen gezählt werden jedoch nur einmal z.B. in Zelle K3 steht Halle und in Zelle K25 steht auch Halle so soll der Text Halle nur einmal gezählt werden dasselbe soll auch mit Zahlen geschehen. Danke
wo in zelle G3:G27 eine Zahl dann Anzahl aus zelle K3:K27
wo in zelle G31:G55 eine Zahl dann Anzahl aus zelle K31:K55
wo in zelle G59:G83 eine Zahl dann Anzahl aus zelle K59:K83

0 Punkte
Beantwortet von
Guten Morgen,

es wäre jedenfalls hilfreich zu wissen, ob Du eine Excelversion benutzt, die die Funktion EINDEUTIG .beinhaltet oder nicht

Falls ja sollte es mit dem schon vorhandenen relativ "einfach"  sein

=ANZAHL2(EINDEUTIG(INDEX(K:K;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)):INDEX(K:K;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)+24)))-1

ansonsten eventuell

=SUMMENPRODUKT(1/ZÄHLENWENN(INDEX(K:K;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)):INDEX(K:K;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)+24);INDEX(K:K;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)):INDEX(K:K;VERGLEICH(DATUM(2023;7;ZEILE(A1));B:B;0)+24)&""))-1
0 Punkte
Beantwortet von jelena Mitglied (750 Punkte)
Bearbeitet von jelena

Hallo Guten Morgen, wo sehe ich, ob meine Excelversion die Funktion EINDEUTIG beinhaltet. Ich benutze Microsoft 365 version 2304.

Es sollen aus dem jeweiligen Bereich die verschiedenen Texte oder Zahlen gezählt werden jedoch nur einmal z.B. in Zelle K3 steht Halle und in Zelle K25 steht auch Halle so soll der Text Halle nur einmal gezählt werden dasselbe soll auch mit Zahlen geschehen. Danke
wo in zelle G3:G27 eine Zahl dann Anzahl aus zelle K3:K27
wo in zelle G31:G55 eine Zahl dann Anzahl aus zelle K31:K55
wo in zelle G59:G83 eine Zahl dann Anzahl aus zelle K59:K83. Danke

...