350 Aufrufe
Gefragt in Tabellenkalkulation von jelena Mitglied (769 Punkte)

Guten Tag, ich habe eine Beispiel Datei angehängt und bitte um eine Formel in Spalte Zelle P5 für Prozente, wenn z.B. in B4 bis M4 eine zahl dann Prozente von  Summe B5:L5 und Summe B4:L4 und nicht M4 usw. eine Formel in Spalte Zelle P11 für Prozente, wenn z.B. in B10 bis G10 eine zahl dann Prozente von Summe B11:F11 und Summe B10:F10 und nicht G10

https://supportnet.de/forum/?qa=blob&qa_blobid=12744279378900318440

6 Antworten

0 Punkte
Beantwortet von m-o Profi (22.8k Punkte)

Hallo Jelena,

du schreibst

wenn z.B. in B4 bis M4 eine zahl dann Prozente von  Summe B5:L5 und Summe B4:L4

Bedeutet das, wenn nur eine Zahl von B4 bis L4 steht, dann Summe von B5:K5 bzw. B4:K4?

Weiter unten schreibst du dann:

eine Formel in Spalte Zelle P11 für Prozente, wenn z.B. in B10 bis G10 eine zahl dann Prozente von Summe B11:F11 und Summe B10:F10

Das ist aber eine andere Formel wie oben. Ist das so gewollt?

Und kann es vorkommen, dass ein Monat dazwischen leer ist, z.B. Januar = Zahl, Februar = leer, März = Zahl?

Gruß

M.O.

0 Punkte
Beantwortet von jelena Mitglied (769 Punkte)
Hallo M.O. Wenn z.B. in B11 bis F11 eine zahl dann Prozente von Summe B11:F11 und Summe B10:F10, wie in meiner Beispiel Datei. Es  kann auch dazwischen ein Monat leer sein. Danke
0 Punkte
Beantwortet von
Guten Morgen,

Probiers mal mit

=SUMMEWENNS(B4:M4;C4:N4;"<>")/SUMMEWENNS(B5:M5;C4:N4;"<>")

oder

=SUMMEWENNS(B4:M4;B5:M5;"<>")/SUMMEWENNS(B5:M5;B5:M5;"<>")

in P5

(falls die Prozente verkehrt rum sind die Teile der Formel links und rechts des  /   vertauschen ;)
0 Punkte
Beantwortet von jelena Mitglied (769 Punkte)

Hallo, habe die Formel angepasst, =SUMMEWENNS(B5:M5;B5:M5;"<>")/SUMMEWENNS(B4:M4;B5:M5;"<>")-1 doch wenn z.B. in der nächsten Zeile keine Daten vorhanden sind dann kommt die Meldung #DIV/0! wie kann man das beheben. Danke

0 Punkte
Beantwortet von

Guten Morgen,

z.B. so

=WENN(SUMMEWENNS(B4:M4;B5:M5;"<>")=0;"";SUMMEWENNS(B5:M5;B5:M5;"<>")/SUMMEWENNS(B4:M4;B5:M5;"<>")-1)

wobei jetzt die Zelle leer angezeigt wird, falls dann o oder 100% oder .... kommen sollte einfach statt dem

"" einsetzten

0 Punkte
Beantwortet von jelena Mitglied (769 Punkte)

Hallo guten Tag, ich habe deine Formel so umgebaut WENN(SUMMEWENN(B5:M5;"<>")=0;"";SUMMEWENNS(B5:M5;B5:M5;"<>")/SUMMEWENNS(B4:M4;B5:M5;"<>")-1) und so soll es sein. Vielen Dank

...