115 Aufrufe
Gefragt in Tabellenkalkulation von
Bearbeitet

Servus,

Ich habe in der ersten Spalte zahlen stehen die wie folgt aussehen, zum Beispiel 1, 1/2, 1/a und so weiter. Die Zahlen und Buchstaben sind durch Schrägstrich getrennt, das ist keine Rechen Operation.

Jetzt soll in der nächsten Spalte die Zahlen und Buchstaben in eine vernünftiges Format gebracht werden. Und zwar sind die Zahlen vor dem Schrägstrich 5 stellig und nach dem Schrägstrich 4 stellig und jeweils vorn mit Nullen aufgefüllt. Ist kein Schrägstrich vorhanden wird es nur eine 5 stellige Zahl ohne Schrägstrich. Zum Beispiel 00001, 00001/0002, 00001/000a und so weiter.

Das ganze sollte sowohl in Excel als auch in Libre Office funktionieren.

Vielen Dank schon mal und schöne Pfingsten

Gruß Ines 

3 Antworten

0 Punkte
Beantwortet von
Versuchs mal mit
=WENN(WECHSELN(A1;"/";"")=A1;RECHTS("00000"&A1;5);RECHTS("00000"&LINKS(A1;SUCHEN("/";A1));5))
0 Punkte
Beantwortet von xlking Experte (1.6k Punkte)
Gegenvorschlag:

=WENN(ISTFEHLER(SUCHEN("/";A1));WIEDERHOLEN("0";5-LÄNGE(A1))&A1;WIEDERHOLEN("0";5-SUCHEN("/";A1)+1)&LINKS(A1;SUCHEN("/";A1)-1)&"/"&WIEDERHOLEN("0";4-LÄNGE(A1)+SUCHEN("/";A1))&RECHTS(A1;LÄNGE(A1)-SUCHEN("/";A1)))

Gruß Mr. K.
0 Punkte
Beantwortet von
Servus,

@LET, deine Formel endet immer beim Schrägstrich, also bei 1/a wird dann 00001/ ausgegeben.

@ xlking, das haut hin.

Vielen Dank euch beiden.
...