Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Wenn Dann- Verschachtelung





Frage

Hi Leute ich hab da ein komisches Problem Ich möchte folendes mit einer Wenn dann-Verschachtelung erreichen. Die Abfrage soll Prüfen wenn ich beispielsweise in einem Feld einen Wert eintrage(423) dann soll er mir die dazugehörige Kategorie anzeigen(hier: 3) <50 --> 1 <138 --> 2 <265 --> 3 <430 --> 4 <634 --> 5 <877 --> 6 <1159 --> 7 <1480 --> 8 .... Ich hatte mit dieser Formel angefangen: =WENN(B30<=50;"1";WENN(B30<=138;"2";WENN(B30<=265;" 3";WENN(B30<=430;"4";WENN(B30<=634;" 5";WENN(B30<=877;" 6";WENN(B30<=1159;" 7";WENN(B30<=1480;"8";"")))))))) ...aber irgentwie geht es nicht weiter.Gibt es vielleicht ein anderen Weg? Ich bin verzweifelt, kann mir jemand helfen

Antwort 1 von cort57

hi !

ich denke auf diese expertenfrage brauchst du ein experten forum.
ich mach schon lang mit dem rechner aber von einer "Wenn Dann- Verschachtelung" hab ich noch nichts gehört.

sorry, cort57

Antwort 2 von Aliba

Hi Jimmy,

erstmal muss ich dir bestätigen, obwohl ich nicht mit Rechner rummach, daß es WENN-DANN - Verschachtelungen gibt.

Ob diese in deinem Fall günstig sind ist halt fragwürdig.

Für deine Frage gibt es eine Menge Lösungsmöchlichkeiten.

Als ersten Ansatz nehmen wir halt einfach mal den VERGLEICH. Hierzu müssen wir jedoch die Begrenzungen der Wertbereiche von den Anfangswerten abhängig machen:

=VERGLEICH(A1;{0;50;138;265;430;634;877;1159;1480;...;x};1) würde nun das von Dir erwünschte Ergebnis bringen.

Je nachdem, wieviele Grenzen es hier noch gibt, würde sich eventuell das Anlegen einer Hilfstabelle empfehlen, auf die man per SVERWEIS, INDEX oder ähnlichem zugreifen könnte.

Natürlich ist das Ganze auch mit WENN-Dann-Verschchtelungen zu lösen, allerdings wäre das wohl die aufwendigste Lösung.

Antwort 3 von Saarbauer

Hallo,

grundsätzlich sind max. 7 Verschachtelungen in einer Zelle möglich.

Mit einer Hilfszelle ist eine Ausweitung entspechend möglich, da die Hilfzelle nur eine Wenn()-Funktion beansprucht und selbst 7 weteie Verschachtelungen beinhaltet.

Weitere Antworten zum Thema

https://supportnet.de/fullsearch?sn_key=%2BWenn&id_group=22&i...


Gruß

Helmut

Antwort 4 von rainberg

Hallo Helmut,

deine Aussage stimmt nicht ganz.
Mit einem Trick kannst du ohne Hilfszelle so viele Verschachtelungen herstellen, bis du die Übersicht verlierst.
Will damit nur sagen, dass es möglich ist, ob wohl man von diesem Unsinn keinen Gebrauch machen sollte.
Aliba hat ja schon die richtigen Wege aufgezeigt, trotzdem hier ein erweiterungsfähiges Beispiel.

=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;0)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;WENN(A1=13;13;WENN(A1=14;14;0)))))))+WENN(A1=15;15;WENN(A1=16;16;WENN(A1=17;17;WENN(A1=18;18;WENN(A1=19;19;WENN(A1=20;20;WENN(A1=21;21;0)))))))

Gruß
Rainer

Antwort 5 von Saarbauer

Hallo Rainer,

in der Form hast du recht, aber trotzdem

=
Zitat:
WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;0)))))))
+ WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;WENN(A1=13;13;WENN(A1=14;14;0)))))))+
Zitat:
WENN(A1=15;15;WENN(A1=16;16;WENN(A1=17;17;WENN(A1=18;18;WENN(A1=19;19;WENN(A1=20;20;WENN(A1=21;21;0)))))))


es handelt sich aber hier um 3*7 Verschachtelungen.

Ob das Ergebnis das Gleiche ist wie bei einer Gesamtverschachtelung (21), kann ich so auf die Schnelle nicht feststellen. Ich gehe aber davon aus, dass du das geprüft hast.

Gruß

Helmut

Antwort 6 von jimmy81

Danke an alle die sich bemühen das Problem zu beheben.

Aber ich finde wenn ich eine Wenn dann verschachtelung im Sinne von rainbergs Idee,(3*7 Verschachtelung)
dann hat es nicht denn gewünschten Effekt.

Er addiert ja praktisch alle Wenn Anweisungen, das soll er ja garnicht.

Es soll mir nur ein Wert liefern.
Wenn beispielsweise der Wert zwischen 0 und 50 ist soll er mir 1 liefern, usw.

Oder seh ich da was Falsch, ich hab das ausprobiert und es wurde micht der gewünsche Effekt ermittelt.

Ist das wirklich zu schwer was ich vorhabe? :-(

Antwort 7 von rainberg

Hallo Jimmy,

mein Beispiel, sollte nur verdeutlichen, dass mehr als 7 Verschachtelungen möglich sind.
Es handelt sich dabei auch nicht um 3*7 Verschachtelungen, sondern um 21 wobei das "+" als "Oder" zu verstehen ist. Also keine Addition.
Du fährst wirklich am besten, wenn du den Vorschlag von Aliba aufgreifst.

Gruß
Rainer

Antwort 8 von Jimmy81

Das Problem ist ich verstehe den Syntax von Aliba nicht.

=VERGLEICH(A1;{0;50;138;265;430;634;877;1159;1480;...;x};1)

Ich hatte die Formel kopiert, aber bei mir gab es eine Fehlermeldung. Was bedeutet daß "Vergleich"?

Könnte jemand oder Aliba die Formel so schreiben das das Problem (ganz oben) gelöst wird.

zwischen 0 - 50 --> 1
zwischen 51 - 138 --> 2
zwischen 139 - 264 --> 3
usw.

Ich habe echt keine Ahnung.

Vielen Dank im Voraus

Antwort 9 von rainberg

Hallo Jimmy,

ich bin sicher, Aliba wird dir antworten, wenn du ihn konkret fragst, was du nicht verstanden hast.

Gruß
Rainer

Antwort 10 von Aliba

Hi Jimmy,

=VERGLEICH(A1;{0;50;138;265;430;634;877;1159;1480;...;x};1)

SO wie die Formel jetzt da steht, wird sie auch nicht funktionieren. Denn der Teil ;...;x
steht für dein ... usw , das Du geschrieben hast.
Ich weiss ja auch nicht, wie Deine Datenreihe nun weitergeht. Deshalb war dieser Formelteil eigentlich gedacht, daß Du hier Deine Datenreihe weiterführst.

Was macht die Formel:

Sie vergleicht den Eintrag von A1 mit der Datenreihe in den geschweiften Klammern (du könntest diese Zahlen auch in eine Hilfsspalte , z.B. V1 bis V100 eintragen und dann anstelle der geschweiften Klammern und des Inhaltes dann V1:V100 schreiben)

Also die Formel vergleicht den Eintrag aus A1 mit der Datenreihe oder den Einträgen in V1 bis V100
und sucht nach dem Wert aus A1. Wichtig ist nun der Eintrag in der Formel ;1 denn dieser sagt aus, wie der Wert in der Datenreihe gesucht werden soll.
Die 1 sagt aus, daß die Daten in aufsteigender Reihenfolge vorliegen.
Wenn nun der Wert in der Datenreihe gefunden wird, wird die Position innerhalb der Datenreihe geliefert.
Wird der Wert nicht exakt gefunden, dann wird die Position des nächstkleineren Wertes geliefert.
Deshalb muss in diesem Fall auch die Datenreihe mit der 0 begonnen werden.

CU Aliba

Antwort 11 von Locke

Mal was Anderes:
Du hast hier 8 Zeilen und 2 Spalten angegeben und darunter sind Punkte........
Symbolisieren die, dass das noch weiter geführt werden soll?
Wenn ja und auch aus dem Grund der Flexibilität (falls die die Zahlen mal ändern sollten) hilftz Dir die SVERWEIS-Formel viel einfacher an das Ziel.
Du musst dazu nur irgendwo die Werte hinterlegen.
Ich habe hier ein Beispiel:
In Zellen A1 bis A8 stehen die Werte und in Zellen B1 bis B8 die dazugehörigen Kategorien.
Der Wert den Du eingibst ist bei meinem Beispiel in C1.
Nun lautet die Formel:

=SVERWEIS(C1;A1:B8;2;WAHR)

Damit kannst Du die Werte beliebig ändern oder das Ganze nach unten erweitern wie Du willst.

Gruß
Locke

Antwort 12 von Jimmy81

Danke Aliba

Ich hab jetzt den Syntax verstanden, und umgesetzt.
es funktioniert wunderbar.

Vielen Dank für deine Mühe.

Bye

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: