Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Texte aus verschiedenen Tabellenblättern zusammenführen





Frage

Hallo, ich habe folgendes Problem: ich habe eine Tabellenkalkulation mit mehreren Tabellenblättern. Nun habe ich in dem einen Tabellenblatt eine Liste unter anderem mit einer Spalte von Telefonnummern, einer Spalte mit Namen und noch weitere Spalten, aber keine Ortsnamen. In einem anderen Tabellenblatt ist eine ähnliche Liste, allerdings auch mit Ortsnamen und den Telefonnummern. Ich möchte nun anhand der Telefonnummern die zugehörigen Wohnorte im ersten Tabellenblatt automatisch ergänzen, weiß aber nicht, wie ich das mit einer Formel anstellen soll. Ich hoffe ich habe mich verständlich ausgedrückt. Bei Fragen einfach nochmal schreiben. Vielen Dank schon mal und schöne Grüße Christian May

Antwort 1 von rainberg

Hallo Christian,

das geht mit den Funktionen SVERWEIS() oder INDEX() in Verbindung mit VERGLEICH(), je nach dem wie die Spalten in den Tabellen angeordnet sind.
Eine genauere Auskunft ist anhand deiner spärlichen Info im Moment nicht möglich.
Gruß
Rainer

Antwort 2 von 5163130

Hallo Rainer,

ich habe auf dem ersten Tabellenblatt in der ersten Spalte eine Telefonnummer. In der zweiten Spalte ist der Name und in der dritten Spalte die email-Adresse

Auf dem zweiten Tabellenblatt habe ich ebenfalls die Telefonnummer in der ersten Spalte, in der zweiten Spalte den Straßennamen und Hausnummer und in der dritten Spalte den jeweiligen Wohnort.

Nun möchte ich die Daten in einer Tabelle vereinen, indem ich mit Hilfe eines Vergleiches die Wohnorte anhand der jeweiligen Telefonnummer zuordne.

Der Wohnort soll in die vierte Spalte im ersten Tabellenblatt übernommen werden und zwar genau in die Zeile, in der die dazugehörige Telefonnummer steht.

Leider habe ich in beiden Tabellenfeldern nicht genau gleich viele Daten eingepflegt, so dass die Zuordnung nicht einfach über die Ordnung der alphabetischen Reihenfolge erfolgen kann.

Bitte gib mir nochmal bescheid, wie das mit der Verbindung SVERWEIS, INDEX und VERGLEICH funktionieren soll.

Danke.

Gruß Christian

Antwort 3 von rainberg

Hallo Christian,

schreibe diese Formel in D2 von Tabelle1 und kopiere sie nach Bedarf nach unten.

=WENN(ISTNV(SVERWEIS($A2;Tabelle2!$A:$C;3;0));"Nummer nicht vorhanden";SVERWEIS($A2;Tabelle2!$A:$C;3;0))

Zeile1 beider Tabellen ist für Zeilenüberschriften gedacht.

Gruß
Rainer

Antwort 4 von rainberg

Hallo Christian,

hier noch die Lösung mit INDEX und VERGLEICH

=WENN(ISTNV(VERGLEICH(Tabelle1!$A2;Tabelle2!$A:$A;0));"Nummer nicht vorhanden";INDEX(Tabelle2!$C:$C;VERGLEICH(Tabelle1!$A2;Tabelle2!$A:$A;0)))

Diese Formel kann man auch verwenden, wenn das
Suchkriterium nicht in der ersten Spalte der Matrix steht, was ja bei SVERWEIS Bedingung ist.

Mach dich dazu mal in der Onlinehilfe schlau.

Gruß
Rainer

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: