Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel, wie mach ich eine Wenn-Funktion, dieprüft,ob Text vorhanden ist





Frage

Also,ich habe Folgendes Problem, Ich hab inmeinem Excel ne Tabellemit werten... naja und ich will jetzt das, wenn ich in B2 Text habe egal was, das dann in A2 ne 1 steht. Please HELP Dann kommt zwar noch was,aber das sollte kein problem sein.

Antwort 1 von K-D

Hi,

If Me.Cells(2, 2) <> "" Then
Me.Cells(1,1) = 1
End If

Also Test auf leere Zeichenkette sind 2 Anführungszeichen nacheinander.

Mit den Nummern bin ich mir nicht sicher. Ich werd mir wohl nie merken, wann in VBA mit 0 und wann mit 1 angefangen wird zu zählen.

Gruß
K-D

Antwort 2 von rainberg

Hallo Held,

schreibe in A2 diese Formel

=WENN(ISTTEXT(B2);1;"")

Gruß
Rainer

Antwort 3 von The_Hero

Vielen Dank K-D und Rainer ihr habt mir sehr geholfen!

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: