Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Problem mit rang





Frage

Hallo, ich möchte Werte in der Spalte B fortlaufend mit einer Rangzahl versehen. Allerdings gibt es mehrere doppelte Werte. Wenn ich die Formel rang benutze werden den doppelten Werten die selben Ränge zugeordnet. Was kann ich machen, damit jedem Werte ein anderer Rang zugeordnet wird? Die Reihenfolge bei der Rangzuordnung der gleichen Werte dabei egal. Vielen Dank im Voraus Gruß lilie

Antwort 1 von Primut

Hi Lilie,

ich hab das nur mit einer Hilfsspalte hinbekommen,
da ja erstmal der Rang ermittelt werden muß und dann alle ermittelten Ränge auf Dopplung verglichen werden müssen.
Als Beispiel:
Deine zu "rangierenden" Werten stehen in Spalte B in meinem Beispiel B1:B20.
Asl Hilfsspalte richtest du C ein, kannst sie ja auch nachher ausblenden. Dort in C1 eintragen: =RANG(B1;$B$1:$B$20;1) und bis C20 runterkopieren. Hier wird der auch doppelte Rang erstmal festgestellt (Klar, die 1 steht für kleinster Wert Rang1).
Nun schreibst du in Spalte D, D1 =C1+ZÄHLENWENN($C$1:C1;C1)-1 und kopierst das auch bis D20. Damit hast du dort eine chronologische Rangreihenfolge ohne Doppelungen.

Gruß Primut

Antwort 2 von rainberg

Hallo lilie.

werden die Werte in Spalte B per Hand eingetragen oder sind dies Formelergebnisse?
Wenn Formelergebnisse, bitte Formel posten.

Gruß
Rainer

Antwort 3 von Primut

Hi Rainer,

ich muß ja doch mal nachfragen. Was macht das denn für einen Unterschied?

Gruß Primut

Antwort 4 von CaroS

Hallo lilie,

Du hast z. B. in B1:B20 Zahlen, schreibst in C1

=RANG(B1; $1:B$20; 1) + ZÄHLENWENN(B$1:B1; B1) - 1

und kopierst die Formel bis C20. Die obere (20) und untere (1) Grenze kannst Du natürlich anpassen.

Gruß
CaroS

Antwort 5 von Primut

Hi Caro,

ok, sauber, da hab ich Excel tatsächlich unterschätzt und es geht auch ohne Hilfsspalte, d.h. ich hab´s erst gar nicht ohne versucht, aber Versuch macht klug. ;-)
Dein erster Bereich muß natürlich mit Spaltenbezug sein:
=RANG(B1; B$1:B$20; 1)...

Gruß Primut

Antwort 6 von CaroS

Hallo Primut,

danke für die Korrektur. Da habe ich doch bei der Verschönerung vor dem Absenden noch ein paar mal die Vorschau aufgerufen und fand schließlich, dass jeweils ein Leerzeichen nach dem Semikolon der Lesbarkeit auch nicht schaden könnte. Also, gedacht - getan. Leider war dabei der Einfügen-Modus der Tastatur versehentlich eingeschaltet, was ich erst gegen Ende der Formel bemerkt habe, und dann passiert sowas.

Die direkte Kopie aus Excel heraus wäre fehlerfrei gewesen, aber warum klaut mir Excel auch jedesmal meine Leerzeichen!

Das erklärt auch, warum andere immer eher fertig sind mit ihren Formeln. Erst habe ich in meinen Excel-Testdateien nach der Formel gesucht, weil ich genau wusste, dass ich das vor ein paar Tagen schon einmal gemacht hatte, dann habe ich es "schnell" neu geschrieben, getestet, kopiert, verschönert und dann war´s aus mit "schnell".

Und bei all den Ähnlichkeiten zu Euch beiden weiß keiner, dass das wirklich alles auf meinem eigenen Mist gewachsen ist, selbst die Übereinstimmung bei der Wahl von B1:B20 ist purer Zufall.

Euch allen noch ein schönes Wochenende!
CaroS

Antwort 7 von rainberg

Hallo Primut,

wie Du siehst, gibt es immer mehrere Lösungswege.

Mein Vorschlag (bei Formelergebnis in Spalte B) wäre gewesen, zum Formelergebnis einen unmerklichen Faktor zu addieren.

Angenommen die Werte enstehen durch

=SUMME(C1:Z1)

dann könte man diese Formel erweitern in

=SUMME(C1:Z1)+ZEILE()%%

Damit wird ebenfalls eine Hilfsspalte vermieten und bei entsprechender Zellformatierung ist dieser Korrekturwert optisch nicht wahrnehmbar.
Wenn die Rangfolge bei mehreren gleichen Ergebnissen an Kriterien gebunden werden soll, kann man statt ZEILE() das entsprechende Kriterium einsetzen, kommt eben darauf an, was man an Daten vorliegen hat.

Gruß
Rainer

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: