Supportnet Computer
Planet of Tech

Supportnet / Forum / WindowsVista

Keine Treiberinstallation automatische erkannter Geräte mehr möglich (Skurile Fehlermeldung)





Frage

Hallo allerseits, ich bekomme seit einiger Zeit eine skurille Fehlermeldung wenn neue Hardware (Bluetooth Headset, USB Webcam, USB Drucker) erkannt wird und kann die entsprechenden Treiber nicht installieren. Ich habe bereits einige Zeit damit verbracht im Internet sowohl auf englischen wie auch auf deutschen Seiten nach ähnlichen Vorkommnissen zu fahnden - vergeblich. Meistens handelt es sich dabei um die selbe Fehlermeldung, jedoch auf Dateierweiterung bezogen. Der Fehler äussert sich wie folgt: Der allseits bekannte Dialog "Neue Hardware gefunden" öffnet sich, ich wähle aus dass ich einen Treiber installieren will ("Treiber suchen und installieren (Empfohlen)"). Daraufhin taucht eine Fehlermeldung mehrmals auf die sich entweder auf rundll32 oder auf eine "newdev.exe" im system32 Ordner bezieht. Im Wortlaut: >>Der Datei ist kein Programm zur Durchführung dieser Aktion zugeordnet. Erstellen Sie eine Zuordnung in der "Systemsteuerung" unter "Zuordnung festlegen" << Eine manuelle Installation der Treiber über den Gerätemanager ist teilweise möglich. Bei meinem neuen Drucker war dies leider nicht der Fall, auch das Bluetooth headset lässt sich nicht über diese Methode installieren. Leider besteht bei Vista keine Möglichkeit mehr einfach nur "drüberzuinstallieren" und die vielleicht durch Installationen beschädigten Dateien einfach zu ersetzen. Ich bin mit meinem Latein echt am Ende... Thx in advance! Greetz

Antwort 1 von Dethix

Nachtrag:

Beim Konfigurieren der WLAN Einstellungen für die Uni is das gleiche noch einmal aufgetaucht: Bei der Konfiguration der Einstellungen für SecureW2 TTLS Authentifikation, wobei anscheind auf eine .exe Datei zugegriffen wird. Was zur Hölle is da los?? :(

Antwort 2 von TippInfo

Windows Vista ist ein junges Betriebssystem und
dem entsprechend auch Pflegebedürftig.....

Das heißt im Klartext....
Man muß (oder sollte) alte installationspfade manuell
aus der Registry entfernen, dann hat man bei der automatischen suche nach
Treibern nicht das Problem, dass in alten installationspfaden
irgendwas installiert wird...

Automatische suche nach Treibern verwende ich nur wo
ich weiß das diese gesuchten Treiber auch vorhanden sind...

z.B.: Windows-Intern, USB Festplatten, USB-Stick, Monitore und das war's auch schon...

Webcam, Netzwerkkarten, Graka, Modem, Drucker, Sound etc.....
bei solchen Geräten lieber beim Hersteller nach gucken ob es
VISTA Treiber gibt und dann diese installieren.....

Wenn Windows VISTA ..online keine Treiber findet, dann
schaut es auch onboard nicht besonders Rosig aus....

Also nicht wundern wenn VISTA, Ramsch installiert....

Antwort 3 von TippInfo

Bei installation oder konfiguration, kann
ma ja wunderbar vorher Sicherheitspunkte erstellen...
Wenn dann was schief geht, kann ma auf diese Sicherungen
zurück greifen und alles ist wieder in Butter....

Antwort 4 von Dethix

Ich glaub du hast mich falsch verstanden ... die automatische suche is nich der Punkt, die benutz ich an und für sich auch nich. Ne alternative bleibt bei dem dialog nur garnicht.

Der Treiber wird bei der Installation VOR Erkennung des Druckers installiert. Nach der Theorie sollte er also bei o.g. auswahl den bereits installierten Treiber finden und dem Gerät zuordnen.

So weit kommts aber nicht mal, davor taucht oben beschriebene Problematik auf.
Meine Erklärung dafür ist, dass er versucht die .exe Datei zu interpretieren. Sprich, er versucht - wenn die Datei aus einem anderen Programm "gecalled" wird die Datei mit einem bestimmten Programm "aufzumachen" und merkt sozusagen nicht dass es sich hierbei um eine ausführbare Datei handelt. Irgendwas scheint es da zerschossen zu haben. Mein Anliegen wäre eben den Ursprungszustand z.B. durch ersetzen bestimmter dateien oder ändern von Registryeinträgen wieder herzustellen.

Die Restore Points helfen mir nix, das Problem besteht schon recht lange und hatte keine Zeit mich darum zu kümmern, sprich für mich ist nichtmehr nachvollziehbar was dieses Problem verursacht haben könnte... wenn da vllt. jemand ne idee hat ?

Antwort 5 von Opa53

Moin,

aus meiner Sicht ist es nicht ganz eindeutig, ob es sich um ein plötzlich aufgetauchtes 'Fehlverhalten' von Vista handelt oder an der neu zu installierenden Hardware liegt.

Bei deinem Drucker könnte es sich z.B. darum handeln, dass die Sicherheitsrichlinien von Vista es nicht zulassen, dass bestimmte Dateien in das Systemverzeichnis geschrieben werden und dann klappt es auch nicht mit der Erkennung der Treiber. Bei vistakompatiblen Druckern dürfte das nicht passieren, aber dazu hast du leider keine Angaben gemacht.

Eine Möglichkeit wäre in solch einem Fall, die vorherige Installation der Drucker-Treiber 'Als Administrator' auszuführen, Genaueres kann dir hierzu aber eventuell der Support des Herstellers verraten. Bei relativ neuen Druckern, die aber nicht ausdrücklich für Vista angeboten werden, wird es oftmals aktualisierte Treiber und/oder Installationsanweisungen bei den Herstellern geben.

Gut möglich, dass du das alles schon beachtet hast, aber erwähnt hast du es nicht.

Gruß vom
Opa

Antwort 6 von Dethix

Hallo nochmal,

ein hardwarespezifisches Problem kann ich eigentlich ausschließen. Der Drucker (Canon Pixma iP 5300) wird definitiv von Vista unterstützt, Canon bietet dafür spezielle Treiber an die ich auch benutze. Sorry dass ich das nicht erwähnt habe.
Ebenfalls gegen ein hardwarespezifisches Problem spricht, dass die Webcam bereits schon einmal mit Vista funktioniert hat und das eine ähnliche Fehlermeldung beim Aufruf des Konfigurationstools von Secure W2 (zur WLAN Authentifikation) auftritt, was eigentlich nichts mehr direkt mit hardware zu tun hat.

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: