Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Wenn Dann Funktion Spalte minus Spalte





Frage

Hallo Zusammen, mich plagt seit heute morgen eine Tabelle, die z.B. wie folgt aussehen könnte: Spalte B = Portokosten inkl. Verpackung Spalte C = Portokosten ohne Verpackung Spalte D = Suchkriterium wie "F" oder "E" und in Zelle B2 steht nun meine Formel. Ich möchte mit einer Wennfunktion bewirken, dass Excel mir Spalte B - Spalte C ausrechnet, wenn in Spalte D z.B. "F" steht... Und dann soll er mir die Summe der ganzen Spalte ausspucken, wenn in D jeweils das Suchkriterium steht. Ich habe es mit folgenden Formeln versucht, leider erfolglos! =WENN(D1:D9="F";SUMME(B1:B9)-SUMME(C1:C9);"") =WENN(D1:D9="F";B1:B9-C1:C9;"") mit SUMMEWENN hat es auchnich funktioniert... Über eine Hilfszelle in der ich die Summe der jeweiligen Spalte rechne, würde ich an das Ergebnis kommen. Jedoch möchte ich gerne alles in einer Formel haben. Bin über jede Hilfe sehr Dankbar =)

Antwort 1 von rainberg

Hallo,

=SUMMEWENN(D1:D9;"F";B1:B9)-SUMMEWENN(D1:D9;"F";C1:C9)

sollte funktionieren.

Gruß
Rainer

Antwort 2 von MaxMustermann=)

Hey vielen Dank!!!

Es funktioniert einwandfrei,

so schnell hätte ich mit einer Antwort nicht gerechnet ;-)

Schöne Grüße

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: