Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel: ZÄHLENWENN





Frage

Hi, ich möchte aus einer Spalte bestimmte Werte auslesen, und zwar nicht nur Werte, die zB. >5 sind, sondern gleichzeitig auch noch <9, also Werte, die in dem Bereich zwischen 5 und 9 liegen. Geht das ganz normal mit ZÄHLENWENN? habe nix gefunden, womit ich die zwei auszulesenden Werte verbinden kann , zB. mit UND ?? Hilfe!

Antwort 1 von M.O.

Hallo,

das musst du mit SUMMENPRODUKT lösen, z.B. so:

=SUMMENPRODUKT((A1:A20>5)*(A1:A20<9))

Den betreffenden Bereich musst du natürlich anpassen.

Gruß

M.O.

Antwort 2 von jaysetsfire

cool, scheint zu funktionieren! danke!

Antwort 3 von jaysetsfire

äh hm , und was mach ich, wenn ich negative werte dabei hab? zB. will ich die Werte zählen, die im Bereich zw. -3,3 und +0,7 liegen. Dann gehts nicht....

Antwort 4 von M.O.

Hallo,

dann müsste deine Formel so aussehen:

=SUMMENPRODUKT((A1:A20>-3,3)*(A1:A20<0,7))

Gruß

M.O.

Antwort 5 von jaysetsfire

jo, die Formel akzeptiert er, aber das Ergebnis, das ausgegeben wird, ist falsch (vll wegen dem minus?)...
nochmal zum ZÄHLENWENN: damit gehts nicht? man kann damit also nicht werte zählen, die durch 2 grenzen gleichzeitig bestimmt sind?

Antwort 6 von Aliba

Hi,

also am minus liegt es sicherlich nicht. Summenprodukt sollte eigentlich funktionieren.
Kannst auch mal eine Beispieldatei unter
www.netupload.de
ins Nezt stellen, wo SUmmenprodukt nicht funzt.

Ansonsten gehts mit Umwegen über ZÄHLENWENN:

=ZÄHLENWENN(A1:A20;">3,3")-ZÄHLENWENN(A1:A2;">=0,7")

CU Aliba

Antwort 7 von Aliba

Hi,

nochmal ich. Soll natürlich A1:A20 heissen beim 2. Zählenwenn

CU Aliba

Antwort 8 von meinTipp

Hallo,

wenn du Leerzellen in dem Suchbereich hast, so werden sie als 0 interpretiert und mitgezählt.

Gruss Rolf

Antwort 9 von jaysetsfire

AHHHHH
danke an Aliba und an Rolf (liegt sicher an den Leerstellen!). muss mich jetzt nur entscheiden, welche methode ich verwende...^^

Antwort 10 von meinTipp

dann versuch es doch einmal mit
=SUMMENPRODUKT((A1:A20>-3,3)*(A1:A20<0,7)*(A1:A20<>""))

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: