Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Spalte durchsuchen, wenn richtige Spalte, dann Zeilen auf Kriterien überprüfen





Frage

Hallo, ich möchte gerne eine umfangreiche Tabelle auswerten: vereinfachte Form: Spalten a bis d Zeile 1 bis 100 In einer Matrix sollen nun die Spalten a und c durchsucht werden (dynamisch, je nach Eingabe - kann also auch a und d sein). In den Zeilen gibt es ganzzahlige Werte zwischen 1 und 3. Diese sollen in einer Überkreuztabelle dargestellt werden, wann z.B. in a1 steht 1 und in c1 auch eine 1, dann steht in der Matrix auch eine 1, weil diese Zahl dann gezählt wird. Mein Problem dabei ist, ich weiß nicht, wie ich dynamisch die Spalten formatieren kann und der dann immer die zugehörige Spalte nach den Werten durchsucht und diese zusammenzählt. Wäre super, wenn mir da jemand helfen könnte. Bei Fragen, bitte einfach nochmal kurz melden. Vielen Dank schon mal. MfG Christian

Antwort 1 von Saarbauer

Hallo,

so ganz verstanden habe ich es nicht, aber könnte mit Summenprodukt() funktionieren.

Vielleicht kannst du die Tabelle oder iene Beispieltabelle hier einstellen

http://www.netupload.de/

und den Link hier hinterlegen

Gruß

Helmut

Antwort 2 von 5163130

Hallo Helmut,

danke für den Tipp über netupload.

Ich habe es mal so genau beschrieben wie möglich. Die Anleitung ist in der Datei.

Vielen Dank schon mal.

Ciao Christian

Antwort 3 von 5163130

.... upps den Link vergessen...

http://www.netupload.de/detail.php?img=1cf32e1a726aafab20ea8360397224f2.xls

Ciao Christian

Antwort 4 von 5163130

hier noch eine etwas aussagefähigere Datei ....

http://www.netupload.de/detail.php?img=8e3d36d00d31f1f4e543149751b0ada5.xls

Vielen Dank für die Hilfe schon mal ...

Antwort 5 von Saarbauer

Hallo,

ist von mir leider nicht nachvollziehbar was du da vorhast.

Gruß

Helmut

Antwort 6 von Aliba

Hi,

folgende Formel in R8 und dann nach rechts und unten kopiert:

=SUMMENPRODUKT((Tabelle1!$Q8=BEREICH.VERSCHIEBEN($A$1;0;VERGLEICH($P$8;$A$1:$M$1;0)-1;28;1))*(Tabelle1!R$7=BEREICH.VERSCHIEBEN($A$1;0;VERGLEICH($T$6;$A$1:$M$1;0)-1;28;1)))

CU Aliba

Antwort 7 von Saarbauer

Hallo,

inzwischen kam mir auch die Idee mit Berreich verschieben, aber @Aliba hat aus meiner Sicht die richtige Lösung, aber kam dann nicht richtig weiter.

Nehme an das Problem ist damit erledigt

Gruß

Helmut

Antwort 8 von 5163130

Vielen Dank für Eure Hilfe.
Hat super geklappt.

Ciao Christian