Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel Formeln





Frage

Hallo Ich habe eine Frage wegen funktionen die ich verschmelzen muss. Folgendes: a b c d 1 01 02 03 04 2 03 04 09 10 3 05 06 07 08 4 07 08 01 02 5 09 10 05 06 So ich muss a1 und b1 bis a5 und b5 vergleichen mit c1 und d1 bis d1 und d5. Die Einträge sind in verschiedenen Zeilen und logischerweise auch in verschieden Spalten. Diese müsste ich vergleichen und brauche eine Ausgabe ob sie zusammen passen oder nicht. Welche Funktionen muss ich da verwenden. Ich hoffe das ihr mir helfen könnt. Danke jetzt schon. Lg Martin

Antwort 1 von Saarbauer

Hallo,

Diese müsste ich vergleichen und brauche eine Ausgabe ob sie zusammen passen oder nicht.

In welcher Form vergleichen ?
Wie zusammenpassen ?

Deine Angaben reichen nicht aus, eine genauere Erläuterung ist erforderlich

Gruß

Helmut

Antwort 2 von Martin1563

Hallo Saarbauer

Original 1 Original 2
CNHGG00184 CNKGH03770
CNHGG00185 CNKGH04337
CNHGH03033 CNKGH04342
CNHGH03045 CNKGH04380
CNHGH04744 CNKGJ00372
CNKGH02453 CNKGJ00443
CNKGH03770 CNKGJ00449
CNKGH04337 CNMGH12906
CNKGH04342 CNMGH13651
CNKGH04380 CNMGH13735

Diese Beiden Spalten gehören verglichen und es soll wenn möglich eine Ausgabe erfolgen ob es zwei gleiche gibt oder nicht.
Wenn ja sollte etwas passieren und wenn nein ebenfalls.
Wenn es nicht zu schwer wird könnte mann auch die, die gleich sind in eine neue Tabelle einfügen.
das wäre überhaupt genial.

Danke Martin

Antwort 3 von Saarbauer

hallo,

zum Zählen in C2

=ZÄHLENWENN($B:$B;A2)

der Rest, hab ich im Moment keine Idee

Gruß

Helmut

Antwort 4 von Martin1563

Hallo Saarbauer

Danke auf jedenfall.

Lg martin

Antwort 5 von rainberg

Hallo Martin,

in Spalte A und B ab Zeile2 stehen die Vergleichswerte.
Schreibe in

C2:
=WENN(ZÄHLENWENN(A:A;B2);MAX(C$1:C1)+1;"")

und kopiere diese Formel bis ans Ende der Vergleichsdaten.
Die Spalte C funkiert als Hilfsspalte.

Schreibe in D2:
=WENN(ISTNV(VERGLEICH(ZEILE(1:1);C:C;0));"";INDEX(B:B;VERGLEICH(ZEILE(1:1);C:C;0)))

und kopiere diese Formel nach Bedarf nach unten.
In Spalte D werden nun alle Mehrfachvorkommen aufgelistet.

Gruß
Rainer

Antwort 6 von Martin1563

hallo rainberg

vielen Dank für deine Hilfe, hat super geklappt.

jetzt habe ich noch eine Frage, jetzt habe ich diese zwar die doppelt geführt werden, aber kann man die, die im suchkrieterium sind irgendwie kennzeichnen lassen, damit man auch weis welche das jetzt sind oder geht das nicht.
Damit wäre es einfach perfekt.

Danke Martin

Antwort 7 von rainberg

Hallo Martin,

angenommen, Du willst die Doppelten in Spalte B kennzeichnenn, dann markiere die gesamte Spalte B, rufe die Bedingte Formatierung auf und trage unter "Formel ist" folgendes ein

=ZÄHLENWENN($A:$A;B1)

Gruß
Rainer

Antwort 8 von Martin1563

Hallo Rainberg

Danke.

Noch eine Frage hätte ich.

Könnte ich dir das Excel Sheet schicken und du schaust dir das einmal an.
Natürlich mit genauer Anleitung was ich brauche.

Denn du bist sicher ein Profi in Excel.

Ich kenn mich zwar aus mit der Grundfunktion von Excel und die logischen Formeln aber das was ich hier brauche ist mir ehrlich gesagt zu hoch.

Lg Martin

Antwort 9 von rainberg

Hallo Martin,

wenn Du Dich hier im Forum anmeldest, könnte ich Dir meine E-Mail-Adresse per Pager mitteilen.
Ansonsten müsstest Du mir eine Mailadresse nennen an die ich meine Adresse senden kann.

Gruß
Rainer

Antwort 10 von Martin1563

Hallo Rainberg

meine adresse ist martin.krenn@gmx.at

weis leider noch nicht wie das funkt mit dem pager.

Danke Martin

Antwort 11 von rainberg

Hallo Martin,

Du hast Post

Gruß
Rainer

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: