Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Datums-Berechnung mit Excel





Frage

Hi, ich habe folgendes Problem: Ich möchte, wenn ich in Excel ein Datum eingebe (Bsp.: 25.06.2007), dass er mir automatisch genau 1, 2 oder 3 Jahre weiterrechnet. Was dann etwa so aussehen soll: 25.06.2007 24.06.2008 24.06.2009 24.06.2010 Ich habe versucht einfach das Datum mit 365, 730 bzw. 1095 zu addieren. Dies funktioniert aber nicht bei allen Jahren, da einmal mit 28. und 29. Tagen im Februar in Excel gerechnet wird! So komme ich dann in dem obigen Bsp. auf den 25.06.2009 z.B.. Wie kann ich das Problem lösen?

Antwort 1 von rainberg

Hallo,

wenn Ausgangsdatum in A1, dann...

=DATUM(JAHR(A1)+1;MONAT(A1);TAG(A1))

Gruß
Rainer

Antwort 2 von lleopard

Soweit ich weiß gibt es feste Regeln für Schaltjahre: Wenn das jahr glatt durch 4 zu teilen ist usw...

Also war 2004 ein Schaltjahr und 2008 wird es auch.

Wenn also der Rest eine ganze Zahl ist, dann + 366, sonst +365.

Bis zum Jahr 2100 sollte das ausreichen ... das wird nämlich kein Schaltjahr sein!

In Access hilft da die Funktion Mod weiter. Gibts aber bei Excel leider net... zumindest nicht bei Excel2003.

Bei mir klappt es so:

Zelle A2= 26.06.2007
in Zelle A3 steht folgende Formel:

=WENN(REST(JAHR(A2)+1;4)=0;A2+366;A2+365)

Wenn also das Jahr aus A2 + 1, also 2008 ohne Rest durch 4 teilbar ist, dann ist es ein Schaltjahr, und wir rechnen 366 Tage, sonst eben nur 365 dazu.

Bei mir klappts ....

Antwort 3 von Proggi

hat beides vor und nachteile...
müste mann prüfen ob die formel

DATUM(JAHR(A1)+1;MONAT(A1);TAG(A1))

bei einem 29.februar in einen fehler läuft, da es im folgejahr keinen 29.feb gibt.

anders sinds nicht genau alle 4 Jahre ein schaltjahr, ich weiß aber nicht in wievielen Jahren(oder Jahrzenten) mal ein Schalttag ausfällt mehr kommt.

Antwort 4 von rainberg

Hallo nochmal,

um das Schaltjahr zu berücksichtigen.....

=WENN(UND(MONAT(A1)=2;TAG(A1)=29);DATUM(JAHR(A1)+1;MONAT(A1)+1;0);DATUM(JAHR(A1)+1;MONAT(A1);TAG(A1)))

Gruß
Rainer

Antwort 5 von Aliba

Hi,

wenn ich das richtig verstehe, erwartest Du folgende Ergebnisse:

25.06.07
24.06.08
24.06.09
24.06.10
24.06.11
23.06.12
23.06.13
23.06.14
23.06.15
22.06.16
22.06.17
22.06.18
22.06.19
21.06.20
....

Dann wäre die Addition von 365 Tagen schon das Richtige, allerdings darfst Du nicht auf das Ursprungsdatum ein Vielfaches von 365 addieren, sondern musst immer auf das vorherige Ergebnis 365 addieren.

Wenn also die Datumswerte direkt untereinander stehen, und das Startdatum zb in A1 steht, dann in A2 die Formel:
=A1+365 und soweit benötigt nach unten kopieren.

CU Aliba

Antwort 6 von streuberg

Hallo noch mal,

also ich habe jetzt mal ein paar eurer Tipps ausprobiert und möchte mich schon mal bedanken!

Aber bis jetzt war kein Vorschlag dabei, der genau das Ergebnis gebracht hat was ich bräuchte!

Vieleicht zum besseren Verständnis:
Ich möchte hiermit darstellen, den Zeitraum, wenn eine Person in Elternzeit, für 1, 2 bzw. 3 Jahre, geht bzw. wieder kommt!

Beispiel: Kind wird am 25.06.2007 geboren! (Ausgangswert)

Ende Elternzeit:

für 1 Jahr: 24.06.2008
für 2 Jahre: 24.06.2009
und für 3 Jahre: 24.06.2010

Das sind die Ergebnisse, die ich gerne hätte! Wobei ein Jahr, mit oder ohne Schaltjahr, ein Jahr ist!

Antwort 7 von Sledge

Hallo,

angenommen Du hast das Ausgangsdatum in A1:
in die Zeile für das erste Jahr

=DATUM(JAHR(A1)+1;MONAT(A1);TAG(A1)-1)

für die Jahre 2 und 3 folgende Formel
(diese beziehen sich auf das Jahr 1 , d.h. G21 = Zelle mit Formel1)

=DATUM(JAHR(G21)+1;MONAT(G21);TAG(G21))

Viele Grüße
Sledge

Antwort 8 von Sledge

eins noch

* Alle Jahre, welche durch 4 ohne Rest teilbar sind, sind Schaltjahre.
* Alle Jahre, welche durch 100 ohne Rest teilbar sind, sind keine Schaltjahre.
* Alle Jahre, welche durch 400 ohne Rest teilbar sind, sind wiederum Schaltjahre.

nur der vollständigkeit halber ;)

Viele Grüße
Sledge

Antwort 9 von streuberg

Alles klar!

der letzte Tipp von Sledge hat funktioniert! Vielen Dank an dich und auch den Anderen!

streuberg