Supportnet Computer
Planet of Tech

Supportnet / Forum / NW-Sonstiges

kleines Subnetz bei Klasse-C-Netz





Frage

Hallo Ich hab ein kleines Netzwerk mit 2 Rechnern (Win XP), der eine (IP: 192.168.0.1) stellt die Internetverbindung her und funkioniert als Router und DHCP für den anderen Rechner. der 2. Rechner gibt bei ipconfig /all folgendes aus: Ethernetadapter LAN-Verbindung: Verbindungsspezifisches DNS-Suffix: mshome.net Beschreibung. . . . . . . . . . . : Realtek RTL8139-Familie-PCI-Fast Eternet-NIC Physikalische Adresse . . . . . . : 00-E0-4C-E6-CE-DC DHCP aktiviert. . . . . . . . . . : Ja Autokonfiguration aktiviert . . . : Ja IP-Adresse. . . . . . . . . . . . : 192.168.0.2 Subnetzmaske. . . . . . . . . . . : 255.255.255.252 Standardgateway . . . . . . . . . : 192.168.0.1 DHCP-Server . . . . . . . . . . . : 192.168.0.1 DNS-Server. . . . . . . . . . . . : 192.168.0.1 Primärer WINS-Server. . . . . . . : 192.168.0.1 Lease erhalten. . . . . . . . . . : Mittwoch, 14. April 2004 22:08:14 Lease läuft ab. . . . . . . . . . : Mittwoch, 21. April 2004 22:08:14 Wie zu sehen ist, habe ich die Subnetzmaske (in binärer Form) auf 30 führende 1en gestellt, vorher war sie immer auf der Vorgabe 255.255.255.0, also 24 führende 1en. Ich wollte damit bezwecken, dass nur der IP-Bereich 192.168.0.1 bis 192.168.0.3 in meinen Subnetz angesprochen werden kann, in der Hoffnung dass der DHCP nur Adressen in diesem Bereich vergibt (damit ich nicht doofe IPs wie z.b. 192.168.0.183 bekomme). Dieser Versuch funktionierte nicht, er gab mir 192.168.0.83, wobei dann auch die Internetverbindung vom 2. Rechner aus nicht mehr funktionierte. Ich hab dann die IP fix auf 192.168.0.2 gestellt und dann gleich wieder auf DHCP zurückgestellt, weil der DHCP von Windows die Angewohnheit hat, dann einfach wieder dieselbe IP zu vergeben, die er vorher schon fix hatte (also 192.168.0.2). Jetzt, seit ich diese IP vom DHCP bekommen hatte, funktioniert das Netz problemlos mit der Subnetzmaske 255.255.255.252. Weiß jemand von euch, der sich gut mit Subnetting auskennt, warum mir der DHCP trotzdem 192.168.0.83 gab? Sorry, vielleicht hab ich auch was an dem ganzen Konzept mit den Subnetzen nicht verstanden, aber ich kanns mir nicht erklären.

Antwort 1 von Frank1

ich bring mal den Link hier (nicht weil ich so gut googeln kann) hier ist es kurz und besser als ich es kann erklärt:

http://www.marbella-compudata.net/howtos/subnetting.html

aber in Class C bekommst du mit der angegebenen Maske nur die zwei Adressen - warum Windows sich anders entschied - keine Ahnung - vielleicht hat wer geschummelt...

Übrigens - wenn du nur die zwei Maschinen hast - warum machst du keine festen Adressen - man hat doch eher weniger Stress?

mfg frank

Antwort 2 von FANATLA20

danke. naja wenigstens hab ich das konzept dann verstanden.

Also der Grund, warum ich sie nicht fix vergeben habe ist folgender:
Ich hab auf dem Router ein paar Ports geforwarded, und da muss man eine IP angeben, wohin der Port geforwarded werden soll. Da hab ich überall 192.168.0.2 eingestellt. So kann ich auf dem 2. Rechner mehrere Server laufen lassen (Apache, Ftp, usw.) die dann von außen zugänglich werden, aber eben nur wenn der Rechner die IP 192.168.0.2 vom DHCP bekommen hat. Das Problem ist, dass ich auf dem selben Rechner auch Linux installiert habe und dort auch einen Web- und FTP-Server laufen lasse. Nur wenn ich bei Linux die IP fix vergebe, funktioniert die Internetverbindung komischerweise nicht mehr (Das Problem hatte ich schon mit Suse und auch mit Debian) und wenn ich sie dann über DHCP zuweisen lasse, bekomme ich immer eine andere blöde IP wie 192.168.0.32 unter der das Forwarding wieder nicht funzt. Also müsste ich den DHCP irgendwie dazu zwingen, dass er immer die selbe IP vergibt, was eigentlich genau NICHT der Sinn eines DHCP ist, aber es funzt ja mit fixer IP nicht.

Antwort 3 von FANATLA

Ich habs aber mit Linux jetzt noch nicht ausprobiert, ob vielleicht dort der DHCP nur diese eine IP vergibt. Ich glaubs aber nicht da das Problem eher am DHCP selbst liegt und der läuft ja immer unter dem selben Windows-System.

Wahrscheinlich ist der sogenannte DHCP-Server, der unter Windows XP läuft wenn der Rechner als Standard-Gateway bei den anderen eingestellt ist, nicht so ausgereift, denn unter Windows Server 2003 ist es z.B. ganz anders, da kann man den DHCP ganz detailliert konfigurieren (IP-Bereiche, Ausschluss von Bereichen, Lease-Zeit, usw).

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: