3.6k Aufrufe
Gefragt in Windows98 von tacoomik Mitglied (153 Punkte)
Ich habe abermals ein problem mit meniem Epson-scanner von https://supportnet.de/t/2465616.

Nach einem sytemabsturz mit datenverlust haben sich meine hoffnungen zerschlagen, dies noch reparieren zu können, so habe ich auf das backup menier BS-installation zurückgegriffen. Die ist jedoch aus der zeit, wo ich noch meinen alten Canon-scanner hatte, so muss ich den Epson neu installieren. Ich bin grad zu dem punkt vom 15.09.2014, 01:25 (supportnet.de/t/2465616) gekommen, wo das so wunderbar geklappt hat, doch diesmal stürzt mir der installationsprozess mit der fehlermeldung
SETUP verursachte einen Fehler durch eine ungültige Seite in Modul SETUP.EXE bei 0167:00401ca9.
Register:
EAX=00000001 CS=0167 EIP=00401ca9 EFLGS=00010202
EBX=00000000 SS=016f ESP=005b0a90 EBP=00a106b0
ECX=005b1460 DS=016f ESI=bff76da8 FS=5917
EDX=bffc9490 ES=016f EDI=00000000 GS=0000
Bytes bei CS:EIP:
38 1f 8b f7 74 41 90 8b 4c 24 10 03 cf 3b f1 73
Stapelwerte:
005b3058 00664fa0 00000000 00664f9c 00000009 00000001 00000000 00000000 00664fa0 782d0000 005b0af8 0000001c 4d36e972 11cee325 0008c1bf 1803e12b
ab.

Also wenn ich nichts übersehen habe, bis auf den FS-register-wert exakt das selbe, was ich zu anfang noch mit den versuchen mit dem treiber von der CD zu basteln bekommen habe (siehe anfang des genannten threads).

Es irritiert mich allerdings, wenn ich die treiberinstallation starte, kriege ich eine meldung
WinZip Self-Extractor

Scanner Driver and Epson Scan Utility v.3.9.0.0

This file contains the Epson Perfection V33/V330 Photo TWAIN driver/EPSON Scan Utility 3.9.0.0 for Windows XP/XP_x64 edition/Vista 32 and 64/ 7 (32 & 64 bit).

*Note: This fite is self-extracting and will automatically Start the Installation process.*

Windows 2000 wird hier gar nicht genannt.

Zunächst habe ich gedacht, ich habe mir damals versehentlich eine falsche version archiviert. Danach gegoogelt habe ich allerdings diese feststellungen gemacht:

Es ist heute viel schwieriger an den entsprechenden download zu kommen. Epson ist mit dem K-meleon nicht mehr richtig erreichbar (mit dem IE6 schon gar nicht) und die allermeisten DL-webs, die ihn anbieten, melden dann ihren link als ungültig bzw. die datei nicht auffindbar. Einzig ab userdrivers.com/Scanner/Epson-Perfection-V33-Scanner-Driver-and-EPSON-Scan-Utility-3-9-0-0-for-Windows-2000-XP-Vista-7/download konnte ich nach der Google-eingabe anhand der beschreibung "Scanner Driver and EPSON Scan Utility v3.9.0.0 für Windows 2000" eine datei runterladen - epson13870.exe (22'731 KB), also dieselbe, die ich schon habe. Und überall wird sie für alle die zu anfang des self-extractors genannten Windows-versionen + Windows 2000 angeführt. So gehe ich davon aus, dass es schon die richtige ist, mit der ichs vor knapp 16 monaten gemacht habe, nur habe ich damals dem genauen (und also evtl. nicht so wichtigen) wortlaut der einschlägigen meldung keine aufmerksamkeit geschenkt.

Es ist mir nun völlig rätselhaft, warum das jetzt nicht mehr geht. Ich habe mir den damaligen thread erneut sorgfältig durchgelesen und finde keinen fehler, den ich jetzt gegenüber damals machen würde. Ausser dass die datei doch nicht die richtige wäre.

Aber wie käme ich dann auf die korrekte ran?

22 Antworten

0 Punkte
Beantwortet von tacoomik Mitglied (153 Punkte)
@Lasko: Threadtitel = "Scanner Epson Perfection V330 Photo & W98 die 2".

Mithilfe von KernelEx läuft auch vieles unter W98, was primär für spätere Windows vorgesehen ist, und offiziell als nicht W9x-kompatibel erklärt wurde. So auch dieser scanner, dir mir da bis vor kurzem, bis zu einem festplattenabsturz, nachdem er neu installiert werden muss, seit 15 monaten wunderbar auf W98SE funktionierte.
0 Punkte
Beantwortet von tacoomik Mitglied (153 Punkte)
@Spielesammler: Das scheint ein treibersatz von Epson zu sein, der zwar neuer als der älteste von den 3, die ich habe, ist, jedoch älter als die zwei neusten. Da mein scanner bereits mit dem zweitneusten tadellos funktionierte, konzentriere ich mich darauf, das gerät wieder auf basis dieser zum lauf zu bringen.

Aber auf jeden fall danke.

Ich muss noch schauen, was es mit der auflistung unter [System] auf sich hat, ob das evtl. nicht welche nützlich hinweisende werte sind, obwohl ich auch diesbezüglich eher skeptisch bin.
0 Punkte
Beantwortet von win98professor Experte (1.3k Punkte)
Hallo Tacoomik,

bitte lösche mal beide "usbscan.sys" Dateien und den Inhalt des Ordners "twain_32". Im Windows 98 System sollte sich nur eine "usbscan.sys" im Ordner c:\windows\system32\drivers befinden. Entpacke dann die originale "usbscan.sys" per 7-Zip aus der Windows 98 CD (im Ordner "Driver20.cab") und füge diese im Ordner "Drivers" ein. Die Datei hat die Versionsnummer 4.10.1998 und eine Größe von 8,73 kb. Für diese Datei wird kein KernelEx benötigt. Außerdem den NUSB v3.3 und den KernelEx deinstallieren. Neustart. Jetzt den NUSB v3.3 + KernelEx Final 4.5 neu installieren. Da KernelEx durchgeführte Einstellungen speichert, muss jetzt die "usbscan.sys", falls sie noch auf Win2000SP4 steht, wieder auf "Default" zurückgestellt werden.

Als nächstes die Epson v3.9.0.0 für die Installation per KernelEx auf Windows 2000 SP4 setzen und neu installieren. Neustart & testen. Keine Funktion: Die Epson .exe Dateien sowohl mit KernelEx Win2000SP4 als auch in der Einstellung "Default" testen. Keine Funktion: Eine manuelle Installation versuchen. Dazu Scanner deinstallieren (Inhalt des Ordners twain_32 wieder manuell löschen). Nach dem Neustart in der Systemsteuerung > Hardware auswählen und den Assistenten starten > Option "Hardware in der Liste wählen" > Option "Bildverarbeitungsgerät" wählen > Diskette > zum entpackten Treiber navigieren und einbinden. Neustart & testen.

Falls es nicht funktioniert, gibt es noch eine Möglichkeit, die man testen kann. Da der Treiber v3.9.0.0 nur eine Twain-Steuerungsdatei für Windows 2000/XP enthält, kann man versuchen, die vom Epson Treiber hinterlegten Dateien im twain_32 Ordner manuell auf KernelEx Win2000SP4 zu setzen. Wenn auch das nicht helfen sollte, wird es schwierig. Eine Methode die wir damals nicht getestet haben wäre noch der epson12181 in der Version 3.0.4.0. Link . Dieser enthält eine Twain-Steuerungsdatei und einen Uninstaller für Windows 98.

Ich bin mir auch beim Epson v3.9.0.0 nicht ganz sicher, ob dort noch die Windows 2000 Dateien hinterlegt sind. Alle derzeit verfügbaren Downloads verweisen in der .inf Datei nur auf das Betriebssystem NTx86.5.1. Windows 2000 trägt aber die Bezeichnung NTx86.5.0. Auch der aktuelle Windows 2000 Treiber von Epson enthält in der .inf nur noch den Verweis auf die NTx86.5.1. Bei HP wurden damals auch nach dem Supportende alle entsprechenden Treiber für die älteren Systeme entfernt und sind dort auch per Anfrage nicht mehr erhältlich. Bei Kodak wurden nach der Produktionsaufgabe die Softwareserver komplett abgeschaltet. Microsoft entfernt sämtliche Downloads gemäß ihrer Lifecycle-Richtlinien. Ein späterer Neuaufbau eines Systems wird damit (vielleicht auch so gewünscht?) fast unmöglich gemacht.

Gruß Micha
0 Punkte
Beantwortet von tacoomik Mitglied (153 Punkte)
Vielen dank für die tipps.

Ich habe das nun alles peinlich genau nach deiner anleitung durchgespielt, das resultat ist leider immer noch das selbe.

Doch ein paar feststellungen habe ich dabei gemacht:
- die installation selbst muss ohne KernelEx erfolgen, sonst kommt die obige fehlermeldung "SETUP verursachte einen Fehler durch eine ungültige Seite in Modul SETUP.EXE bei 0167:00401ca9."
- im gegensatz zu anfänglichen versuchen ist jetzt im SW-management der Systemsteuerung ein posten EPSON, mit dem man die treiber sauber entfernen kann. Das habe ich auch vor dem letzten versuch gemacht. Demnach sehe ich den epson12181 v3.0.4.0 mit dem Uninstaller für Windows 98 als nicht nötig.

Zuletzt habe ich also die v3.9.0.0 installiert. Weil es das selbe ist, wie vor dem störfall, der mir den scanner ausser betrieb gesetzt hat, gehe ich davon aus, dass eigentlich alle treiberdateien die richtigen sein müssen. KernelEx habe ich für die drei .exe dateien - escndv.exe und 2x estwm.exe - auf W2k SP3 gesetzt; allerdings müsste es gemäss frühereer erfahrnug mit XP-SP4 genau gleich laufen.

An der escndv.exe und allem, was danach kommt, kann es nicht liegen. Das ist der EPSON Scan, der gestartet wird, erst nachdem der scanner eingeschaltet wurde und sich initialisiert hat. Wird EPSON Scan früher gestartet, ist die fehlermeldung über kommunikationsprobleme mit scanner normal. Und hier bleibt ja nach dem enischalten die initialisierung des geräts aus. Es muss also etwas da sein, was zusammen mit dem einschalten des scanners alleine in aktion treten soll, aber was? Der estwm.exe? Wozu ist diese datei eigentlich gut?

Oder müsste ich nicht etwas im MSconfig anders setzen?

Und noch etwas, was ich eher nicht glaube, dass es damit was zu tun hat, doch für alle fälle erwähne ich das hier auch. Im gegensatz zu früher bleibt hier beim runterfahren des rechners das logo-bild mehrere minuten hängen, bevor sich der PC ausschaltet. (Doch kann man hier den zusammenhang mit sicherheit ausschliessen, würde ich diese sache erst angehen, wenn der scanner läuft.)
0 Punkte
Beantwortet von win98professor Experte (1.3k Punkte)
Hallo Tacoomik,

der letzte Hinweis war im direkten Zusammenhang mit dem Scanner sehr gut. Windows 98 hat nämlich die Angewohnheit, bei Problemen mit dem USB-Treiber oder angesteckten Geräten beim Runterfahren entsprechend lange hängen zu bleiben. Um das Problem zu finden, muss zuerst der NUSB deinstalliert werden. Bevor aber der nächste Schritt folgen kann, benötigst du eine Maus + Tastatur mit PS/2 (runder Standard-Stecker) Anschluss.

Den Scanner und alle anderen USB Geräte vom PC abziehen. Wenn alles kontrolliert und evtl. gegen PS/2 ausgetauscht wurde, kannst du anschließend in den Gerätemanager gehen. Dort löscht du jetzt alle USB-Einträge (ganz unten in der Liste). Bevor du anschließend neu startest, installierst du den NUSB v3.3 neu. Beim Neustart werden dann alle USB-Gerätetreiber neu eingerichtet. Wenn die Abfrage nach dem Treiber startet, immer einfach auf "Weiter" drücken. Alle benötigten Treiber werden automatisch aus der NUSB-Liste geladen. Es kann sein, dass dafür auch die Windows 98 CD benötigt wird.

Wird ein Treiber trotzdem nicht gefunden und im Gerätemanager gelb markiert, kannst du diesen manuell nachladen, indem der NUSB in einen Ordner entpackt wird und du diesen dann als Ziel angibst. Dann sollte das System die benötigte .inf Datei dort finden. Danach neu starten und testen. Je nachdem wie das Ergebnis ausfällt alle USB-Geräte wieder nacheinander neu einstecken und einrichten lassen. Dieser Fehler tritt nämlich auch dann auf, wenn ein vorhandenes USB-Gerät wie z. B. eine Tastatur Probleme macht oder ein USB-Stick ein technisches Problem hat. Auch ein Wechsel des USB-Ports sollte noch getestet werden, denn auch hier liegt oftmals eine Fehlerquelle. Ältere Mainboards neigen nach einigen Jahren gerne mal zu kleineren Aussetzern oder Kontaktschwierigkeiten. Mit etwas Glück könnte hier die fehlende Fehlerquelle liegen.

Gruß Micha
0 Punkte
Beantwortet von
Mir ist auch noch was eingefallen mit nicht funktionierenden Treibern.

Am besten wieder mit einem neu installierten W98 SE beginnen.
Servicepack mit letztem IE Version drauf und wichtig ist der Installer
da muß der richtige drauf sein und wenn der nicht stimmt, wird falsch installiert oder fehlerhaft. (NET.Framework muß drauf sein)

Ich hatte mit einem Logitech Handscanner damals massive Probleme beim scannen. Dialog Popups öffneten fehlerhaft oder gar nicht.
Damals war der Fehler, ein cooles DJ Programm das Setup-Paket hat die Win98SE ole32 (Dateien) mit einer anderen Version überschrieben und das was der Auslöser dass der Handscanner dann nicht richtig funktionieren wollte, obwohl die Treiber installiert waren (auch eine erneute Scanner-Installation schlug fehl).

Off-Topic!
Ich hab sogar noch einen original w98se pc mit Pentium 233 im Schrank stehen (mit einer GForce-3 Grafikkarte) wo alle updates drauf sind, inclusive DX9c und eine menge Spiele die ich aber nicht mehr zocke (z.B.: Unreal oder Rune und so weiter).
Der PC bzw. W98se arbeitet noch immer astrein und fehlerfrei hab da immer sehr geanu darauf geachtet und keinen Müll installiert.
Hab auch ein Platten-Image davon.
KernelEx, hab das nie gebraucht bzw. installiert.

Bin gespannt ob es dir gelingt dass dein Scanner endlich wieder funktioniert.

Melde dich wieder - ich will das unbedingt wissen :)
0 Punkte
Beantwortet von
sorry Off-Topic!

korrektur (oben) ist kein Pentium 233 sondern da ist ein Celeron mit 1,1GHZ drinn
Beim P233 der ist bestückt mit einer Voodoo2 und einer ELSA-Winner) funktioniert aber auch noch (Sammler-Stück halt) !!
0 Punkte
Beantwortet von tacoomik Mitglied (153 Punkte)
@win98professor:
Abermals danke für den tipp. Leider auch danach nichts neues. Alles ist reibunslos gemäss anleitung abgelaufen (gleich wie W98 for ever, gilt für mich auch PS/2 für maus und tastatur for ever, zumindest bis mir vorräte an entsprechenden geräten ausgehen:D), doch es trat danach keine änderung im verhalten ein. Auch die schlussphase des runterfahrens ist nicht schneller geworden. Es wäre hilfreich, sowohl für den scanner, wie auch das runterfahren des PC eine log-datei zu haben, die jeden schritt des rechners einzeln aufzeichnen würde, ähnlich der bootlog.txt-datei, womöglich noch mit zeitaufzeichnungen. Doch das scheint mir ein unerfüllbarer wnusch zu sein.

Was mir auch noch auffällt, falls das vlt. auf etwas konkretes hinweisen könnte, in den energieeigenschaften des Geräte-managers wird angegeben, der scanner zieht von der USB des PC 2 mA strom. Ich mag mich erinnern, ganz am anfang, wo ich mich damit jetzt zu bafassen angefangen habe, waren das 4 mA (ist nur der strombedarf der eingangskreise des USB-anschlusses, ja keine energieversorgung des scanners; da deckt er seinen bedarf von einem netzteil).

@Speelesammler:
Ich selbst spiele so gut wie gar nicht, doch eine zeit lang war ich in einem spieler-forum aktiv; kam durch eine fusion mit einem Windows-forum rein. Vor allem hiabe ich dort eine ganz tolle gruppe sehr hilfsbereiter leute vorgefunden, von den einige auch sehr gute kenntnisse über diese alte technk hatten. Von ihnen habe ich ua. erfahren, dass alte spiele, an den viele leute auch heute noch sehr interessiert sind, und die für W98 geschrieben wurden, am original des BS am besten laufen; auf alleden in späteren Windows integrierten simulationen des 98ers seien sie oft kaum vernünftig spielbar. Leider hat dann der admin und betreiber des forums irgendwie den spass an der sache verloren, liess das abo für hosting auslaufen und einmal kam halt der traurige feierabend :(.

Und dein PC mit P233, ist das nicht zufällig ein IBM 300PL?
0 Punkte
Beantwortet von
Off-Topic!

Ist ein Soyo-Mainboard, der mit dem Celeron 1GHZ (1.1GHZ) ist ein MSI-Mainboard mit AGP-Grafik GF3.
Beide Mainboards haben vor Jahren ein nagelneues Gehäsue bekommen. In beiden ist eine Soundblaster AWE32 verbaut mit onboard Wavetable-Chip (EMU-8000) mit Windows und DOS-Treiber.

Beim Penium 233 die Festplatte da ist Win311 for Workgroups mit OS/2 Wrap 3 Deutsch drauf, man kann da hin und her schalten - OS2 nach Win311 oder Win311 nach OS2 (funktioniert fehlerfrei).
In der dritten Partition da ist Windows 95a drauf.
Ins Internet gehe ich mit diesen Geräten nicht mehr, da sind nur gesammelte 3dfx oder andere Spiele drauf.
Hatte letzens Besuch und die Kids waren begeistert vom P233 - die wollten nicht mehr nach Hause nur mehr Starwars Racer 1 spielen und Ultimate Race Pro usw.
In der ersten kleinen Partition da ist der OS2-Boot-Manager drauf
der sich meldet wenn der PC gestartet wird.

Diese 2 alten Geräte im neuen Gehäuse werden von mir gepflegt für die Nach-Welt, eben zum her zeigen - wie damals alles begonnen hat.

Ja das waren noch Zeiten, der gute alte Norton-Commander für DOS
(wer erinnert sich nicht gerne zurück, ohne Norton war man damals
fast Blind im System).
0 Punkte
Beantwortet von tacoomik Mitglied (153 Punkte)
Bei jenem gamer-forum war mindesetns die hälfte der leute dort unter 20, einige gar unter 15. Und einmal kam ein thema "Wie sehen eure rechner aus", und als ich dort bilder meines deckelfreien IBM mit P233 gepostet habe, war das ein totalerfolg :D. Übrigens, sein vorteil ist ua. dass er ganz leise ist. Die modernen festplatten (zwischen 2005 und 2010 etwa) hört man fast nicht und für die CPU mit ihren max. 18 Watt genügt ein vergrösserter radiator rauf und den lüfter braucht es dann nicht mehr. Es surrt also nur ganz wenig der ziemlich langsam drehende lüfter des netzteils.

Zum thema:
Ich weiss nicht, ob es in diesem fall normal ist, dass in der Systemsteuerung unter "Scanner und Kameras" gar nichts als installiert angeführt ist, selbst wenn der scanner eingeschaltet ist, was ihn im geräte-manager korrekt anzeigt.
...