1.5k Aufrufe
Gefragt in WindowsXP von
Also, GMX will TLS 1,0 deaktivieren und ich kann dann mit meinem Outlook Express keine Mails mehr empfangen.

Nun gibt es eine Anleitung im Netz, wie man das TLS 1,2 installieren kann. Die ist aber sehr kompliziert:

>>Man braucht von Microsoft das Update: KB4019276-x86.

Dieses Update ist eigentlich fur Windows XP embedded vorgesehen. Wer es unter Windows XP Home oder Professional installieren mochte, wird die Fehlermeldung: „Die installierte Windows-Version paßt nicht zu dem Update, das Sie installieren mochten.“ bekommen und die Installation bricht ab. Um es dennoch unter Windows XP Home oder Professional installieren zu konnen, mussen wir dem Update vorspielen, daß es auf Windows XP Embedded installiert werden soll. Dafur sind folgende Schritte in der Windows-Registrierung erforderlich:

1. Start

2. Ausfuhren

3. „regedit“ eingeben.

4. Ok

5. HKEY_LOCAL_MACHINE\SYSTEM\WPA\

6. Im rechten Fenster mit der rechten Maustaste auf „Neu → Schlussel“ klicken.

7. „PosReady“ eingeben.

8. Im rechten Fenster mit der rechten Maustaste auf „Neu → DWORD-Wert“ klicken.

9. „Installed“ eingeben.

10. Den Wert auf „1“ andern.

11. Den Registrierungseditor schliesen.

Jetzt lasst sich das Update KB4019276 installieren. Wenn die Installation abgeschlossen ist, startet der PC / Laptop neu. Das Update hat 2 neue Eintrage in der Windows-Registrierung hinzugefugt. Damit Outlook oder Outlook Express mit TLS 1.1 und 1.2 einwandfrei funktioniert, mussen wir 2 weitere Eintrage in die Windows-Registrierung hinzufugen. Dazu starten wir wieder den Registrierungseditor wie folgt:

1. Start

2. Ausfuhren

3. „regedit“ eigeben.

4. Ok

5. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\

SCHANNEL\Protocols\TLS 1.1\Client\

6. Im rechten Fenster mit der rechten Maustaste auf „Neu → DWORD-Wert“ klicken.

7. „DisabledByDefault“ eingeben.

8. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\

SCHANNEL\Protocols\TLS 1.2\Client\

9. Im rechten Fenster mit der rechten Maustaste auf „Neu → DWORD-Wert“ klicken.

10. „DisabledByDefault“ eingeben.

11. Den Registrierungseditor schliesen.

Jetzt konnen wir den PC / Laptop neu starten. Nachdem er neu gestartet ist, starten wir unser Email-Programm (Outlook oder Outlook Express). Wenn alles richtig installiert und eingetragen wurde, konnen wir jetzt wieder von allen gangigen Emailanbietern uber verschlusselte Verbindung und ohne Fehlermeldung Emails empfangen und senden. <<

Klingt sehr schwer für mich als Laien. Immerhin habe ich das Update schon heruntergeladen, aber in der Registry herumzufummeln traue ich mir nicht zu. Was tun?

45 Antworten

0 Punkte
Beantwortet von visionhelp Einsteiger_in (25 Punkte)
Bearbeitet von visionhelp
Dank der Vor-Warnung von Marco war ich vor-bereitet. Sehr gut ... so-weit. Aber exakt nun das Gleiche bei meiner XP Prof. SP3 Corporate Version. (Ha. Un´ nu´ ? OK.)

Hier eine andere Version ´POSReady Windows XP Embedded´ (10,4 MB statt 1,08 MB) https://www.catalog.update.microsoft.com/search.aspx?q=KB4230450. (Aber auch die gleiche Fehler-Meldung für Installieren.)

6 Links, die ich nun fand, die ich aber erst studieren muß (leider länger), und überlegen muß, WAS zu-erst testen. Vielleicht gibt es aber auch Jemand mit-Interessierten, die da schneller durch-steigen, schneller und besser Ahnung oder/und Ideen haben, oder bekommen.
https://msfn.org/board/topic/177534-how-to-activate-windows-xp-online-2018-2021/page/2/#comments
https://msfn.org/board/topic/178087-update-windows-xp-ie8-to-tls12-connected-last-skype-7/
https://support.microsoft.com/en-us/topic/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-winhttp-in-windows-c4bd73d2-31d7-761e-0178-11268bb10392
https://www.sb-innovation.de/showthread.php?33029-RatioMaster-Plus-2-1/page36&p=352891#post352891
https://msfn.org/board/topic/171814-posready-2009-updates-ported-to-windows-xp-sp3-enu/#comment-1061758
or perhaps here a solution, please, can not fast ´just´ test all: https://msfn.org/board/topic/171814-posready-2009-updates-ported-to-windows-xp-sp3-enu/?do=findComment&comment=1061758

(TLS 1.2 auch für Internet, Web-sites ..., OK.)
0 Punkte
Beantwortet von visionhelp Einsteiger_in (25 Punkte)
Bearbeitet von visionhelp
Von Hersteller ´support / supporter´ Kontakt-Plattform (github) ´mypal 68.12.4b´ nun diesen Link - als der richtige Download, plus Erkäuterung (Erläuterung selbst-verständlich) - erhalten (Hinweis: die Übersetzung des wohl englischen Textes ist aller-übelst, daß man da nur etwas mit anfangen kann, wenn die Sach-Information SELBST ERARBEITET wird; das schaffe ich gerade SCHNELL da auch nicht): https://support.microsoft.com/de-de/topic/aktivieren-von-tls-1-1-oder-tls-1-2-als-sichere-protokolle-winhttp-windows-embedded-posready-2009-und-windows-embedded-standard-2009-aktualisieren-f51ec93b-9988-7ac6-98a1-b8968c40ab7f

Aber schon mal das Update herunter-laden, und schauen was das Installieren macht, sagt. Dann die nächsten Schritte erst mal in Verstehbares umbauen und zusammen-bauen. Ich poste es so-weit jetzt aber schon mal hier. Vielleicht ist der Eine oder Andere da schneller. (Ich bin neugierig, ob das nun in die richtige Richtung geht. Wegen TLS 1.1 und 1.2 für ´sicheres Protokoll WinHTTP´ irritiert mich noch NUR. Ob das tatsächlich für OE mit hilft.)
0 Punkte
Beantwortet von visionhelp Einsteiger_in (25 Punkte)
Bearbeitet von visionhelp

Auszug aus der "Zusammenfassung": "Dieses Update ermöglicht den Systemadministrator an TLS 1.1 oder TLS 1.2 wird das WINHTTP_OPTION_SECURE_PROTOCOLS-Flag auf Windows Embedded POSReady 2009 und Windows Embedded Standard 2009."

Ich übersetze das so, daß dieses ´Update´ haupsächlich, wenn nicht aus-schließlich, den/die genannten Registry-Eintrag/Einträge vor-nimmt, um TLS 1.1 und TLS 1.2 zu aktivieren. (Für Browser - nicht um den Browser zu verwenden, sondern weil dort sehbar und (´nochmals´) einstellbar ist; verstehe ich - UND OE.)
Überprüfen dann in den Internet-Optionen (IE) unter ´Erweitert´, und notfalls da nochmals selbst aktivieren dort. Mal sehen.

0 Punkte
Beantwortet von visionhelp Einsteiger_in (25 Punkte)
Bearbeitet von visionhelp

Ich muß/kann ein bedeutendes Versäumnis melden: HKEY_LOCAL_MACHINE\SYSTEM\WPA\PosReady "Installed": steht auf ´0´. Das MUSS ´1´.
(Also, also wieder ´Alles´ von vorne, neuer Versuch.)
Jetzt Folgendes:

Die ´1´ im Bild ist vom Versuch, aber nach Wechsel in anderen Schlüssel und wieder zurück: steht wieder auf ´0´.
Da muß ich mich aber mit den Berechtigungen zunächst beschäftigen.

0 Punkte
Beantwortet von visionhelp Einsteiger_in (25 Punkte)
Aber nun hier die Updates als deutsche Sprach-Version(en) gefunden und gut verstehbare Anleitung (für Mail oder/und IE8, der Erwähnung wegen): https://www.emailarchitect.net/forum/posts/m4939-Enable-TLS-1-2-on-Windows-XP-for-EASendMail
...