Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Runden auf ,5 oder ,0





Frage

Hi, Ich möchte beim Berechnen in Excel 2000 gerundete Ergebnisse haben, die nur auf 0,5 genau sind. Also eine Stelle hinter dem Komma immer 0 oder 5. Beim Suchen hier habe ich schon irgendwas dazu gefunden, aber nicht richtig kapiert. Schön wäre es, wenn ihr mir die angewendete Formel auch kurz erläutern könntet, ich möchte immer wissen, was er da rechnet, um beim nächsten mal selbst eine Lösung zu finden. Gruß FR

Antwort 1 von Event

Hallo

Gib mal in der Excel-Hilfe "Runden" ein.

Gruß

Antwort 2 von fritz-rudolf

Ich glaube, dass hilft nicht so richtig. Das Runden prinzipell ist ja klar, es wird nur immer auf ganze Stellen hinter dem Komma gerundet, ich brauche aber halbe Stellen, also 0,5-er Schritte, also z.B. 1,2 = 1,0 2,7 = 2,5 36,6 = 36,5 36,8 = 37,0 usw.

Gruß
FR

Antwort 3 von Event

Hallo

Angenommen Dein zu rundender Wert steht in Zelle A1, dann gibt

=RUNDEN(A1/5;1)*5

das von Dir gewünschte Ergebnis.

Gruß

Antwort 4 von fritz-rudolf

THX Event, es klappt wie gewünscht!

Und bitte jetzt noch die Mathe-Nachhilfe, welcher Wert da jetzt was genau ist.

Danke und Gruß
FR

Antwort 5 von Event

Hallo

Da die Excel-Funktion ´Runden´ immer nur auf, die im zweiten parameter angegebene Nachkommastellen rundet - also <0,5 wird 0 und >=0,5 wird 1 - bedarf es dieser kleinen Hilfskonstruktion.

Gruß

Antwort 6 von vadder

und noch was zur freien auswahl

4,44 * 2,13 = 9,46

4,44 * 2,13 = 10,00 =aufrunden(b4*c4;0)
4,44 * 2,13 = 9,50 =aufrunden(b5*c5;1)
4,44 * 2,13 = 9,46 =aufrunden(b6*c6;2)

4,44 * 2,13 = 9,00 =abrunden(b8*c8;0)
4,44 * 2,13 = 9,40 =abrunden(b9*c9;1)
4,44 * 2,13 = 9,45 =abrunden(b10*c10;2)

4,44 * 2,13 = 9,00 =runden(b13*c13;0)
4,44 * 2,13 = 9,50 =runden(b14*c14;1)
4,44 * 2,13 = 9,46 =runden(b15*c15;2)

alles ist möglich

vadder

Antwort 7 von fritz-rudolf

@vadder
versteh ich nicht (((:-(

@event

ich versuchs mal, wenn richtig interpretiert, bitte sagen (sonst auch!)

=RUNDEN(A1/5;1)*5

Ergebnis aus Zelle A1 geteilt durch 5 soll auf eine Stelle gerundet werden, das gerundete Ergebnis dann mit 5 multipliziert

...und wer läßt sich solche Hifskonstrukte einfallen?
Gibts dafür irgenwo Übersichten mit Erläuterungen?

THX FR

Antwort 8 von Das_Urmel

Du suchst
Abrunden()
Aufrunden()
Excel Hilfe
mfg
Michael Bormann

Antwort 9 von Event

Hallo
In diesem Fall ist das wohl ein typischer Dreisatz; will sagen Elementarmathematik.
Gruß

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: