Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Zeiten in Excel runden





Frage

Hallo, hab da ein Problem mit dem Runden von Zeiten in Excel: wenn KOMMT-GEHT Buchung Positiv, dann solle die Zeit auf 1/4 Std. abgerundet werden. wenn KOMMT-GEHT Buchung Negativ, dann soll die Zeit auf 1/4 Std. aufgerundet werden. Bsp.: differenf -18 min runden auf -30 min differenz +18 min runden auf +15 min

Antwort 1 von dat_karlchen

Sorry hab vor lauter Aufregung
Bitte Bitte vergessen

Antwort 2 von rainberg

Hallo Karlchen,

ein kurzer Blick in die letzten Beiträge hätte Dir Deine Frage erspart.

https://supportnet.dethreads/1553197

Statt AUFRUNDEN kannst Du auch ABRUNDEN und RUNDEN einsetzen.

Gruß
Rainer

Antwort 3 von dat_karlchen

Guten Morgen Rainer,

Danke für den Link habe das Problemchen damit gut lösen können


Frohe Pfingstfeiertage

karlchen

Antwort 4 von dat_karlchen

Hallo Rainer,

habe das durchgetestet und hab da noch eine letzte Frage:

wie kann ich das Runden bei vollen 15 min. abschalten, da ja durch

=WENN(Q22<0;AUFRUNDEN(Q22*96;0)/96;ABRUNDEN(Q22*96;0)/96)

auch die +1:30 auf +1:15 abgerundet und die - 1:30 auf 1:45 aufgerundet werden??

Danke im voraus

mfg

karlchen

Antwort 5 von dat_karlchen

sorry muß heißen:
... und die - 1:30 auf - 1:45 aufgerundet werden

sorry

karlchen

Antwort 6 von rainberg

Hallo karlchen,

zunächst auch Dir Frohe Pfingsten.

Deine Feststellung kann ich leider nicht bestätigen, bei mir rundet Deine Formel richtig.
Poste doch mal paar Zeitwerte bei denen falsch gerundet wird.

Gruß
Rainer

Antwort 7 von dat_karlchen

Hallo Rainer,
sorry, habe einen Fehler in einer vorhergehenden Berechnung übersehen.

karlchen

Antwort 8 von dat_karlchen

Hallo Rainer,

an dem Fehler lag es leider nicht,

hatte das Problem, dass bei Zeiten von

KOMMT 6:00 GEHT 15:30 diff.: 1:30 gerundet 1:30
bis
KOMMT 6:07 GEHT 15:37 diff.:1:30 ger. 1:30

war ok

aber ab

KOMMT 6:08 GEHT 15:38 diff 1:30 ger. 1:15 ?

habe die Funktion um ein paar Kommastellen erweitert und schon rechnet er richtig
=WENN(Q35>0;ABRUNDEN(Q35*(96,00001);0)/96;AUFRUNDEN(Q35*96;0)/96)

gruß

karlchen

Antwort 9 von rainberg

Hallo Karlchen,

auch das kann ich nicht bestätigen, die Formel rechnet auch hier richtig.
Es kann nur an Deinen Formeln liegen, die diese Differenz bilden.

Ich habe so getestet:

A B C D E F
1 kommt geht Arbeitszeit Sollstunden Differenz gerundet
2 06:08 15:38 09:30 08:00 01:30 01:30

Formeln der Tabelle
C2 =REST(B2-A2;1)
E2 =C2-D2
F2 =WENN(E2<0;AUFRUNDEN(E2*96;0)/96;ABRUNDEN(E2*96;0)/96)
Gruß
Rainer

Antwort 10 von dat_karlchen

Hallo Rainer,

habe meine Formeln auf die REST Funktion umgestellt
nun klappt das mit dem Auf- und Abrunden auch.

Vielen Dank für Deine Bemühungen

Gruß

Karlchen

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: