Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Wert zwischen 2 Daten





Frage

Hallo Zusammen Ich hätte da folgendes Problem, für den Urlaubsplan 2007 habe ich 2 Blätter angelegt. Auf dem Blatt Feiertage habe ich die Feiertage und die Ferien in der 1.Spalten" von" und in der 2.Spalte "bis". Das 2.Blatt wäre der Januar. Nun soll in Zelle C6 "F"(Feiertag) stehen wenn C3 (Datum) ein Feiertag von der Gleichnamigen Tabelle übereinstimmt. Dies habe ich so realisiert:"=WENN(ISTFEHLER(SVERWEIS(C$3;Feiertage!$A$3:$B$13;2;0));"";"F")". Klappt auch. Wie aber kriege ich es hin das jetzt in Zelle C5 "FS" steht wenn der wert der Zelle C3 in den Ferienzeitraum (Spalte"von"/Spalte"bis, der Ferien von Feiertag) fällt. Kann mir jemand helfen, wäre sehr Dankbar. Na dann vielleicht bis später. Danke

Antwort 1 von Saarbauer

Hallo,

schon mal an Summenprodukt() gedacht

:"=WENN(ISTFEHLER(SVERWEIS(C$3;Feiertage!$A$3:$B$13;2;0));"";"F")

& Wenn(Summenprodukt((Feiertage!$A$3:$A$13=<C$3)*(Feiertage!$A$3:$A$13=>C$3)) > 0;"S";"")

Gruß

Helmut

P.S. Formel ist ungetestet

Antwort 2 von Mathew

Vielen Dank Helmut
Werd es gleich mal probieren, melde mich dann nochmal. Bis dann

Antwort 3 von Mathew

Hallo Zusammen
Habe Summprodukt getestet, hat leider nicht funktioniert. Wahrscheinlich habe ich mein Proplem falsch beschrieben. Hier nochmaliger Versuch:
Habe TBlatt "Feiertage" und TBlatt "Januar". Auf TBlatt Feiertage sind in Spalte A die Anfangsdaten der Ferien und in Spalte B die Enddaten. Nun soll in Januar in Zeile 5 "SF" stehen wenn das Datum aus Zeile 3 in einen der Zeiträume von/bis der Ferien fällt.
Die Formel soll also abfragen ob das Datum in einen der Ferienzeiträume fällt.

Antwort 4 von Aliba

Hi Mathew,

ich glaube da hatte Helmut nur einen kleinen Schreibfehler in seiner ungetesteten Formel:

=Wenn(Summenprodukt((Feiertage!$A$3:$A$13=<C$3)*(Feiertage!$B$3:$B$13=>C$3)) > 0;"FS";"")

CU Aliba

PS: Ist zwar immer noch ungetestet, sollte aber funzen.

Antwort 5 von Saarbauer

Hallo @Aliba,

deine Lösung ist auch möglich, jedoch bin ich davon ausgegangen, dass @Mathew einmal "F" drin stehen haben will und an anderer Stelle ein "S" und wenn beides passt, dann "FS", daher

=WENN(ISTFEHLER(SVERWEIS(C$3;Feiertage!$A$3:$B$13;2;0));"";"F") & Wenn(Summenprodukt((Feiertage!$A$3:$A$13=<C$3)*(Feiertage!$A$3:$A$13=>C$3)) > 0;"S";"")

Hatte es nur in zwei Zeilen geschrieben, da ich glaubte es wäre leichter verständlich.

Gruß

Helmut

Antwort 6 von Mathew

Vielen Dank für eure Hilfe hat super gefunzt.
Schönen Abend noch und Danke nochmal

Antwort 7 von Saarbauer

Hallo @Mathew,

wäre interessant welche Variante du gewählt hast

Gruß

Helmut

Antwort 8 von Aliba

Hallo Helmut,

lt. der Anfrage von Mathew sollte ja die Ausgabe von F und FS in unterschiedlichen Zellen erfolgen, also ist die Verkettung der Formeln nicht nötig.
Desweiteren schreibt er ja, dass er für die Ferien das Anfangsdatum in SPalte A und das Enddatum in Spalte B stehen hat. Das hatte ich als einen Schreibfehler deinerseits in der Summenproduktformel interpretiert, da ja innerhalb der Formel dann auch die Spalte B und nicht nur die Spalte A abgefragt werden muss.

Und darum gings mir eigentlich hauptsächlich, auf diesen kleinen Fehler in der Summenproduktformel hinzuweisen.

CU Aliba

Antwort 9 von Mathew

Hallo Helmut
Habe die Variante von Aliba gewählt, da hat es gefunzt, leider hab ich mich bei der ersten Beschreibung etwas unglücklich ausgedrückt. Aber der 2. Teil deiner Formel hat ebenfals hingehauen, Nochmal vielen Dank, Hoffentlich kann auch mal behilflich sein.