Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Problem mit Sverweis





Frage

Hallo, ich habe ein Problem mit der Formel Sverweis, vielleicht kann mir jemand helfen. Ich habe eine Tabelle, die mit Daten gefüllt ist. Jede Datenzeile erhält eine zugehörige Nummer und besitzt ca. 20 Spalten. In einer zweiten Tabelle gebe ich die entsprechende Nummer ein. Die Formel Sverweis sucht dann in Tabelle 1 nach dieser Nummer und gibt mit dann die gesuchte Information aus Tabelle 1 automatisch aus. Diese automatische Suche funktioniert allerdings nur, wenn mein vorgegebener Matrixbereich von Sverweis ca. 30 Zeilen umfasst. Erweitere ich den Matrixbereich um eine weitere Zeile, damit diese Nummer und Ihre Daten innerhalb der Matrix liegen, so erhalte ich als Ergebnis der Formel Sverweis den Wert 0. Verringere ich danach den Matrixbereich am anderen Ende um eine Zeile(damit die gesuchte Nummer weiterhin innerhalb des Matrixbereiches liegt), so erhalte ich wieder den gesuchten Wert bzw. die gesuchten Daten. Nur somit umfasst meine Formel nicht die gesamte Tabelle 1, sondern nur den kleinen Bereich von ca. 30 Zeilen und das hilft mir nicht wirklich weiter. Er muss meine gesamte Tabelle absuchen können. Hat die Formel Sverweis einen maximalen Suchbereich oder wie kann ich dieses Problem lösen? Vielen Dank für Eure Hilfe! Andi

Antwort 1 von Saarbauer

Hallo,

kann ich mir nicht vorstellen, da ich Tabellem von wesentlich grösserem Umfang schon mit Sverweis() bearbeitent habe.

Da der Aufbau in dem SVerweis mir nicht bekannt ist, vermute ich, dass durch das Runterziehen der Formel, die Grenzen so verschoben werden, dass diese nach der 30. Zeile nicht mehr Funktioniert.

Gruß

Helmut

Antwort 2 von rainberg

Hallo Andi,

poste doch mal die verwendete Formel, vielleicht kann man dann schon mehr sagen.

Gruß
Rainer

Antwort 3 von Andi07

Hallo,

ich kann mir halt auch nicht vorstellen, dass es ein Limit bei der Formel Sverweis gibt, aber ich kann keinen Fehler finden.

Die eingegebene Formel lautet:

=SVERWEIS(B16;[daten.xls]Projekte!$A:$AK;18;WAHR)

Wobei hier halt die kompletten Spalten A-AK verwendet werden. Und nur bei der Begrenzung der Matrix auf den Bereich von ca. 30 Zeilen funktioniert es.

=SVERWEIS(B16;´[daten.xls]Projekte´!$A$15:$AL$45;18;WAHR)

Wenn ich diesen Matrixbereich nur um eine Zeile vergrößere funktioniert es nicht mehr.

Danke für Eure Hilfe
Andi

Antwort 4 von Saarbauer

Hallo,

eine Frage:

Sind deine Daten sortiert, in aufsteigender Reihenfolge?

Bei dem Sverweis() mit "Wahr" müssen die Werte sortiert sein und es wird, ich meine, der nächst grössere Wert genommen. Bei "Falsch" können die Werte unsortiert sein, aber es werden nur gebau passende Werte genommen.

Welche Fehlermeldung erhälst du denn?

Gruß

Helmut

Antwort 5 von Andi07

Hallo,

die Frage war gut. Meine Daten sind eigentlich aufsteigend sortiert(1.1.,1.2.,2.1.,2.2....Vielleicht hat Excel bei dieser Art Nummerierung ein Problem).

Ich bekomme auch keine Fehlermeldung, sondern einfach nur den Wert "0" ausgegeben .

Ich hab jetzt mal "falsch" eingegeben und dann gibt der mir den richtigen Wert aus. Ich verstehe zwar nicht wirklich, warum dann bei "wahr" es bei der begrenzten Anzahl Zeilen funktioniert. Aber wenn das Problem so einfach zu umgehen ist. Super!

Vielen Dank für die Hilfe und guten Rutsch!
Andi

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: