Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

sverweis mit bedingtem lookup





Frage

Hi alle, Ich habe eine Tabelle A und moechte fuer einen gegebenen Datensatz einen Wert in einer anderen von 41 Tabellen abrufen (mit SVERWEIS). Welche der 41 verwendet wird, haengt von einem bestimmten Wert ab. Mit zwei Tabellen 1 und 2, wuerde das so gehen: =SVERWEIS(H2,WENN(C2=1,Tabelle1!$A$6:$B$1000,Tabelle2!$A$6:$B$1000),2,FALSCH) WENN kann ich aber leider nicht 41 mal verschachteln. Gibt es eine andere Loesung? Ich hatte die Idee, in einer neuen spalte "X" den namen des zu verwendenden Tabellenblatts einzufuegen (z.b. Tabelle31!$A$6:$b$1000) und das dann in die SVERWEIS formel reinzukopieren: =SVERWEIS(H2,X2,2,FALSCH) aber das geht nicht, weil excel nun denkt es soll meinen wert in X2 suchen anstelle aus X2 das zu verwendende Tabellenblatt rauszuziehen. Kann einer folgen und helfen? Danke!

Antwort 1 von Hajo_Zi

Hallo Unbekannter,

benutze Indirekt.

Gruß Hajo

Antwort 2 von student0815

KLAPPT! Vielen Dank - Du hast mein Wochenende gerettet :)

Henry

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: