Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

SVERWEIS nur ausführen wenn Zelle leer





Frage

Hallo, gibt es eine Möglichkeit SVERWEIS nur auszuführen wenn die Zelle noch leer ist. Bsp: Wenn ich in Zelle A eine Nummer eintrage, soll er in einer anderen Tabelle einen Wert suchen und damit Zelle B befüllen. Das funktioniert ja auch soweit ganz prima. Aber, das soll nur einmal gemacht werden. Beim ersten mal. Wenn sich nachher die Lookup-Tabelle ändert soll der ursprüngliche Wert drin stehen bleiben. Als Nebeneffekt sollen die Informationen aus B auch drin stehen bleiben wenn sich die LookUp-Tabelle beispielsweise leert. Hat jemand eine Idee? Gruß Sabine

Antwort 1 von coros

Hallo Sabine,

leider nicht ganz verständlich, aber wenn es nur darum geht, dass die SVERWEIS-Formel ausgeführt wird, wenn z.B. in zelle A1 etwas steht, würde das wie folgt aussehen:

=WENN(A1>"";SVERWEIS(........);"")

MfG,
Oliver
Da hier der einzige Lohn für die Helfer eine Rückmeldung ist, wäre es nett, wenn Du
ein Feedback abgeben könntest, ob der Lösungsvorschlag Dein Problem gelöst hat.

Antwort 2 von rainberg

Hallo Sabine,

das geht nicht, Formeln sind dynamisch und nehmen immer die Werte ihrer Bezüge an.
Wenn die Bezugswerte entzogen werden, gibt es eine Fehlermeldung oder ein falsches Ergebnis.

Du kannst höchstens den Formelwert kopieren und durch "Inhalte einfügen" > "Werte" statisch machen.

Ansonsten hilft Dir nur VBA.

Gruß
Rainer

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: