Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

excel: wie kann ich in excel eine abfrage ertelllen, die ausgibt, wieviel verschiedene feldinhalte es gibt





Frage

also: ich habe eine spalte mit ca. 1000 zeilen. dort sind z.b. einträge wie a b b a c c a b a und jetzt möchte ich wissen, wieviele verschiedene einträge es gibt. die rictige antwort in diesem fall wäre 3, da ich nur a,b und c habe. hoffentlich habt ihr meine frage verstanden. ich habe keine ahnung, wie ich diese formel machen soll. für eure hilfe wäre ich sehr sehr dankbar! grüsse @ all

Antwort 1 von Saarbauer

Hallo,

leider zu ungenau beschrieben, abrer z.B. mit Zählenwenn() machbar.

Gruß

Helmut

Antwort 2 von Saarbauer

Hallo,

mit einer Hilfsspalte und

=WENN(ZÄHLENWENN($A$1:A1;A1)=1;1;"")

am Ende der Hilfsspalte

=SUMME(B1:B23)

Hilfsspalte ist hier B

Gruß

Helmut

Antwort 3 von coros

Hi sebba,

grüß Dich Helmut. Von mir kommt eine Makrolösung. Kopiere das Makro in ein StandardModul und starte es z.B. über eine Befehlsschaltfläche.

Option Explicit

Sub Vergleichen()
Dim wks As String, iRow As Integer, Zähler As Integer, iSheet As Integer
wks = ActiveSheet.Name
For iSheet = 1 To Worksheets.Count
If Sheets(iSheet).Name = "Auswertung" Then
Application.DisplayAlerts = False
Sheets(iSheet).Delete
Application.DisplayAlerts = True
Exit For
End If
Next
With Worksheets.Add
.Name = "Auswertung"
End With
For iRow = 1 To Sheets(wks).Range("A65536").End(xlUp).Row
If WorksheetFunction.CountIf(Sheets(wks).Range("A1:A" & iRow), Sheets(wks).Cells(iRow, 1)) = 1 Then
Zähler = Zähler + 1
Sheets("Auswertung").Cells(Zähler, 1) = Sheets(wks).Cells(iRow, 1)
End If
Next
Sheets("Auswertung").Cells(Sheets("Auswertung").Range("A65536").End(xlUp).Offset(1, 0).Row, 1) = _
WorksheetFunction.CountIf(Sheets("Auswertung").Range("A:A"), ">""") & " verschiedene Einträge"
End Sub


Bei dem Makro wird ein neues Blatt mit dem Namen "Auswertung" angelegt, in der die verschiedenen Einträge einzeln ohne Duplikate aufgeführt werden. Am Ende steht dann wie viele verschiedene Einträge gefunden wurden. Die Daten, die auf Duplikate geprüft werden sollen, müssen bei dem Makro in Spalte A stehen.

Ich hoffe, Du kommst klar. Bei fragen melde Dich bitte.

Solltest Du nicht wissen, wie Du den Code in Deine Datei bekommst, dann schau mal auf meiner HP in der Rubrik Anleitungen und dort dann in der Anleitungsnummer 3 nach. Dort stelle ich dazu eine bebilderte Anleitung zur Verfügung, die Dir sicherlich helfen wird.

MfG,
Oliver
Da hier der einzige Lohn für die Helfer eine Rückmeldung ist, wäre es nett, wenn Du ein
Feedback abgeben könntest, ob der Lösungsvorschlag Dein Problem gelöst hat.