Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

wenn dann ????





Frage

Hallo. Habe nicht gefunden. Also ich möchte das der Bereich A1 bis A 20 überprüft wird. Wenn z.B. in A1 nicht "Hans, Wurst" steht dann soll in A2 geguckt werden usw. wenn nun z.B. in A3 "Hans, Wurst" steht dann soll der Bereich B3 bis K3 copiert werden und in A25 eingefügt werden. Der Bereich zum copieren je nachdem wo der richtige Name steht. A1 = B1 bis K1 A2 = B2 bis K2 A3 = B3 bis K3 usw. Danke Gruß COX

Antwort 1 von Saarbauer

Hallo,

geht wahrscheinlich nur mit VBA, aber eins ist mir unklar:
Wie willst du die Zellen B... bis K... in A25 kopieren?

Hier ist eine Erklärung notwendig

Gruß

Helmut

Antwort 2 von cox

Oh. Dann anders ausgedrückt.

Also B3 bis K3 sollen z.B.

nach

B25 bis K25 kopiert werden.


Also die Daten die hinter dem richtigen Namen stehen
sollen kopiert werden. Und an andere Stelle wieder eingefügt werden.

Gruß COX

Antwort 3 von Saarbauer

Hallo,

wenn ich es richtig verstandwen habe hast du in A25 einen Wert / Namen stehen und in A1 bis A20 steht er auch irgendwo (z.B. A15). Die Daten aus B15 bis K15 sollen dann nach B25 bis K25 übertragen werden

Müsste mit

=SVERWEIS($A$25;$A$1:$K$20;SPALTE();FALSCH)

in B25 bis K25 gehen

Gruß

Helmut

Antwort 4 von cox

Leider Nein.

Also die Tabelle ist so aufgebaut.

A1 = Mister A B1 bis K1 = Daten
A2 = Mister B B2 bis K2 = Daten
A3 = Mister X B3 bis K3 = Daten
A4 = Mister D B4 bis K4 = Daten

Und ich möchte nun

das der Breich. B... bis K... kopiert und wo anders
wieder eingefügt wird. z.B. B6 bis K6

Aber nur der Breich wo Mister X steht
Also hier B3 bis K3

A1 bis A4 durchsuchen lassen wo Mister X steht.
und den Bereich hinter Mister X (B... bis K... kopieren und in B6 bis K6 einfügen)

Mister X steht aber immer an einer anderen stelle.

Gruß COX

Antwort 5 von Saarbauer

Hallo,

das macht normalerweise der Sverweis(), aber vielleicht meinst du es anders

Kannst du deine Tabelle mal hier einstellen

http://www.netupload.de/

und den Link hier hinterlegen, dann kann man sich das Ganze mal ansehen

Gruß

Helmut

Antwort 6 von cox

http://www.netupload.de/detail.php?img=f8e9394067d904d6227358604ce3bfda.xls

Antwort 7 von Saarbauer

Hallo,


meine Lösung war im Prinzip richtig, jedoch konnte ich nicht wissen, dass du in Spalte A nichts reinschreibst

Daher versuch es mal damit

=SVERWEIS("Mister X";$A$1:$F$4;SPALTE();FALSCH)

Gruß

Helmut

Antwort 8 von cox

Super Danke.

Habe ja schon mit dem verweis ausprobiert aber habe es nicht hinbekommen.

Ein Frage aber noch.

Wenn nun eine Zelle die leer ist kopiert wird.
Kann sein dann wird immer 0,00 angezeigt.
Geht das auch dass die Zelle dann leer bleibt.


Gruß COX

Antwort 9 von Saarbauer

Hallo,

zwei Wege

1. "Extras""Optionen""Ansicht""Nullwerte" Hacken raus (gilt für gesamtes Blatt)
2. für Einzelwerte "Bedingte Formatierung" und dann Schriftfarbe auf hintergrundfarbe einstellen

Gruß

Helmut

Antwort 10 von cox

Oh man. Stimmt ja.

Habe hier noch mal einen link.
Wäre nett wenn Du da mal reingucken kannst.



Excel Tabelle zum download

Danke
Gruß COX

Antwort 11 von cox

Ups kleiner Fehler.

Sollte keine Übereinstimmung sein dann soll in N3 E25 kopiert werden. Nicht E2.

Gruß COX

Antwort 12 von Saarbauer

Hallo,

ich hoffe es passt

Mister x

Gruß

Helmut

Antwort 13 von cox

Vielen Dank!
Echt Super von Dir.

Eins noch.
Unter Betreff soll auch die jeweilige Schicht angezeigt werde.
Also wenn unter 1 ST4M steht dann soll auch in der Tabelle neben an unter Betreff ST4M stehen.



Danke Gruß
COX

Antwort 14 von cox

Habe den zu ändernden Wert gefunden.

Danke.
Gruß COX

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: