Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

sverweis - finde meinen Fehler nicht!





Frage

Hallo, folgendes Problem in meiner Excel-Liste: Ich habe eine Preisliste und möchte mit Hilfe des sverweis-Befehls den dazugehörigen Preis zu einer beliebig, ausgewählten Artikelnummer einfügen. Hier ist meine Formel: =SVERWEIS(C9;Liste;4;0) -in C9 steht meine Artikelnummer (z.B. 075122) -'Liste' ist meine aktuelle Preisliste, Bereich $B$2:$H$3100 -in der 4. Spalte in 'Liste' steht mein Preis Das Ergebnis, welche meine Formel bringt lautet: #NV und ich weiß echt nicht warum!Ich hoffe mal, dass jemand mit meinen Angaben was anfangen kann und bedanke mich schon mal im voraus für Eure Hilfe! MfG

Antwort 1 von Pistenschreck

Hi Lumpa

Die eine Artikelnummer wird Textformat, die andere im Zahlenformat vorliegen.

Gruss Werner

Antwort 2 von Pistenschreck

Nochmal

Könnte auch sein, dass die Artikelnummer in LISTE nicht in der ersten Spalte liegen

Gruss Werner

Antwort 3 von HumpaLumpa

Ja, hatte ich auch schon gedacht, habe aber schon alle Variationen durch probiert. Leider kann ich in dieser Preisliste keine Zellen formatieren, scheint gesperrt zu sein.

Aber wenn ich in dieser Formel an Stelle der 0 (Falsch), eine 1 eingebe, dann bekomme ich den Preis vom vorher aufgeführten Artikel. Also kann es eigentlich am Format nicht liegen.

Vielen Dank für deine Antwort, ich bin über jede weitere Hilfe froh.

Gruß Oli

Antwort 4 von Saarbauer

Hallo,

einen Versuch ist es wert, kopier mal eine Artikelnummer aus der Preisliste in deine Liste und seh mal nach was dann passiert.

Normalerweise müsste es dann funktionieren.

Gruß

Helmut

Antwort 5 von HumpaLumpa

Ja, wenn ich aus meiner Preisliste die Artikelnummer kopiere und einfüge funktioniert es, aber sobald ich eine neue Artikelnummer reinschreibe geht´s wieder nicht!

Gruß Oli

Antwort 6 von Pistenschreck

Hallo Oli

Dann Formatiere die Eingabezelle mit @ (Text)

Gruss Werner

Antwort 7 von Saarbauer

Hallo,

eindeutig ein Hinweis auf unterschiedliche Formatierungen der Zellen oder irgendwelche nicht sichtabren Zeichen

Gruß

Helmut

Antwort 8 von HumpaLumpa

@Werner

Was meinst du genau mit dem Formatieren "@ (Text)"?

Vielen Dank für eure Hilfe!

Gruß Oli

Antwort 9 von Pistenschreck

Hallo Oli

Ich glaube das ist eine endlose Spirale. Ohne Deine Datei auf meinem PC zu Begutachten, wird es schwierig sein.

Kannst Du mal eine abgespeckte Version, ohne vertrauliche Daten auf einen Server laden?

z.B. Hier
http://www.netupload.de/

Gruss Werner

Antwort 10 von HumpaLumpa

Hallo Werner,

bitte nicht böse sein, aber diese Datei darf ich nicht weitergeben... werde es dann mit dem Kopieren weiterführen und noch weiter Neues versuchen und mich wahrscheinlich bei neuen Problemen wieder melden.

Trotzdem vielen Dank für deine Hilfe.

Gruß Oli

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: