Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

MS Excel Wenn Funktion Prozente richtig erkennen und gruppierne





Frage

Hallo, ein Kunden hat 30 % Anteil, einer 60% oder auch ein Kunde mit 1% Anteil. Hier verwende ich eine Wenn Dann Funktion >50 % dann Ja sonst Nein. Allerdings der mit einem Prozent wird trotzdem mit Ja angezeigt! Kann mir hier jemand den Fehler mitteilen bzw wie ich das richtig darstellen kann? Vielen Dank im voraus. J Sent

Antwort 1 von Proggi

wenn du 1% als Text darstellst bekommst du bei jeder angabe JA.

es muss als Zahl / Prozentwert formatiert sein.
habe mal 6 Zeilen gemacht, 3x als Zahl, 3x als Text formatiert.
(' startet einen Text in Excel)

60%
20%
1%
'60%
'20%
'1%

ergibt
Ja
Nein
Nein
Ja
Ja
Ja

Antwort 2 von Proggi

Formel aus B1:

=WENN(A1>50%;"Ja";"Nein")

Antwort 3 von JSent

Hallo,

danke passt! klasse!

Allerdings noch was.

IN Zelle A2 steht 0 in Zelle B2 steht 1.

Er soll berechnen wenn in A oder B 2 eine Zahl steht!

Wie kann ich ihm das klar machen?

Wenn A2 = 0 dann 0 aber wenn B2 1 dann berechne!

Danke im voraus.

Antwort 4 von Proggi

kannst auch wenn auch verschachteln

=wenn(A2=0;wenn(B2=0;"beides0";"B2istnicht0-A2ist0");"A2istnichtnull-B2unbekannt")


allerdings kann es sien das es je nach anwendungsgebiet sinvollere lösungen gibt.

anstelle der "strings" kannst du auch weitere Formeln einfach einfügen

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: