Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

doppelte Prüfung beim Sverweiss - wie??





Frage

Hallo zusammen, ich möchte eine Tabelee aktualisieren lassen durch eine Sverweis. Dazu muss der Sverweis zwei Felder untersuchen. Ich habe schon mit einer Wenn Formel rumprobiert aber die klappt nicht so recht. Hier mal die Formel: =WENN(SVERWEIS(H4;[AktuellerStand.xls]Sheet1!$a$2:$D$1288;3;0)=H4;WENN(SVERWEIS(G4;[AktuellerStand.xls]Sheet1!$A$2:$D$1288;4;0);[AktuellerStand.xls]Sheet1!$D$2;"nicht vorhanden")) Zur vereinfachung eine kleine ERklärung dazu: Excel soll suchen ob das Feld G4 und H4 mit einer Zeile in der Matrix übereinstimmt. Und wenn er eine Zeile gefunden hat die 3. Zelle der Matrix einsetzen. Wo habe ich den Fehler? Vielen Dank Rebuss

Antwort 1 von Aliba

Hi Rebuss,

die Formel kann aus mehreren Gründen nicht funktionieren:
1. Du suchst nach dem Eintrag in H4 in der Spalte A Deiner Matrix und gleichzeitig nach dem Wert aug G4 in Spalte A Deiner Matrix. Wenn nun in G4 u. H4 unterschiedliche Einträge stehen, kann das nicht funktionieren.
2. Du sagst Wenn der Wert aus H4 in A4 steht muß gleichzeitig H4 dem Eintrag in der Spalte C der Matrix entsprechen. Jetzt sollen schon 3 Zellen gleich sein, nämlich der Eintrag in H4 , der in Spalte A und der in Spalte C der Matrix.
3. In der 2. WENN-Abfrage fehlt, was passieren soll, wenn die Bedingung WAHR ist.

Danach versteh ich die Formel sowieso nicht mehr.

Was sind das denn überhaupt für Einträge in den Zellen?
Texte oder Werte? Wenn es sich bei den Einträgen der Spalte C Deiner Matrix um Werte handelt, dann könnte man evtl. die Angelegenheit über SUMMENPRODUKT lösen.

Also ich verstehe Deine Anfrage zusammengefasst so:

Wenn in Spalte A deiner Matrix ein Eintrag gleich H4 ist und gleichzeitig der danebenstehende Eintrag in der Spalte B gleich G4 ist, dann liefere den Eintrag aus Spalte C, sonst "nicht vorhanden".

Also bitte weitere Erläuterungen, dann werden sie geholfen.

CU Aliba

Antwort 2 von Rebuss

Hallo Aliba,

vielen Dank das du mir helfen helfst. Ich habe zur Vereinfachung mal zwei Screenshots hochgeladen.

Nun noch meine Erklärung:

In der Spalte K in Bild1 soll der neue Stand aus der Spalte D in Bild2 eingesetzt werden. Dazu soll er in Bild1 die Spalten G und H mit den Spalten A und B in Bild2 vergleichen und wenn beide identisch sind die Spalte D aus Bild2 in die Spalte K aus Bild1 einsetzen

Wie kann ich das machen?

Vielen Dank

Rebuss

Antwort 3 von Aliba

Hi Rebuss,
folgende Formel sollte funzen:
=SUMMENPRODUKT((Tabelle1!$A$2:$A$1000=G2)*(Tabelle1!$B$2:$B$1000=H2)*Tabelle1!$D$2:$D$1000)

Tabelle1! mußt Du halt entsprechend anpassen, sowie auch die Bereiche.

CU Aliba

Antwort 4 von Rebuss

Hallo Aliba,

genial vielen Dank.

Ich verstehe zwar absolut nicht warum du eine Summenproduktformel benutzt hast und nicht irgendwie Sverweise verknüpft hast aber naja.

Wenn dir ganz arg langweilig kannst du mir das ja vieleicht erklären und wenn nicht

nur vielen Dank

Rebuss

Antwort 5 von Aliba

Hi Rebuss,
in der jetzigen Form deiner Tabellen sehe ich keine Möglichkeit dies über SVERWEISE zu realisieren, da der 2. SVERWEIS nicht weiß, daß er nur in der gleichen Zeile wie der erste fündig weden darf.
Die einzige Möglichkeit hier mit SVERWEIS zu arbeiten, wäre eine zusätzliche Hilfsspalte, die im Quellblatt als Spalte A eingefügt wird. Hierein dann die Formel =A2&B2. Die Formel in Spalte K deiner Zieltabelle wäre dann:
=SVERWEIS(G2&H2;Tabelle1!$A$2:$E$1000;5;0)

CU Aliba

Antwort 6 von Rebuss

Hi Aliba,

nein nein ich bin vollkommen zufrieden mit deiner Formel. Ich verstehe sie nur nicht.

Solange ich das richtige Ergebniss bekomme ist es mir egal ob ich Sverweiss oder Summeprodrokt benutze.

Gruss

Rebuss