Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Fehlerwert #NV ersetzen





Frage

Hallo, ich bekomme in einer Zelle (B10) als Ergebnis von einem VERWEIS entweder einen Wert (Name) oder den Fehlerwert #NV. Wie kann ich den Fehlerwert #NV ersetzen? Wenn das Ergebnis der Name ist, so soll der Name stehen bleiben. Wenn das Ergebnis #NV ist, so soll nix drin stehen. Ich habe versucht: =WENN(Fehler(B10)=7;"";(B10)) So klappts aber nicht. Den Fehlerwert 7 habe ich mir aus der Excel-Hilfe rausgelesen. Als Endergebnis möchte ich folgendes haben: Ich bekomme dieses Ergebnis in 10 nebeneinander liegenden Zellen. Davon ist immer 1 Ergebnis ein Name und die anderen 9 sind #NV. Das ganze diehnt bis hierhin als Hilfsrechnung. Nun möchte ich in einer Zelle den Namen bekommen, der in einer der 10 Zellen aus der Hilfsrechnung steht. Das wollte ich mit =VERKETTEN machen. Dazu muss ich das #NV umwandeln/ersetzen. Falls es einen besseren Weg gibt, den Namen aus der Hilfsrechnung in die Zielzelle zu bekommen, bin ich dafür auch sehr dankbar. Vielen Dank, Gruß Sven.

Antwort 1 von coros

Moin Sven,

frage doch einfach mit einer Wenn-Formel die Zelle ab, auf die auch die Verweis-Formel zugreift. Als Beispiel:

Die Sverweisformel lautet folgendermaßen:

=SVERWEIS(A1;Tabelle1!A1:B2;2;FALSCH)

dann wertet die SVERWEIS-Formel den Eintrag in der Zelle A1 aus. Nun musst Du nur noch mit einer Wenn-Formwl die Zelle A1 abfragen. Als Beispiel:

=WENN(A1>0;SVERWEIS(A1;Tabelle1!A1:B2;2;FALSCH);"")

Bei dem Beispiel erscheint erst ein Wert in der Zelle mit der SVERWEIS-Formel, wenn in Zelle A1 etwas eingegeben wurde (=WENN(A1>0;). Ansonsten bleibt die Zelle leer (;"")).

Ich hoffe, Du kommst klar. Bei Fragen melde Dich wieder.

MfG,
coros
Da hier der einzige Lohn für die Helfer eine Rückmeldung ist, wäre es nett, wenn Du ein
Feedback abgeben könntest, ob der Lösungsvorschlag Dein Problem gelöst hat.

Antwort 2 von want2cu

Hallo SVEN,

ich habe eine andere Lösung, weil ich meine, dass bei Coros mit A1 die falsche Zelle abgefragt wird. Die Fehlermeldung #NV wird m.E. dann erzeugt, wenn der Wert, der in A1 steht, in der Suchmatrix nicht gefunden wird.

Diesen Fehler fängt man z.B. wie folgt ab:

=WENN(ISTFEHLER(SVERWEIS($A$1;$A$8:$E$24;2;FALSCH));"";SVERWEIS($A$1;$A$8:$E$24;2;FALSCH))

Die Bezüge muss man noch entsprechend anpassen. Die Wenn-Abfrage in Verbindung mit der Funktion ISTFEHLER (man kann hier auch ISTNV nehmen) sorgt dafür, dass dann eben "" (=nix) in der Zelle steht und nicht die Fehlermeldung ausgegeben wird.

Dann kann man aus den Zellen A1:A10 relativ einfach z.B. mit MAX die Zelle ausgeben, wo etwas drinsteht.

CU
want2cu

Antwort 3 von sv_t

Hallo,

mit der
 =WENN(ISTFEHLER ... 
- Formel klappts prima.

Besten Dank, Gruß Sven

Antwort 4 von want2cu

Hallo Sven,

schön, dass dir der Tipp geholfen hat. Vielen Dank auch für die nette Rückmeldung.

cu
want2cu

Antwort 5 von waddehaddedudeda

Super Jungs, hat genau das bewirkt was ich wollte. ..
Danke!

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: