Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

WENN Formel um Text erweitern? 3ter Versuch





Frage

Also gut jetzt nocheinmal. 1. Im Feld A1 steht ein Betrag 2. Im Feld B1 gebe ich diesen Betrag eine Beschreibung, die unterschiedlich ausfallen kann z.B. >>Spenden-A<< >>Spenden-B<< >>Spenden-C<<. 3. Jedes Mal wenn ich also in Spalte B1 irgendeinen(!) von diesen in Pkt. 2 genannten Texten eingebe soll Excel mir den Betrag von A1 in Zelle C1 wiederholen. Mittlerweile bin ich also schon soweit das ich es schaffe, wenn ich in B1 einen einzigen Text angebe z.B. >>Spenden-A<< das er mir den Betrag wiederholt in C1... Mein Problem besteht darin das sich der Text in B1 jeden Monat ändert. Mal heisst er Spenden-A mal Spenden-B. Ich muss also Excel irgendwie beibringen nicht nur einen sondern mehrere Texte zu erkennen! Also wenn ich einmal >>Spenden-A<< oder >>Spenden-B<< oder >>Spenden-C<< in B1 schreibe, dann liebes Excel, wiederhole den Betrag aus A1 in C1 WIE GEHT DAS? Vielen Dank nocheinmal Gruß Jan

Antwort 1 von 1001flow

Hallo Jan,

der Befehl in Spalte C lautet

=verketten(A1;" ";B1)




Gruß 1001flow



Antwort 2 von Klaas

Hallo Jan,

was flow1001 schreibt ist prinzipiell richtig. Es wird aber jede Eingabe in Spalte A in Spalte C wiederholt.
Wenn Du nur die Spenden raussuchen willst probier folgenden Eintrag in Zelle C1:
=WENN(LINKS(B1;4)="Spen";A1;"")
Anschliessend kannst Du die Formel ja weiter kopieren.
Gruß
Klaas

Antwort 3 von Opa53

Hallo Jan,
in allen Deinen Anfragen beschreibst Du das Problem jeweils etwas anders und auch nie in seiner Gesamtheit. Hier sprichts Du z.B. nur von Spenden, vorher jedoch noch von weiteren möglichen Texten. Darum können Dir im Detail durchaus richtige Antworten offensichtlich nicht so recht weiterhelfen.
Ich versuche jetzt mal zusamenzufassen, wie ich Dein Anliegen bisher verstanden habe:
Also Du hast in Spalte A diverse Beträge stehen.
In Spalte B stehen wechselnde Texte, welche jeweils den Betrag in A erläutern.
Anhand der Texte in B möchtest Du die Beträge aus A nach Einnahmen in Spalte C und Ausgaben in Spalte D trennen.
Eine Aufteilung nach den Wertangaben in A ist nicht möglich, da diese unabhängig davon, ob es Einnahmen oder Ausgaben sind, immer einen positiven Wert haben. (Warum eigentlich und kannst Du darauf keinen Einfluss nehmen?)
Wenn Du jedoch zumindest Einfluss auf die Einträge in B nehmen kannst, dann lege ganz einfach fest, dass grundsätzlich Einnahmen mit "ZE-" (Zahlungseingang) und Ausgaben mit "ZA-" (Zahlungsausgang) vor dem eigentlichen Text gekennzeichnet werden. Dann würde für Dich die ganze Festlegung zur Suche nach einer Vielzahl eventuell an irgendeiner Stelle in den Texten vorkommenden Strings (welche auch noch eine korrekte Schreibweise voraussetzen) entfallen.
Der Tipp von Klaas würde dann abgewandelt so lauten:
Für C1 =WENN(LINKS(B1;3)="ZE-"A1;"")
Für D1 =WENN(LINKS(B1;3)="ZA-"A1;"")
Gruß
Opa

Antwort 4 von want2cu

Hallo,

es würde die Sache auch ganz erheblich vereinfachen, die EInnahmen und Ausgaben in separate Spalten zu schreiben. Dann könnte man in einer weiteren Spalte auch relatv einfach den fortlaufenden Salso bilden. Und mit Summewenn könntest du die einzelnen Einnahmen und Ausgaben recht einfach summieren und z.B. eine Art EInnahme-Überschuss-echnung erstellen.
Damit deine Anfragen nicht zur "unendlichen Geschichte" werden, wäre es prima, deine Fragen vollständig, mit möglichst genauen Informationen in einem einzigen Thread zu stellen. Es ist recht anstrengend und nervig, zur Beantwortung deiner Fragen in mehreren Threads nachlesen zu müssen, wer dazu schon was geantwortet hat und wie sich deine Fragestellung dann teilweise geändert hat.

CU
want2cu

Antwort 5 von Flupo

Ergänzend zu want2cu's Beitrag wär es auch nicht schlecht, wenn du in deinen Threads mal ein erklärendes oder abschließendes Wort a'la "Ich habs jetzt! Danke" bringen würdest.
Und bitte nicht für jede Nachfrage einen neuen Thread aufmachen.

Gruss Flupo

Antwort 6 von Jan Bauer

Hallo,

also zunächst einmal Danke für die Antworten. Sorry, das ich das mit Threads nicht richtig verstanden habe. Vergessen wir also alle anderen Treads.

Vergesst bitte auch die ganze Sache mit den Spenden und Einnahmen und Ausgaben und negativ Betrag und Positiv Betrag, da denkt ihr sonst zu kompliziert.

Ich habe also wie ich schon beschrieben habe...

Einen Betrag in A stehen (das sind immer positve Einnahmen!)

In Spalte B gebe ich diesen Einnahmen eine Beschreibung.

Das Ziel soll immer dasselbe sein... Den Betrag von A nach C kopieren.

Das Problem ist nur, die Beschreibung ist jeden Monat anders.

einmal SPENDEN-A
SPENDEN-B
SPENDEN-C

Ich möchte aber nicht jeden Monat die Formel ändern... so möchte ich die folgende Formel

=WENN(D7="SPENDEN-A";B7;"")
(Diese Formel habe ich bereits erhalten und die stimmt auch gut für meine Zwecke - DANKE)

Ich möchte die Formel einfach erweitern... Noch zusätzlich SPENDEN-B, SPENDEN-C als Text hinterlegen.

Wie geht das?

Danke

Jan



Antwort 7 von ThomasG

Dann verwende doch noch die ODER-Verknüpfung!!
Ich gehe mal davon aus, dass es noch anderen Text außer SPENDEN-x geben kann, von diesem schreibst Du aber nix. Es müsste also auch mit der Funktion LINKS() gehen:

=WENN(LINKS(B1;8)="SPENDEN-";A1;0)

Gruß
Thomas

Antwort 8 von Opa53

Zitat:
Ich habe also wie ich schon beschrieben habe...
Einen Betrag in A stehen (das sind immer positve Einnahmen!)
In Spalte B gebe ich diesen Einnahmen eine Beschreibung.
Das Ziel soll immer dasselbe sein... Den Betrag von A nach C kopieren.

Und wozu benötgst Du unter diesen Umständen bitteschön überhaupt die WENN-Funktion?
C1 =A1 und fertig.
Gruß
Opa


Antwort 9 von Jürgen Grahn

Warum nicht einfach ???

=WENN(B1="";"";A1)


Gruß Jürgen



Antwort 10 von Johannes Kaersch

Hi Jan,

für deine Aufgabe benötigts du eine verschachtelte Wenn-Funktion. Versuch's mal mit der:

=WENN(D7="SPENDEN-A";C7;WENN(D7="SPENDEN-B";C7;WENN(D7="SPENDEN-C";C7;"")))

Wenn du immer noch Probleme haben solltest, lass es mich wissen.

Gruß Johannes

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: