825 Aufrufe
Gefragt in Tabellenkalkulation von

Hallo,

ich soll eine Excel Tabelle erstellen um die Zeitzuschläge automatisch auszurechnen. Dazu würde ich dann eine Wennformel verwenden.

=WENN(UND(D14<=ZEIT(20;0;0);D14>=ZEIT(21;0;0));ZEIT(1;0;0);"")*WENN(UND(E14<=ZEIT(20;0;0);E14<=ZEIT(21;0;0));ZEIT(1;0;0);"")

Es soll halt eine Stunde extra berechnet werden wenn die Zeit zwischen 20 und 21 Uhr ist. (Eigentlich nur Samstags, aber das hab ich jetzt mal weggelassen)

So sieht die Tabelle aus:

Samstags Samstag Nachtarbeit Sonntags  Feiertage
Über- 13.00 20:00 21.00  0.00 
stunden - 20:00  - 21:00 - 6:00 - 24:00
Uhrzeit Schlüssel  anzurechn. x 30 % x 20%  x 20 % x  20 % x  25 % x  35 %
von bis von  bis nur Anzahl Stunden 15 21 21 21 19 94
00:00 00:00 00:00
00:00 00:00 00:00 00:00
00:00 00:00 00:00 00:00
20:00:00 22:00:00 02:00 02:00 02:00 #WERT!

Freue mich wenn ihr mir helfen könnt :)

34 Antworten

0 Punkte
Beantwortet von japfl177 Einsteiger_in (24 Punkte)

Danke :)

Ich habe nun begonnen neue Formel einzufügen. Bei einen anderen MA ergibt sich aber wieder am 09.01. der Fehler. So langsam steig ich auch nicht mehr durch bei der langen Formel frown

https://supportnet.de/forum/?qa=blob&qa_blobid=13104500806729367203

Liebe Grüße

+1 Punkt
Beantwortet von m-o Profi (19.4k Punkte)
Hallo,

ich hatte ja geschrieben, dass man die Formel mal überprüfen muss. Wie ist das mit den Zuschlägen?

Für welche Zeiten gibt es du Zuschläge, hier vor allem morgens bis 6.00 Uhr?

Gruß

M.O.
0 Punkte
Beantwortet von japfl177 Einsteiger_in (24 Punkte)
ja genau bis 6 Uhr. Oben in der Tabelle ist ja eine Erklärung. Danach richtet sich das alles.

Am 09.01. sollte es daher keinen Nachtzuschlag geben
0 Punkte
Beantwortet von m-o Profi (19.4k Punkte)
Hallo,

hier mal die überarbeitete Formel für die Spalte N. Einzufügen in N12 und soweit wie benötigt nach unten ziehen.

=WENN(B12="F";"";WENN(A12="Sonntag";0;WENN(UND(E12>=21/24;F12<=6/24);REST(F12-E12;1);WENN(UND(STUNDE(E12)>0;STUNDE(E12)<=6;F12<=6/24);F12-E12;WENN(UND(STUNDE(E12)>0;E12<=6/24;F12>6/24);6/24-E12;0))))+WENN(UND(F12>=21/24;G12<=6/24);REST(G12-F12;1);WENN(UND(STUNDE(F12)>0;F12<=6/24;G12<=6/24);G12-F12;WENN(UND(STUNDE(F12)>0;F12<=6/24;G12>6/24);6/24-F12;0))))

Gruß

M.O.
...