Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

SVERWEIS größer als





Frage

Hallo ich komme da mit einer Formel nicht weiter. Folgendes Problem : =VERGLEICH(D5;AE1:AE1000;1)+(ZÄHLENWENN(AD1:AD1000;D5)=1) AE 1 = 25 AE 2 = 50 AE 3 = 75 usw. AD 1 = 1 AD 2 = 2 AD 3 = 3 usw. gebe ich nun in zeile D5 74 ein wirft er mir 3 aus (richtig) 75 ein wirft er mir 4 aus (falsch es sollte 3 sein) 76 ein wirft er mir 4 aus (richtig) ich bitte um hilfe, danke Lisa

Antwort 1 von Lisa

ach noch was, wenn ich 24 eingebe sagt er mir #NV da hätte ich auch ganz gerne dann wenigstens eine 1 stehen.

danke Lisa

Antwort 2 von want2cu

Hallo Lisa,

ich habe mal dein Beispiel nachgestellt und erhalte folgende Ergebnisse, die aber nicht deinem Posting entsprechen:

ab
25 1
50 2
75 3
100 4

Prüfe bitte noch mal genau deine Angaben und erkläre doch mal, was du eigentlich erreichen willst. Du postest mit dem Titel SVERWEIS und benutzt 2 ganz andere Funktionen.

CU
want2cu

Antwort 3 von pelle

Hallo Lisa,

kann mich nur want2cu anschließen!

Bei 76 wirft er mir 3 aus!

Gib mal ein wenig mehr Infos zu dem, was Du erreichen möchtest!

Gruß
Pelle

Ps.: schick evtl. mal Beispieltabelle

@want2cu
Meld mich die Tage bei Dir!
gruss
pelle

Antwort 4 von Lisa

oh entschuldigung, hatte soviel mit den Formeln rumhantiert das sverweis ja gar nicht mehr in der Formel enthalten ist.
also absteigend AD AE
1 25
2 50
3 75
usw.

was meint ihr mit beispiel ?
die Formel ist
=VERGLEICH(D5;AE1:AE1000;1)+(ZÄHLENWENN(AD1:AD1000;D5)=1)

so und wenn ich in zeile D5 dann gehe und
74 eingebe wirft er mir 3 aus (richtig)
75 eingebe wirft er mir 4 aus (falsch es sollte 3 sein)
76 eingebe wirft er mir 4 aus (richtig)

was gibt es daran nicht zu verstehen ?
er soll mir bei 75 auch 3 anzeigen weils in AD und AE auch so gespeichert ist. alles andere macht er ja richtig. und das wenn ich in D5 nichts eingebe da #NV in der zeile wo er mir das immer nicht ganz korrekt wiedergibt, damit kann ich leben obwohl ich da gerne ein null stehen hätte wenn ich in D5 nichts eingebe.

Antwort 5 von want2cu

Hallo Lisa,

auch wenn du dein Posting einfach nur wiederholst, wird es dadurch nicht richtiger. Anstatt hier herumzupampen, solltest du dir lieber mal die Mühe machen, und die Antworten vernünftig lesen und deine eigenen Angaben aufgrund der Hinweise nochmals überprüfen.

Wenn man deine Formel benutzt, kommt eben nicht das heraus, was du behauptest.

Mit Beispiel habe ich die von dir angegebenen Wert gemeint.
Mit "nicht verstehen" müßtest du eigentlich selbst klarkommen, wenn du wirklich das in deiner Tabelle hast, was du hier postest. M.E. müßtest du leicht feststellen, das das nicht der Fall ist. pelle hat dir dies ja auch bestätigt.

Also: wenn du deinen Teil dazu beiträgst, dass dein Posting "in Ordnung" ist, wirst du hier auch Hilfe erhalten.
Ich äußere mich erst dann zu deiner Anfrage, wenn du die UNgereimtheiten geklärt hast.

BTW: eine "Anrede" und ein "Gruß" machen jegliches Posting freundlicher ;-)

CU
want2cu

Antwort 6 von pelle

Hallo Lisa,

also so ganz verkehrt liegt want2cu nicht!

Wenn wir Dein Problem verstanden hätten,
würden wir nicht nachfragen!

Problem 1:
Deine hinterlegten Formeln liefern bei uns ein anderes Ergebnis als bei Dir!!!

Problem 2:
Dein Hinweis:
"oh entschuldigung, hatte soviel mit den Formeln rumhantiert das sverweis ja gar nicht mehr in der Formel enthalten ist."
sollte Dir ein Hinweis sein, was hast Du noch geändert!!

Problem 3:
Man möchte Dir sicherlich helfen, aber es fehlen ein paar Informationen zu dem was Du mit dieser Formel erreichen möchtest!

Problem 4:
wir können nicht riechen, was Du als Ergebnis erwartest!
Mir ist Deine Formel ohne Hintergrundinformation unplausibel!!

Problem 5:
Deine Formel arbeitet korrekt!!

Also, ein paar Infos mehr wären sinnvoll!
Wiederholen bringt nichts!!!

gruss
pelle


Antwort 7 von want2cu

@pelle:

Lisas Formel arbeitet m.E. eben NICHT korrekt.

Wenn man sich mal in der Bearbeitungszeile den Formelteil +(ZÄHLENWENN(AD1:AD1000;D5)=1) mal mit der Funktionstaste F9 anzeigen läßt, wird das Ergebnis FALSCH ausgegeben. Das ist auch logisch, weil die Werte in der Spalte AD (1,2,3,4...) niemals dem Wert in Zelle D5 (24, 75,76...) entsprechen können.
Das bedeutet im Klartext: der zweite dieser Formel ist wie ein Kropf: vorhanden, aber völlig überflüssig.
Es wird immer nur der erste Teil der Formel ausgewertet. Auch das kann man leicht mit der Taste F9 in der Bearbeitungszeile testen, wenn man den betreffenden Formelteil vorher markiert.

Ich vermute mal, Lisa hat im Forum EXCELFORMELN gestöbert und die für eine einspaltige Lösung vorgesehene Formel falsch auf eine zweispaltige Tabelle umgebaut.

CU
want2cu


Antwort 8 von pelle

@want2cu

Der Hinweis unter Problem 5 war ironisch gemeint! :-)

Die Formel arbeitet korrekt!
Passt aber nicht mit dem gewünschten Ergebnis überein!

Was der Wunsch ist, ist immer noch ein Rätsel!

Das Rätsel kann nur Lisa lösen,

aber Lisa mag wohl nicht mehr!

gruss
pelle

Antwort 9 von want2cu

@pelle,

sorry, dass ich die Ironie nicht kapiert habe.

Ich war wohl zu sehr darauf fixiert,dass der zweite Formelteil völlig überflüssig ist, wie man ja beim Testen mit der F9-Taste (vorher den entsprechenden Teil der Formel komplett markieren) in der Bearbeitungszeile leicht feststellen kann.

Vielleicht haben ja wenigstens ein paar User etwas aus diesem ganzen Posting, wenn sie diese Möglichkeit zur Fehlersuche bei komplexen Formeln jetzt kennen ;-)

CU
want2cu



Antwort 10 von pelle

@want2cu

na ja, die Ironie war ja auch nicht unbedingt einfach zu erkennen!

Deine angesprochene Hilfestellung zur Fehlersuche hilft sicherlich einigen Usern!

Aber ich glaube, Lisa haben wir "verschreckt"!

Sorry Lisa, war nicht unser Ansinnen!
Aber ein paar Infos brauchen wir mehr um zu helfen!

gruss
pelle

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: